New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 24 users

Issue metadata

Status: Available
Owner: ----
EstimatedDays: ----
NextAction: ----
OS: Linux , Windows , Mac
Pri: 1
Type: Bug

Sign in to add a comment

Bookmarks import from Firefox fails

Project Member Reported by, Aug 18 2016

Issue description

Version: 54.0.2826.0
OS: Win7

With chrome://settings/importData (old settings UI since I can't find the import UI in new settings) when you import Firefox bookmarks (profile created by version 48), the following log appears:] places.sqlite sqlite error 1, errno 0: no such table: moz_bookmarks_roots, sql: SELECT root_name, folder_id FROM moz_bookmarks_roots

and the bookmarks from Firefox aren't imported into Chrome.

Looking at places.sqlite in the Firefox profile, there doesn't seem to be a moz_bookmarks_roots table in it. Also, indicates that this table has been removed. 

Labels: Hotlist-GoodFirstBug OS-Linux OS-Mac
Status: Available (was: Untriaged)
 Issue 646728  has been merged into this issue.

Comment 3 by, Sep 16 2016

Status: Started (was: Available) is under way to fix this and was also uploaded as an alternate solution.

@isherman to decide which approach he prefers.
FYI, anyone interested in working on this bug might also be interested in working on  bug 592239 .
I am also having this problem with Chrome 53.0.2785.143 and Firefox 49.

An additional problem is that the user is not notified about the failure via the normal user interface. Instead there is a popup saying "Success!" and showing a big green check mark. The only sign of failure is that the expected imported bookmarks folder did not appear. The error message is only going to be seen by those running Chrome from a terminal and paying attention to output there. Others may waste time wondering where the imported bookmarks might be found in Chrome.

Comment 6 by, Oct 4 2016

Right, the big success notification is pretty bad. What's likely happening is that Firefox's bookmark database changed and Chrome no longer finds it (i.e. succeeds at seeing it's not there and thus importing nothing..!).

As mentioned in #3, patches are under way to update FirefoxImporter::ImportBookmarks() in to understand the latest format.

+ewald FYI on poor UX for import failure shown as a big "success".

Comment 7 by, Oct 4 2016

Is there a more robust way we can handle this? Where we're not so tightly coupled/dependent on the structure of Firefox's bookmark database?

E.g. it would be great in the future if Firefox changes their bookmark database again for us to at least display an appropriate error message of some kind to the user.

+rpop desktop PM

Comment 8 by, Oct 5 2016

I guess what's hard to tell for a chrome reading the old format is whether there's truly nothing there or the format has moved sonewhwre else. Maybe a "nothing imported" UI would be interesting.
Please make sure you check the HTML file import option from FF to Chrome also.  This also does not work.  About 20% of my bookmarks get imported and the rest don't.  
Still doesn't work. Give me one less reason to migrate from Firefox to Chrome.

Comment 11 by, Nov 23 2016

Patch for this bug is coming soon. I had a few problems with adding it.
Project Member

Comment 12 by, Dec 1 2016

The following revision refers to this bug:

commit 75d731d50a0595ffc184075ef4c084109a967752
Author: Ilya Sherman <>
Date: Thu Dec 01 00:14:53 2016

[Import] Add a test file for testing Firefox import code.

The test file is too large to land via the CQ, so landing it manually.
This is in support of [ ].


Review URL: .

Cr-Commit-Position: refs/heads/master@{#435492}


Sure would like to try Chrome, but this is getting ridiculous.  This bug has been open since August 

Comment 15 by, Jan 22 2017

Labels: M-57
Status: Fixed (was: Started)
Fixed in Chrome 57 (currently Chrome Beta) according to the above commits.
Just tried it with Canary (58.0.3000.0), still doesn't work.
Still not working. Jeez, how hard can this be?
Bunch of family members all use firefox. They have indicated they are going to stop new browser development so all their users will probably switch to something, even Edge is they can't import bookmarks.  Gotta fix this!
This issue isn't a big deal for me because I can export from Firefox to HTML and then import that into Chrome. The only disadvantages are that it's more work and it doesn't import favicons.

In Firefox in the Bookmark menu, select Show All Bookmarks (Ctrl+Shift+B). Click on Import and Backup near the top, and then select Export Bookmarks to HTML. Then in Chrome, in the Bookmarks sub-menu select Bookmark Manager (Ctrl+Shift+O). Click on Organize at the top of the right pane and select Import bookmarks from HTML file.
Thank you Boris.  I had forgot about the exporting from Firefox as the option did not seem readily visible to me.  The Ctrl+Shift+B helped and now all is good. Thx again.
You're welcome!

This worked for me in Chrome 58.0.3012.1 canary SyzyASan importing bookmarks from Firefox Nightly 54.0a1 (2017-02-14) (64-bit).

Comment 22 Deleted

Same problem with Windows 10 although I had previously had no problem importing Firefox bookmarks into Chrome with an older computer running on Windows 7.  Chrome claims bookmarks are imported, but they are not.
same problem with me w10 and latest firefox and google chrome will not import all the settings and bookmarks

I did work around for bookmarks by exporting to html and importing but no passwords etc other important data :-(
Labels: -Pri-3 -M-57 Pri-2
Status: Unconfirmed (was: Fixed)
Ilya could you take a look? If this has regressed I would like to fix it for 65.
Owner: ----
Sorry, I don't have bandwidth to work on importer bugs currently.  I'd be happy to help with guidance and/or code reviews, but won't be able to drive the fix.
 Issue 774849  has been merged into this issue.
 Issue 690528  has been merged into this issue.
Labels: -Pri-2 Pri-1
Status: Available (was: Unconfirmed)
[Mac triage] shrike@/groby@: This seems like a real issue for people switching to Chrome, can you find someone to look into this?
I've just created a review for CL that should fix this issue:
 Issue 792831  has been merged into this issue.
Labels: Hotlist-ConOps
Adding conops hotlist for tracking.
A user reported that all Chrome 64, 65 and 66 cannot import Firefox successfully.

If the user can provide more debugging information on this, feel free to jump in to the thread.!topic/chrome/pg2zS5E4oM8
Will this ever get fixed? I won't switch over till I can import cookies, passwords etc., and from the looks of it this has been unresolved for more than a year.
Should I lose hope or is there a chance for it to get fixed reasonably soon?

Sign in to add a comment