New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 627037 link

Starred by 5 users

Issue metadata

Status: Duplicate
Merged: issue 568847
Owner: ----
Closed: Jul 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 3
Type: Bug



Sign in to add a comment

background-attachment: local option not working on Android

Project Member Reported by ramy...@samsung.com, Jul 11 2016

Issue description

<b>Version: <Kenneth, what is the frequency?></b>
<b>OS: <please tell me it's not XP></b>

What steps will reproduce the problem?
(1)Open https://jsfiddle.net/nLg2eo4j/2/
(2)Scroll the text within div.
(3)
What is the expected output?
Background image should also scroll along with text.

What do you see instead?
Background image is not scrolled along with text

Please use labels and text to provide additional information.

 

Comment 1 by ramy...@samsung.com, Jul 11 2016

If border-radius is added to the above testcase, it works. Looks like paint invalidation issue. (Ex: https://jsfiddle.net/nLg2eo4j/3/)

Comment 2 by ramy...@samsung.com, Jul 11 2016

Cc: flackr@chromium.org

Comment 3 by pp.k...@gmail.com, Jul 11 2016

Additional info: the same bug occurs in Chrome 51 on Windows 10.

Additional test cases: http://www.quirksmode.org/css/backgrounds-borders/attachment.html contains a test case with and without the border-radius.
Mergedinto: 568847
Status: Duplicate (was: Untriaged)
It fails when we promote the layer to composited scrolling. That is, it fails on HighDPI devices including Mac Retina displays.

Duplicate.

Sign in to add a comment