New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 10 users

Issue metadata

Status: Duplicate
Merged: issue 604033
Owner: ----
Closed: Jun 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug



Sign in to add a comment
link

Issue 621887: Typeof == null, let vs var

Reported by harryto...@gmail.com, Jun 21 2016

Issue description

UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.84 Safari/537.36

Steps to reproduce the problem:
Try running this in console:

for (let i=0; i<4917; i++) {console.log(typeof null === 'undefined')}
All false.

for (let i=0; i<4918; i++) {console.log(typeof null === 'undefined')}
All false except for one.

for (let i=0; i<10000; i++) {console.log(typeof null === 'undefined')}
4917 false
5083 true

for (let i=0; i<20000; i++) {console.log(typeof null === 'undefined')}
4917 false
15083 true

What is the expected behavior?
Always false.

What went wrong?
Not sure of the cause, but the problem is in the steps to reproduce.

Did this work before? N/A 

Chrome version: 51.0.2704.84  Channel: stable
OS Version: OS X 10.10.2
Flash Version: Shockwave Flash 22.0 r0
 

Comment 2 by mmenke@chromium.org, Jun 23 2016

Components: -Blink Blink>JavaScript
Looks fixed on Canary.

Comment 3 by mmenke@chromium.org, Jun 23 2016

 Issue 622628  has been merged into this issue.

Comment 4 by rnimmagadda@chromium.org, Jun 28 2016

Cc: rnimmagadda@chromium.org
Labels: Needs-Feedback
Unable to repro this issue on MAC (10.11.5) for Google Chrome Canary Version - 53.0.2781.2

Screen-recording is attached.

@harrytorry: Could you please update your Chrome Canary Version - 53.0.2781.2 and let us know your observations.

Thank you.
621887.mov
12.2 MB Download

Comment 5 by l446240525@gmail.com, Jun 28 2016

Please merge this into  issue 604033 

Comment 6 by rnimmagadda@chromium.org, Jun 28 2016

Labels: -Needs-Feedback
Mergedinto: 604033
Status: Duplicate (was: Unconfirmed)

Sign in to add a comment