Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 616124 IME pops up in the wrong place on Linux when DPI is != 96
Starred by 1 user Reported by ivan@ludios.org, May 31 2016 Back to list
Status: Duplicate
Merged: issue 475718
Owner:
Closed: Sep 2016
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug



Sign in to add a comment
UserAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.63 Safari/537.36

Steps to reproduce the problem:
Not sure if this will reproduce:

1. On Ubuntu 16.04 with xfce, `apt-get install --no-install-recommends ibus-gtk ibus-gtk3 ibus-qt4 ibus-mozc mozc-utils-gui`, set up ibus and mozc, switch to Japanese with input mode Hiragana.
2. Set DPI to 165 in xfce settings
3. Start Chrome
4. Type into the address bar and notice how the IME suggestions pop up in the wrong place.

What is the expected behavior?
IME pops up in the right place.

What went wrong?
IME pops up in the wrong place, as if Chrome is telling ibus the wrong coordinates that don't incorporate the scale factor that Chrome is using.

Did this work before? N/A 

Chrome version: 51.0.2704.63  Channel: stable
OS Version: Ubuntu 16.04
Flash Version: Shockwave Flash 21.0 r0

This appears to only affect Chrome; the IME box pops up in the right place when using other applications.

It pops up in the right location if I start Chrome with --force-device-scale-factor=1.0.

This worked fine a few days ago, but no longer works for reasons I don't know.
 
chrome-51-ime-165-dpi.png
36.6 KB View Download
chrome-51-ime-force-device-scale-factor-1.0.png
61.8 KB View Download
Comment 1 by ivan@ludios.org, May 31 2016
Oops, this should be closed as a duplicate of https://bugs.chromium.org/p/chromium/issues/detail?id=475718

It is really strange that it worked perfectly a few days ago (in Chrome 51), though.
Comment 2 by ivan@ludios.org, May 31 2016
Never mind on this ever working properly, I was probably just remembering how it worked on my lodpi laptop.
Owner: shuchen@chromium.org
shuchen: Do you agree this is bug 475718?
Mergedinto: 475718
Status: Duplicate
This should be a dup to issue 475718.
Sign in to add a comment