New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 15 users

Issue metadata

Status: Fixed
Owner:
Last visit > 30 days ago
Closed: Apr 2011
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 1
Type: Bug

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Audio.play latency

Reported by richt...@gmail.com, Oct 15 2010

Issue description

Chrome Version       : 8.0.552.0 dev
URLs (if applicable) : http://github.com/richtaur/chrome_audio and http://richtaur.com/misc/dev/chrome_audio/
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 4:
Firefox 3.x:
IE 7:
IE 8:

What steps will reproduce the problem?
1. Open `play_and_pause.html` in Chrome
2. Press the `load` button
3. Repeatedly press the `custom play` button
4. The sound should be playing repeatedly, but it doesn't always play when the button is pressed

What is the expected result?
I'd expect the audio to play immediately each time the "custom play" button is pressed.

What happens instead?
The sound does not always play. Sometimes it is delayed before playing.
 
Labels: -Area-Undefined Area-Internals Feature-Media
Labels: -Area-Internals Area-WebKit Mstone-9 OS-All
Status: Available
Could be related to our prerolling logic.

Which OS are you using?
Labels: -Mstone-9 Mstone-10
Status: Assigned

Comment 4 by sergeyu@google.com, Dec 2 2010

This is probably because we don't flush audio buffers when pause() is called.

Comment 5 by kerz@chromium.org, Dec 9 2010

Labels: -Mstone-10 MovedFrom-10 Mstone-11
P2 bugs with an owner that are not marked as started are being automatically moved to mstone:11.
Labels: Mstone-12 Pri-1

Comment 8 by davej@chromium.org, Apr 18 2011

Owner: scherkus@chromium.org
Status: Fixed
This is fixed now with: http://codereview.chromium.org/6822019/

Committed: http://src.chromium.org/viewvc/chrome?view=rev&revision=81670

Labels: ImportantForGames
Project Member

Comment 10 by bugdroid1@chromium.org, Oct 13 2012

Blocking: -chromium:59691 chromium:59691
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Blocking: -chromium:59691
Project Member

Comment 12 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-WebKit -Feature-Media -Mstone-12 Cr-Content Cr-Internals-Media M-12
Project Member

Comment 13 by bugdroid1@chromium.org, Mar 13 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Project Member

Comment 14 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink

Sign in to add a comment