New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 571297
Owner: ----
Closed: Feb 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 2
Type: Compat



Sign in to add a comment
link

Issue 584909: Zoom regression window.innerWidth(Height)/window.pageX(Y)Offset + regression position:fixed

Reported by juw...@gmail.com, Feb 6 2016

Issue description

Example URL:

Steps to reproduce the problem:
Hello,

on newest Chrome mobile Android the browser stopped to correctly report window.innerWidth and window.innerHeight values + window.pageXOffset and window.pageYOffset
if user zooms the content, so it is impossible to simulate position:fixed.
However the position:fixed was broken few months ago, I just did not report this issue, since I have workarounded it with innerWidth/pageXOffset in zoomed state.
However for today there is no anymore method left to correctly display elements while zooming the content on mobile phone device used on Chrome.
In comparing FireFox has no such issues, and Chrome worked fine with all elements a while ago, but not anymore.
Please fix the regression!

What is the expected behavior?

What went wrong?
everything

Does it occur on multiple sites: N/A

Is it a problem with a plugin? N/A 

Did this work before? N/A 

Does this work in other browsers? N/A 

Chrome version: Some new one  Channel: n/a
OS Version: unsure
Flash Version:
 

Comment 1 by juw...@gmail.com, Feb 7 2016

I assume, the position:fixed regression is the new virtual view port.
Any way to disable it by css/javascript/viewport setting?
However wrong window.innerWidth/Height is worst regression, since I can not anymore simulate and position my elements according to physical screen.
May be there is for Chrome other settings than innerWith/pageXOffset to position/resize elements to make them fixed in physical screen rather than virtual viewport?

Comment 2 by juw...@gmail.com, Feb 9 2016

To summarize,

checked all possible values, no changes, while the content is zoomed the 
innerWidth/Height and pageXOffset do not change at all while scrolling or change only sporadically.
No more any reliable way to recognize zoom level, no support for device-fixed.
Chrome got with last update unusable.
Developers, where the hell do you look, when creating such bugs?

Comment 3 by rsgav...@chromium.org, Feb 10 2016

Labels: Needs-Feedback
Hi, Can you provide more details like
Device Model:
OS:
Chrome version:
Screenshot or Video of the issue:
for further triaging?

Comment 4 by juw...@gmail.com, Feb 11 2016

Hello,

OS: Android 5.1.1
Chrome: 48.0.2564.95
Device: Samsung Galaxy S6 edge+

You can compare that link on Android FireFox/iOS Safari with actual Android Chrome
https://jsfiddle.net/k9kwvkLw/2/embedded/result/

If you still persist on screenshot, please go firstly sure, the link did not suffice to desribe the issue.

Comment 5 Deleted

Comment 6 by juw...@gmail.com, Feb 11 2016

PPS: just zoom in and scroll, if everything works fine, the div element should autoresize and autoreposition it self so that it fits into middle of visible viewport.
All known browsers, (iOS Safari, Android FF, MobileIE 11) work fine with that code, but not anymore Chrome (even if it did before in old version)

Comment 7 Deleted

Comment 8 by juw...@gmail.com, Feb 11 2016

http://www.filedropper.com/c_13

Just same code as separate downloadable file

Comment 9 by rsgav...@chromium.org, Feb 11 2016

Labels: -Needs-Feedback
Owner: tedc...@chromium.org
Status: Assigned

Comment 10 by tedc...@chromium.org, Feb 11 2016

Cc: aelias@chromium.org bokan@chromium.org
Labels: Cr-Blink-Layout
Owner: ----
Status: Available

Comment 11 by bokan@chromium.org, Feb 12 2016

Mergedinto: 571297
Status: Duplicate

Sign in to add a comment