Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 5729 RTL: TabStrip context menu should be positioned properly, If window is not maxmized.
Starred by 2 users Project Member Reported by venkataramana@chromium.org, Dec 19 2008 Back to list
Status: Verified
Owner:
User never visited
Closed: Apr 2009
Cc:
Components:
NextAction: ----
OS: All
Pri: 3
Type: Bug
RTL

Restricted
  • Only users with Commit permission may comment.


Sign in to add a comment
Happens in both ToT, Chrome(r7133) and Chromium (r7307)

What steps will reproduce the problem?
1. Launch Chrome/Chromium for any RTL (arabic is fine) (make sure your
browser window is not maximized)
2. Right click on 1st tabstrip.
3.

What is the expected output? 
The Context menu should be positioned properly inside of the window.

What do you see instead?
The context menu is positioned entirely out side of the window.
(Screenshot attached.)

Please note, We honor the coordinates the context menu, in case of
maximized window.

 
RTL_TabStripContextMenu.PNG
67.1 KB View Download
Mergedinto: 5724
Status: Duplicate
I guess this is similar to 5724.
Mergedinto: -5724
Status: Untriaged
This bug talks about Tabstrip context menu. The other bug talks about window's
context menu.

-Venkat.
Comment 3 by xlyuan@chromium.org, Dec 30 2008
Labels: I18N RTL
To make it more clear, RTL Chrome draws the pop up dialog from the right of where we
click the mouse, Hebrew Firefox and Hebrew Notepad are doing the same as Chrome.

But when right click on Hebrew OS or Hebrew IE7, the pop up window was drawn from the
left of where we click the mouse.


Comment 4 by xji@chromium.org, Dec 30 2008
Is the expected behavior that
right click on tabstrip context menu (and window's context menu) should pops up a 
dialog from the left of where we click the mouse?

And it does not matter whether the pop-up dialog is beyond the window area.
In LTR Chrome, right click the last tabstrip might pop-up a dialog beyond the window 
area, as long as there is enough space in the screen. If there is not enough space in 
the screen, the dialog is re-positioned.


Comment 5 by xlyuan@chromium.org, Dec 30 2008
Yes, I think the context menu pops up at the left of where we click the mouse is
correct. 

I just checked the Hebrew Adobe Acrobat Reader 9.0, it is doing the same as Chrome,
plus Hebrew Firefox and Hebrew Notepad also have this problem, making the priority of
this bug is not that high.

But Idan, can you please comment?

Comment 6 by idana@chromium.org, Dec 30 2008
It looks like the behavior of RTL applications (including native Windows apps like 
the Hebrew version of the file explorer) is not very consistent, both for their own 
context menus and for the system menu. Therefore, it is hard to say whether or not we 
should change Chrome's current behavior. I agree that the priority of this bug should 
be pretty low.
Labels: -Pri-2 Pri-3 Mstone-X
Status: Available
Comment 9 by xji@chromium.org, Jan 22 2009
Status: Assigned
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=13888 

------------------------------------------------------------------------
r13888 | xji@chromium.org | 2009-04-16 15:28:35 -0700 (Thu, 16 Apr 2009) | 7 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/views/tabs/tab.cc?r1=13888&r2=13887

This CL fixes issue 5729 - RTL: TabStrip context menu should be positioned properly, If window is not maxmized.
(http://crbug.com/5729).

The fix is to popup tabstrip context menu from the left of the click in RTL UI.

Without the fix, tabstrip context menu always popup from the right of the click.
Review URL: http://codereview.chromium.org/73021
------------------------------------------------------------------------

Comment 11 by xji@chromium.org, Apr 16 2009
Status: Fixed
fixed in r13888
Status: Verified
Verified in 2.0.175.0 (Developer Build 13939).
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=15133 

------------------------------------------------------------------------
r15133 | mal@chromium.org | 2009-05-01 22:42:24 -0700 (Fri, 01 May 2009) | 12 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/172/src/chrome/browser/views/tabs/tab.cc?r1=15133&r2=15132

Merge r13888.

This CL fixes issue 5729 - RTL: TabStrip context menu should be positioned properly, If window is not maxmized.
(http://crbug.com/5729).

The fix is to popup tabstrip context menu from the left of the click in RTL UI.

Without the fix, tabstrip context menu always popup from the right of the click.

BUG=  5729 
TBR= xji
Review URL: http://codereview.chromium.org/100294
------------------------------------------------------------------------

Labels: -I18N bulkmove Feature-I18N
Happens in both ToT, Chrome(r7133) and Chromium (r7307)

What steps will reproduce the problem?
1. Launch Chrome/Chromium for any RTL (arabic is fine) (make sure your
browser window is not maximized)
2. Right click on 1st tabstrip.
3.

What is the expected output? 
The Context menu should be positioned properly inside of the window.

What do you see instead?
The context menu is positioned entirely out side of the window.
(Screenshot attached.)

Please note, We honor the coordinates the context menu, in case of
maximized window.
Project Member Comment 15 by bugdroid1@chromium.org, Oct 13 2012
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 16 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Feature-I18N Cr-UI-I18N
Project Member Comment 17 by bugdroid1@chromium.org, Mar 20 2013
Labels: -Cr-UI-I18N Cr-UI-Internationalization
Sign in to add a comment