New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 40 users
Status: Fixed
Owner:
Closed: Jan 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux , Windows , Mac
Pri: 2
Type: Bug



Sign in to add a comment
Web pages render incorrectly (randomly irregular black blocks and misplacement)
Reported by chawye...@gmail.com, Oct 24 2015 Back to list
UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36

Example URL:
http://live.bilibili.com/ , http://store.steampowered.com/app/365670/ , etc.

Steps to reproduce the problem:
1. Update or new install Chrome to Stable 46 version
2. Just surf the websites
3. Irregular black blocks or contents misplacement would occur
4. If mouse over those black blocks, black blocks may disappear or not
5. If scroll the page, black blocks may also disappear or not
6. Switch between tabs may cause black blocks

----------

I failed to reproduce this on my friends' laptop. But I found that there are other users also suffer this issue. e.g. http://bbs.kafan.cn/thread-1858679-1-1.html (Chinese site)

What is the expected behavior?

What went wrong?
The pages render incorrectly, with randomly irregular black blocks and misplacement.

Does it occur on multiple sites: Yes

Is it a problem with a plugin? No 

Did this work before? N/A 

Does this work in other browsers? Yes 

Chrome version: 46.0.2490.80  Channel: stable
OS Version: 10.0
Flash Version: Shockwave Flash 19.0 r0

I have searched the releated issue. I posted this as a reply in: 

https://code.google.com/p/chromium/issues/detail?id=142038#c136

And Anon told me to toggle the flag chrome://flags/#disable-slimming-paint 

https://code.google.com/p/chromium/issues/detail?id=142038#c139

The problem is gone after I turning on the chrome://flags/#disable-slimming-paint, means disable slimming paint. I made a period of testing.

And it might be related to  crbug.com/524354  or not, I don't know. ( crbug.com/142038#c137 )

---

The issue is still exist in Chrome 46.0.2490.80. I don't know whether it has been fixed in dev or other future versions, so I post this as a new issue for archiving.
 
misplacement2.PNG
172 KB View Download
blocks1.png
127 KB View Download
misplacement1.png
114 KB View Download
blocks.gif
4.9 MB View Download
blocks2.png
276 KB View Download
Comment 1 by tkent@chromium.org, Oct 26 2015
Labels: -Cr-Blink Cr-Internals-GPU
Comment 2 by Deleted ...@, Oct 27 2015
This is corrupting a number of our webpages (which use really simple underlying coding). Try this quite basic long page here and scroll up /down to see it break up (and then reload and try again)

http://www.g0mwt.org.uk/meetings/past15-oct-dec/#October

Chrome 46.0.2490.80 - but fine in all other browsers we have

regards

 Murray 


agm-bug.jpg
237 KB View Download
Comment 3 by Deleted ...@, Oct 27 2015
Reading elsewhere I suggest this is related the 'Slimming Paint' problems - and not hardware acceleration (I tried toggling hardware acceleration without any great effect)

Murray
Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36

Noticed this same thing after the update last week. Just typing this comment, switching tabs and coming back, and scrolling up and down the black boxes and miss-placed sections appeard. 
Cc: durga.behera@chromium.org
Labels: Needs-Feedback
Unable to reproduce this on Win 10 using Latest stable M 46.0.2490.80.Could you please review the attached screen cast and update further.
547356_Oct_28.mp4
2.9 MB Download
Also seen for version 46.0.2490.80 on OSX Yosemite
Comment 7 by Deleted ...@, Oct 31 2015
Also seen for version 46.0.2490.80 on Surface Pro 3 /Windows10
Comment 8 by btre...@att.net, Nov 1 2015
Happening on my old XP sp3
Web Shot.docx
629 KB Download
Cc: hendr...@chromium.org
Could anyone paste the chrome://gpu and follow the comment # 25 of  Issue 516232 , to help further triage it.

cced to you looking at previous work related to this on  Issue 516232 .
Could you please take a look into this ant update further.
Thanks in advance..!
Attached chrome://gpu output
chrome-gpu.txt
2.5 KB View Download
I did as requested (Comment #25) and saw no changes in terms of the missing repaints after enabling  --use_virtualized_gl_contexts on OSX Yosemite - although it might've made it slightly less frequent.

Chrome gpu attached after enabling it.  
gpu.html
33.7 KB View Download
Cc: -hendr...@chromium.org
Labels: -Needs-Feedback M-48
Owner: hendr...@chromium.org
Status: Assigned
hendrikw@ : Assigned to you based on prior work done on  issue 516232 ,could you please look into the issue comments #10 and #11, if it could help you for further triage it.
Note that on OSX Yosemite enabling the "disable-slimming-paint" flag does not fix the issue. If it helps any then I've seen very similar render/repaint issues in older versions of Chrome and they do seem very related to the use of CSS transform and other hardware accelerated CSS properties. 
It is very easy for me to reproduce and I'm happy to help test ideas if you can not. 

http://tobiasahlin.com/spinkit/ and then choosing the last loader will reproduce it consistently no matter which flags I have turned on. Attached is a video of that spinner.

chrome_46_render_issue.mov
161 KB Download
Comment 14 by Deleted ...@, Nov 4 2015
I've had this problem appear with Chrome 46.0.2490.80 on both Linux and OSX, so it seems to be cross-platform. 
This bug is appearing on some of our sites on Chrome 46.0.2490.80 (OSX El Capitan and Windows 10). Definitely cross-platform.
Cc: hendr...@chromium.org danakj@chromium.org vmp...@chromium.org
Owner: ----
Status: Available
I don't have cycles to look at this at the moment, and I don't think this is related to the other bugs assigned to me.

I have seen this happen in stable (46.0.2490.80), specifically when switching back to a tab.

It looks like the tiles are being purged when another tab needs more memory, and not being re-rastered correctly when we switch back?
I just tested on Chrome Canary which does not show any of the repaint issues i'm seeing in 46 (OSX Yosemite)
I'm seeing similar as #16 on linux stable. But can't repro on a more recent build. So.. I think that will fix itself.

I tried reverting fixes to partial raster and enabling it to see if there was something to merge, but that didn't cause it to start happening on tot.. so I don't know.

Is there any part of this bug that does happen on canary?
I was actually mistaken - the bug is still there on Canary - just not on the test site I was using. Disabling "hardware accelleration" in 46 and Canary completely fixes the issue for me - but of course makes hardware accelleration disabled...
Should've of course included a site that shows the issue in Canary: trello.com - open a board and start moving any ticket or scroll the board - it'll jitter like crazy.
Can you define "jitter" here? The original bug was about black appearing in chunks inside the page contents.
- Certain parts of the page would disappear and reappear when scrolling
- When dragging something that has a transform and box-shadow (Trello tickets) the area that required repaint would have horizontal and diagonal lines sort of randomly in the area containing the box-shadow.

Before posting before I reproduced it - now I went to make a screencast and those issues were gone - but still a repaint issue is present which I've captured in the attached video. No idea wether this is still related to the original issue which at least to me also looked a lot like repaint issues.
trello_missing_repaints.mov
4.3 MB Download
Labels: Hotlist-ConOps
+ConOps as this is also reported through user channels and the forum
Comment 24 by eliae@google.com, Nov 11 2015
Here are more examples from JA users: 

Version: Chrome 46
OS: Mac OS X 10.6.8
Device: iMac Mid2011
Forum thread: https://productforums.google.com/forum/#!topic/chrome-ja/AtQJ7g4aqEM
Tweet: https://twitter.com/stcamel/status/662203169598910464, https://twitter.com/stcamel/status/663202722066247681

スクリーンショット 0027-11-11 16.20.35.png
258 KB View Download
スクリーンショット 0027-11-11 16.20.47.png
78.8 KB View Download
スクリーンショット 0027-11-11 16.21.00.png
410 KB View Download
Comment 25 by tin...@google.com, Nov 12 2015
Owner: vmi...@chromium.org
vmiura@, this is on GPU, can you pls triage this and assign to an owner? Thanks!
I've seen on linux stable sometimes when I switch tab, parts of tiles are rastered as black. I can't reproduce this on beta or tot.

I run in software compositing on linux, which makes me think it is a partial raster bug that was fixed in beta channel. But I tried reverting that fix on ToT (and forcing partial raster on in the renderer) and it didn't make it reproduce there. So maybe not.

The chrome://gpu in #10 is software raster, gpu compositing, which would not trigger that bug.. so maybe it's unrelated.

The good news is this should fix itself in the next beta if it's the same bug (hopefully). There might be something we can merge to stable to fix this in the meantime assuming there will be future stable builds, if it is in fact due to partial raster, though chrome://gpu above suggests otherwise.

Also some of the reports in here are not what the title of the bug is (ie using wrong texture backing when drawing a tiles?) Maybe it's the same bug, or maybe it's not..

This bug is tagged as M-48, why is it tagged as such? It sounds like this started in 46.

Has anyone reproduced this on beta channel M-47?
Cc: ericrk@chromium.org
Comment 28 by derg0...@umn.edu, Nov 13 2015
Have end user experiencing black boxes randomly popping up in gmail after switching tabs. 

Attempted the following: reinstall chrome, remove/disable plugins, update google talk plugin(reinstall), disable/re-enable hardware acceleration.

User is on windows 7, using chrome version 46.0.2490.86, and still experiencing this issue. 

Please update with any suggestions. 

Thank you, 

Lidiya D.
Cc: junov@chromium.org
+junov in case this looks familiar
Hi all!

I'm participating in Chrome-es forum as UD. In the last month we've seen a lot of topics with this issue. There we are using the follow workarround:

1- Deactivating the Hardware aceleration
2- Inactivating chrome://flags/#disable-slimming-paint flag

This two workarrounds often fixes the problem.
I hope this can bring some light to the issue.
Labels: -OS-Windows OS-Linux
Labels: OS-Windows OS-Mac
Cc: ccameron@chromium.org
Per #19 this issue is happening in Canary on Mac.
If this is Mac-only, then it is likely due to the CoreAnimation renderer, which landed just yesterday. I can disable it with a 1-line true->false change (once I repro this).
Let's make it a different bug then if so
Re #34, going through this bug more, I don't think this is the CoreAnimation renderer -- it's only on Canary (48 or 49 depending on where we're branching) and only on OS X 10.9 and above (not 10.6 shown earlier).
#34: Comment #19 was from last week on Monday.
Comment 38 by arufa...@gmail.com, Nov 18 2015
I've seen the same bug on both Windows and Mac. My Mac running on MacBookAir3,1 sees this problem everyday. I also sees this frequently on Windows as well.
I am currently assuming that beta is going to fix this bug, cuz I am not able to reproduce it on beta linux, but I can on stable (software compositing).

I really want to hear if people can reproduce this on beta channel, and what their about:gpu page says. If there's a bug in Mac Canary my feeling is it is probably something different because I can't reproduce the linux (and presumably windows?) bug on beta or ToT.

(see #26)
Comment 40 Deleted
Comment 41 by Deleted ...@, Nov 19 2015
Hello everyone

This incident has been treated in Chrome in Spanish forum

https://productforums.google.com/forum/#!category-topic/chrome-es/g_PraI2gOaE

Where a user has reported had this issue and after disabling the slimming-paint

chrome://flags/#disable-slimming-paint


can solve this issue, maybe this action can help to solve this incident en some cases and similarly, try in first instance disabling the hardware acceleration and check if the software, the S.O. or the graphic drivers are full upgraded.


Regards


Andrés Tirado
Comment 42 by Deleted ...@, Nov 19 2015
Have attempted both disabling slimming paint and hardware acceleration. Still facing the same issue.
Same issue here. Happenning on Windows 7 and Windows 10, hardware acceleration turned off
Cc: chrishtr@chromium.org
There may be multiple issues here.  Some cases above seem solved by disabling slimming paint, some not.
Comment 45 by arufa...@gmail.com, Nov 24 2015
I just hit this problem 3 consecutive times with 3 tabs. I'm running on M46.

I'm not sure why this bug is still marked as M48 given that so many reports are from M46.

Google Chrome	46.0.2490.86 (Official Build) (64 ビット)
変更履歴	e8926f681fbb840b4f389e7e692343d4505722ce-refs/branch-heads/2490@{#560}
OS	Mac OS X 
Blink	537.36 (@e8926f681fbb840b4f389e7e692343d4505722ce)
JavaScript	V8 4.6.85.31
Flash	(無効)
ユーザー エージェント	Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.86 Safari/537.36
コマンドライン	/Applications/Google Chrome.app/Contents/MacOS/Google Chrome --enable-avfoundation --enable-avfoundation --flag-switches-begin --disable-gpu-rasterization --flag-switches-end
Labels: -M-48 M-46
Any chance you can try beta channel and see if it happens there?
Cc: brajkumar@chromium.org
 Issue 551340  has been merged into this issue.
is this being ignored as too difficult now
 Issue 560803  has been merged into this issue.
We were hoping to merge https://code.google.com/p/chromium/issues/detail?id=524354#c28 but as you can see we'll have to wait for 47.

I have yet to see any reports of this on beta so hoping that it is fixed there.
Owner: danakj@chromium.org
Labels: Hotlist-Polish
47 went to stable. Have heard nothing of problems in 47 yet.
danakj: I'll report back if I see a problem.
Comment 55 by derg0...@umn.edu, Dec 7 2015
Upgraded user to 47 and have not heard any issues yet.
Status: Fixed
47 has been out for a while, and still hearing nothing. Hope for more of the same.
I have seen this on 47 during page renders after switching tabs or windows, but so far it has always quickly resolved itself.
Can you attach your chrome://gpu contents when you do see it happen? And if you have any steps to reproduce it, that'd help a lot.

I used to see this all the time on 46 on my dev machine, but don't with 47 yet.
It is much less common now...

chrome://gpu attached.
gpu.html
40.0 KB View Download
Cc: dyen@chromium.org reve...@chromium.org
Thanks, noting that the gpu.html says this is using GPU compositing - so one copy worker pool.

If it happens and you're able to capture a screenshot or something that would be helpful too, the more the better really.

Are the visual effects always black squares? Or other corrupted or misplaced content?

It's possible there's some sync point bugs in our new worker context use for one copy.. that's a different bug but still a bug of course.
I'll see what I can do.

They are often black squares, but occasionally corrupted content, I think. Not sure since 47...
Ok, so it happened just now in an incognito window.
gpu.html
3.1 MB View Download
Screenshot from 2015-12-20 01-04-32.png
560 KB View Download
I got hit again by a big one. Notice that the page is still interactible and updates elements that change on hover.
Screenshot from 2015-12-29 15-57-25.png
246 KB View Download
gpu.html
413 KB View Download
Screenshot from 2015-12-29 15-56-23.png
258 KB View Download
Screenshot from 2015-12-29 15-57-23.png
247 KB View Download
Status: Assigned
Comment 65 by sdf...@gmail.com, Jan 11 2016
This issue has been resolved on Chrome 47; I'm running Windows XP Professional. I can confirm it's fixed as I suffered black box issues for over a month with Chrome 46.
Status: Fixed
@#63 that looks like a different bug, there's a lot of "[24419:24419:1229/155657:ERROR:gles2_cmd_decoder.cc(13099)] : [.CompositorWorker-0x272545b45a80]GL ERROR :GL_INVALID_VALUE : glCopySubTextureCHROMIUM: source texture has no level 0" in your about gpu. I'm going to open another bug.
Cc: kavvaru@chromium.org
 Issue 516152  has been merged into this issue.
Sign in to add a comment