New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 54307 link

Starred by 3 users

Issue metadata

Status: Duplicate
Owner:
Email to this user bounced
Closed: Sep 2010
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug
M-6

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Chrome: Crash Report - Stack Signature: MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const &)-dbae044f_51feb5ec_4588b7b1_9096b278_c38f23dd

Project Member Reported by k...@google.com, Sep 2 2010

Issue description

This appears to the the topcrash in .53 so far...

Product: Chrome
Stack Signature: -3019E6
New Signature Label: MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const &)
New Signature Hash: dbae044f_51feb5ec_4588b7b1_9096b278_c38f23dd

Report link: http://go/crash/reportdetail?reportid=816abc284f16d468

Meta information:
Product Name: Chrome
Product Version: 6.0.472.53
Report ID: 816abc284f16d468
Report Time: 2010/09/02 20:04:53, Thu
Uptime: 12 sec
Cumulative Uptime: 0 sec
OS Name: Windows NT
OS Version: 5.1.2600 Service Pack 3
CPU Architecture: x86
CPU Info: GenuineIntel family 15 model 6 stepping 5

 

Comment 1 by kerz@chromium.org, Sep 2 2010

Labels: Crash-TopCrash

Comment 2 by kerz@chromium.org, Sep 3 2010

Comment 3 by kerz@chromium.org, Sep 3 2010

Labels: OS-Windows

Comment 4 by mal@google.com, Sep 3 2010

Status: Assigned
Huan, I think you were telling me earlier about looking into recent MessageLoop crashes. If you don't know anything about this crash, maybe you can suggest a good owner?


I don't have access to VPN now, but this sounds like a duplicate of 53909.

I had started looking at 53909 that before going on vacation... Basically it is a crash running some unknown (probably already deleted) task, un some unknown message loop.

There wasn't information to go off in the crash dumps, I can't even tell what logical thread the crash is happening on, however based on the thread order it looks to me like the child process launcher thread.

Since we had the crash in the canaries, we can push some instrumentation into ToT to get some more data from the next canary build (would be good to know what thread the crash happens on, and even better what the task was and who posted it.)

Comment 6 by huanr@chromium.org, Sep 4 2010

I will see whether I can add some instrument code to ToT.

Comment 7 by huanr@chromium.org, Sep 8 2010

http://src.chromium.org/viewvc/chrome?view=rev&revision=58786

Adding debugging info for thread name.
This may not provide enough information to analyze the bug,
but it is a start with minimal impact.

BUG= 54307 
TEST=none

Review URL: http://codereview.chromium.org/3337012

------------------------------------------------------------------------
r58786 | huanr@chromium.org | Tue Sep 07 20:46:53 PDT 2010
Changed paths:
 M /trunk/src/base/thread.cc
Adding debugging info for thread name.
This may not provide enough information to analyze the bug,
but it is a start with minimal impact.

BUG= 54307 
TEST=none

Review URL: http://codereview.chromium.org/3337012
------------------------------------------------------------------------

Comment 9 by kerz@chromium.org, Sep 9 2010

This is the topcrash of .55 as well.
Mergedinto: 53909
Status: Duplicate
Mergedinto: -53909
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=59178

------------------------------------------------------------------------
r59178 | eroman@chromium.org | Fri Sep 10 17:53:55 PDT 2010

Changed paths:
 M http://src.chromium.org/viewvc/chrome/trunk/src/base/thread.cc?r1=59178&r2=59177&pathrev=59178

Revert 58786 - Adding debugging info for thread name.

This temporary instrumentation has already yielded the intended data, so it is no longer necessary.

BUG= 54307 

Review URL: http://codereview.chromium.org/3337012

TBR=huanr@chromium.org
Review URL: http://codereview.chromium.org/3322020
------------------------------------------------------------------------
Labels: -Crash bulkmove Stability-Crash
This appears to the the topcrash in .53 so far...

Product: Chrome
Stack Signature: -3019E6
New Signature Label: MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const &)
New Signature Hash: dbae044f_51feb5ec_4588b7b1_9096b278_c38f23dd

Report link: http://go/crash/reportdetail?reportid=816abc284f16d468

Meta information:
Product Name: Chrome
Product Version: 6.0.472.53
Report ID: 816abc284f16d468
Report Time: 2010/09/02 20:04:53, Thu
Uptime: 12 sec
Cumulative Uptime: 0 sec
OS Name: Windows NT
OS Version: 5.1.2600 Service Pack 3
CPU Architecture: x86
CPU Info: GenuineIntel family 15 model 6 stepping 5
Project Member

Comment 13 by bugdroid1@chromium.org, Oct 13 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 14 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-Internals -Mstone-6 Cr-Internals M-6
Project Member

Comment 15 by bugdroid1@chromium.org, Mar 13 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue

Sign in to add a comment