New issue
Advanced search Search tips

Issue 526058 link

Starred by 3 users

Issue metadata

Status: WontFix
Owner: ----
Closed: Sep 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 2
Type: Bug



Sign in to add a comment

Widevine CDM not supported on Android WebView

Reported by pierre.g...@gmail.com, Aug 28 2015

Issue description

Example URL:
http://shaka-player-demo.appspot.com/?dash;asset=assets/oops_cenc_pssh.mpd

Steps to reproduce the problem:
1. Create an simple APK with a Webview set with Javascript enabled
2. Open on this WebView the URL to reproduce the problem to play the Widevine content with shaka-player
3. Click on "Load Stream" 

What is the expected behavior?
The playback starts normally at the beginning of the video.

What went wrong?
The playback does not start properly and the console shows an Player Error related to the mounting of the Widevine CDM: "DOMException: None of the requested configurations were supported."

Did this work before? No 

Is it a problem with Flash or HTML5? HTML5

Does this work in other browsers? N/A 

Chrome version: 44.0.2403.157  Channel: stable
OS Version: 5.1.1
Flash Version:
 
Screen Shot 2015-08-28 at 13.20.39.png
221 KB View Download
Labels: Cr-Mobile-WebView wv-te-triaged
Cc: ddorwin@chromium.org
Labels: -Cr-Internals-Media Cr-Internals-Media-Encrypted
Cc: xhw...@chromium.org
Cc: torne@chromium.org
EME with Widevine is supported in WebView on Lollipop and later. The embedder must implement http://developer.android.com/reference/android/webkit/WebChromeClient.html#onPermissionRequest(android.webkit.PermissionRequest) and grant http://developer.android.com/reference/android/webkit/PermissionRequest.html#RESOURCE_PROTECTED_MEDIA_ID (based on user's choice if appropriate for the application).

Comment 5 by torne@chromium.org, Sep 1 2015

Status: WontFix
Sounds like you just need to handle the permission request. If that still doesn't work, post the test code you are using and we can reopen this.

Comment 6 by dude8...@gmail.com, Apr 13 2016

I was having a similar problem and I tried what comment 4 said. Which got me passed that error, but now I get this one (on API 23):

04-12 19:23:18.437 16614-16648/? E/cr_MediaCodecUtil: Failed to create MediaCodec: video/x-vnd.on2.vp8, isSecure: true
                                                      java.io.IOException: Failed to find matching codec OMX.qcom.video.decoder.vp8.secure, error 0x80000000
                                                          at android.media.MediaCodec.native_setup(Native Method)
                                                          at android.media.MediaCodec.<init>(MediaCodec.java:1670)
                                                          at android.media.MediaCodec.createByCodecName(MediaCodec.java:1651)
                                                          at org.chromium.media.MediaCodecUtil.createDecoder(MediaCodecUtil.java:259)
                                                          at org.chromium.media.MediaCodecUtil.canDecode(MediaCodecUtil.java:209)

and 

04-12 19:23:18.571 16614-16648/? E/cr_MediaCodecUtil: Failed to create MediaCodec: video/x-vnd.on2.vp9, isSecure: true
                                                      java.io.IOException: Failed to find matching codec OMX.google.vp9.decoder.secure, error 0x80000000
                                                          at android.media.MediaCodec.native_setup(Native Method)
                                                          at android.media.MediaCodec.<init>(MediaCodec.java:1670)
                                                          at android.media.MediaCodec.createByCodecName(MediaCodec.java:1651)
                                                          at org.chromium.media.MediaCodecUtil.createDecoder(MediaCodecUtil.java:259)
                                                          at org.chromium.media.MediaCodecUtil.canDecode(MediaCodecUtil.java:209)

And different errors on a Samsung Galaxy S4 (API 19) and my tablet (API 17).

I'm not sure if this is the same issue or should I create a new one?
This is unrelated to this issue. Those are just logs of a caught exception. It looks like WebVoew failed to create a secure VP8 and VP9 decoder, which could be because the device does not have a secure (hardware) decoder for these codecs. However, it's possible this is just the platform querying to determine whether to report support for these to applications, in which case this is expected and can be ignored.

Comment 8 by dude8...@gmail.com, Apr 13 2016

This issue is with using Netflix in a webview and the video won't play, and I think it's because of that exception. Is there a way to use a software decoder for this? Where should I post about this?
Today, Netflix does not appear to have a player that supports playback on Chrome on Android (and thus WebView). This is unrelated to the permission, and other providers that *do* have a mobile web experience work on Chrome on Android and WebView once the permission is granted.

Sign in to add a comment