New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 25 users
Status: Fixed
Owner:
not on Chrome anymore
Closed: May 22
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug


Show other hotlists

Hotlists containing this issue:
Hotlist-1


Sign in to add a comment
Dropdowns not drawn/drawn incorrectly
Reported by orourke....@gmail.com, Aug 3 2015 Back to list
UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36 Edge/12.10240

Steps to reproduce the problem:
1. Install Chrome on Windows 10.
2. Click on the Identity Switcher or go into Setting.
3. Attempt to sign in.

What is the expected behavior?
No response. Buttons correctly highlight, so the browser is not frozen, but no action happens and no error is logged.

What went wrong?
Not entirely sure. No error is logged on my system, so I cannot see where the UI context button is not returning a request. All other UI functions I have tested seem to be operating as expected.

Did this work before? Yes Previous Versions of Windows

Chrome version: 44.0.2403.125 m  Channel: stable
OS Version: 10.0
Flash Version: Shockwave Flash 18.0 r0

I was advised to post this here in the bug tracker by Kameron M from the Chrome Help Forums, so here it is. I have my own development work to do sadly so I do not have time to explore this further. Thanks everyone!
 
Labels: Proj-Windows10
Comment 2 by hodie@chromium.org, Aug 4 2015
Owner: jsc...@chromium.org
Hey, are you trying to do this via touch or via mouse/trackpad?
Comment 3 by hodie@chromium.org, Aug 4 2015
Also, to confirm, do the boxes get active (blue border/highlight) or just selected (grey border/highlight)?
Comment 4 by hodie@chromium.org, Aug 4 2015
Cc: shrikant@chromium.org
Adding shrikant as this might be related to or duplicate of  issue 516711 
To answer all of the questions:

1. I am interacting with a standard mouse. Not touch input and the computer is not in Windows 10's "Tablet Mode".

2. The button changes from grey to blue, as it normally would if it was clickable. except nothing happens.

3. This is not a surface tablet. This is an Intel desktop PC with no touch input. As I said, when I click the Identity Switcher button, nothing happens at all. I do not go to a login screen.

A note on that last issue: There have been a couple of cases where I have gotten Chrome to the Sign In To Chrome page without clicking the Identity Switcher or Settings. In those cases, I was able to log in without issue... To one account. I cannot log into more than one Identity.
Labels: Needs-Feedback
Unable to reproduce the issue on Windows 10 using chrome stable M44-44.0.2403.130 by following steps mentioned below.

1. Opened chrome and clicked on identity switcher
2. Clicked on blue sign-in button
3. Typed username and password and observed able to login

orourke.casey@ Is this issue is reproducible on chrome canary as well? Could you please check the behavior of current chrome stable M44-44.0.2403.130 and canary M46-46.0.2473.0 and update your status.

Thanks!
Canary build Version 46.0.2473.0 canary (64-bit) is not experiencing the issue. Everything is working as intended... Sort of.

Canary did actually reveal the real problem.

The Chrome stable was loading on a second monitor. Canary (not having ever been installed), loaded on the primary monitor. I moved Canary over to the second monitor and Canary exhibited the same symptoms. Just out of curiosity, I moved the stable browser to the primary monitor and the symptoms disappeared.

So the issue appears to be that the buttons are not functioning when the browser is displayed on a non-primary monitor. I think this will allow you to replicate the issue.

Again, the buttons highlight properly when the mouse hovers over them, and the Identity Switcher is in a different (x,y) position than the Sign In button in Settings. Does this make things a bit clearer?
Confirmed what orourke was saying, Login box does not appear unless the browser is on the primary monitor. does not work apart from highlighting the box blue and then nothing on my 3 other monitors.
Comment 9 by Deleted ...@, Aug 10 2015
can't sign in to sync my settings
Comment 10 by Deleted ...@, Aug 10 2015
I'm having the same issue
So we have others confirming it. Could one of you devs attempt to replicate the issue again with the new information so it can get properly assigned? It's kind of obnoxious to have to keep moving Chrome back and forth between monitors to switch identities.
Mergedinto: 450147
Status: Duplicate
Um... I don't think this was a duplicate of 450147. Sounds like a completely different issue.
Comment 14 by hodie@chromium.org, Aug 11 2015
Mergedinto:
Yeah, I would agree. It was my first intuition that they were the same but this seems to be a multi-monitor problem, not a touch problem. jschuh@?
Labels: Needs-Bisect
Status: Unconfirmed
Based on another comment from wjmaclean@ I interpreted  bug 450147  as having a more general fix, but looking at the code it was specific TouchStart.

I'll flag for bisect to determine when this was fixed, but if it's in m45 I'd just wait for the next major update at this stage.
Cc: brajkumar@chromium.org
Labels: -Needs-Bisect
Unable to reproduce the issue on Windows 10 using chrome stable M44 - 44.0.2403.155 using dual monitor setup by following steps mentioned below.

1. Opened chrome and placed the window to the secondary monitor
2. Clicked on identity switcher and typed the login credentials
3. Clicked on Log in button
3. Observed the button is working fine and chrome logged in to the account

orourke.casey@ - Please have a look on the attached screen cast, Let us know if we are missing anything from our end.
Removing the bisect label for now, please free to add if it is required.
Recording #1.mp4
4.8 MB Download
That's really weird as i could not get any of these login pop ups to load on any monitor except the primary one. All 4 monitors are identical model and settings. When i get home from work i will try and log out and back in again on secondary monitor and update if that works or not. 

Maybe because you moved the window to the main and back again it worked. Can you try not moving the window at all and login in Full screen mode on Right hand Side monitor?
I will test and screen cap what I am doing for verification once I get to the computer.
Ok, here is a screen cap of the the issue. I identify the two monitors so you can see the primary and secondary, switch between the monitors and one obvious works fine, the other does not.
2015-08-13-0557-25.mp4
8.5 MB Download
Thank you for this, this is the exact problem that i am having. Is this enough to confirm the issue? I have tested in Canary as well and same is present.
Thanks brajkumar@. If you wouldn't mind, could you tell me if the bug is present in canary and/or beta channels? It sounds like canary is fixed, but I want to narrow down the timelines.
It was present on the Canary build I tested a few comments back. I can download the latest Canary a bit later and try again, however.
I have the issue too, on Canary Version 46.0.2485.0 canary (64-bit) and in chrome too (Version 44.0.2403.155 m); Windows 10 Professional x64.

In Primary Monitor works fine, but not in secondary monitor, like described here.
Comment 24 Deleted
Cc: scottmg@chromium.org
Labels: -Needs-Feedback
Status: Available
Thanks for capturing a video.

I'm not able to reproduce here unfortunately. (Maybe related to GPU or something? Not sure.) We'll need to try to get a local repro.
Comment 26 by Deleted ...@, Aug 28 2015
Yeah, I can also confirm that this bug only occurs when Chrome is on the second monitor. The login popup shows up just fine when Chrome is on the primary monitor. And, more specifically, as long as the popup area is on the primary monitor (if, say, the chrome window is spanning across both monitors) it'll open fine, even if the "sign in to chrome" button is on the secondary monitor. But if the window is too far over into the secondary monitor, the pop up won't display.
Cc: jsc...@chromium.org
Owner: kulshin@chromium.org
Comment 28 Deleted
Status: Assigned
I'm also having trouble getting a repro. Could someone with a repro attach the output of chrome://gpu to help track this down?
chrome://gpu - Output is attached. 

additional info: 
- if switch profile with right mouse button, an another menu appears and it works. => the faster work-around than moving the chrome window to primary monitor...
 
- but the normal way with left mouse button doesn't work on secondary monitor.
gpu.html
136 KB View Download
@kuls, sorry for the delay. Here is the output you requested.
Graphics Feature Status.docx
20.0 KB Download
I've had this issue for a while now. I just figured out an extra bit of info I hope you find useful. 

My Setup: 
Dell M4800
Dell 24" - DisplayPort - Accell B087B-007B DisplayPort to DVI-D Dual-Link Adapter.

Short Version: 
- I have the second monitor issue when using the DisplayPort.
- I do NOT have the second monitor issue when using VGA.

Long Version:
My wife asked me to "do that Chrome Profile thing" on her new work laptop. (: 
It only has a VGA port (no DisplayPort). No biggie...  I reached into the rats nest of cables in my closet, pulled out a VGA cable, connected it all up & got started.

I created a Google account with her new work email address, added her personal profile and den...
As I was adding my personal profile I realized I had been working exclusively on the second monitor. Whaaaat?!

I turned on my laptop & compared Chrome versions. They matched. Maybe there was an update..?
I changed the monitor input to DVI to test it out on my system. No workie...
I changed the monitor input back to VGA and plugged the cable into the VGA port on MY laptop. TADA!!  Everything is working as it should! 

Hope this helps!  (:
For reference my set up is as follows:

GeForce GTX 650 Ti BOOST graphics card connected to:
- HP LP2065, HDMI out to DVI in
- HP L2105tm, DisplayPort out to DVI in
- Samsung SMS27A850, DVI out to DVI in

GeForce GT 640
- Samsung 2443, DVI out to DVI in
- Samsung 2443, DVI out to DVI in

I only experience the problem with the two Samsung 2443 monitors connected to the GeForce GT 640. All monitors on the other card work fine.
Comment 34 by Deleted ...@, Sep 25 2015
Same Problem here.

Windows 10 64-Bit Pro
Chrome 45.0.2454.101 m (64-bit) and Canary 47.0.2518.0 (64-bit)

GFX-Card : GeForce GT 650m and Intel HD 4000 (optimus)

works on Primary Screen (Laptop internal screen)
works on Secondary Screen (LG 23" via VGA- Intel HD 4000)
does not work on Secondary Screen (Samsung 24" via HDMI-GeForce)
I'm thinking o.pon...@googlemail.com is on to something... My second monitor is running off Intel Integrated graphics as well, with the primary monitor running off of an nVidia discrete graphics card.
Comment 36 by Deleted ...@, Oct 15 2015
I have this problem as well.
login, bookmark, extension details, and various extension flyouts, page alerts, etc. don't show up on one monitor, they do show up on the other.

System details:
Windows 7 pro
Chrome Version 46.0.2490.71 m
Both video cards identical (radeon 6450)
Both monitors identical resolution (2560x1440)

If I extend desktop between both monitors, it works on both monitors.
If I switch to just one monitor, it works on it; if I switch to the other, it doesn't work.

Oddly, with Chrome 45, it worked on the left monitor and not the right; after upgrade to Chrome 46 (while on the right monitor), it started working on the right monitor and not the left. (The same thing happened, but from right to left,  when I updated the video driver.)

I'm attaching chrome://gpu.
gpu.html
85.0 KB View Download
Comment 37 by Deleted ...@, Oct 15 2015
I forgot to mention that both monitors are connect with DisplayPort.
Labels: Hotlist-Fixit Hotlist-WinFixit2015
I'm using Canary 48 and can confirm this issue with my dual GPU setup on Windows 10. Attached my chrome://gpu output
gpu.html
146 KB View Download
I'm experiencing the same issue as posted here: https://code.google.com/p/chromium/issues/detail?id=545569

Desktop compositing	Aero Glass
Driver vendor	NVIDIA
Driver version	10.18.13.5598
Driver date	9-13-2015

Data exported	11/2/2015, 5:04:26 PM
Chrome version	Chrome/46.0.2490.80
Operating system	Windows NT 10.0
Software rendering list version	10.11
Driver bug list version	8.23
ANGLE commit id	a7b483f2940c
2D graphics backend	Skia
Command Line Args	Files (x86)\Google\Chrome\Application\chrome.exe" --flag-switches-begin --flag-switches-end
Chrome-monitor-glitch.jpg
138 KB View Download
I also just experienced this same behavior.  "Sign in to Google" button wasn't working on 2nd monitor.  I read this thread so I moved my Google Chrome window to primary monitor and then I was able to see the login window.  

Graphics Card: AMD Radeon HD 7470 - Drivef: v.15.200.1039.0 (2015-05-28)
Montitors: Dell E2014H

I was able to reproduce the behavior by moving my Google Chrome window into 2nd monitor, disconnecting my Google account and trying to re-login.  

If you need a video capture, let me know and I will put one together.  
More information: 

Google Chrome	46.0.2490.80 (Official Build) m (32-bit)
Revision	c6bfd1395b9449cb59180d45944a8cb56799bd9c-refs/branch-heads/2490@{#549}
OS	Windows 
Blink	537.36 (@c6bfd1395b9449cb59180d45944a8cb56799bd9c)
JavaScript	V8 4.6.85.28
Flash	19.0.0.226
User Agent	Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36
Got this to repro with two video cards and chrome on non-primary monitor.

While debugging, discovered that using spy++ to record messages for the avatar window causes the bug to disappear. Really strange.
Wrote a test app and discovered that installing a global windows hook for WH_CALLWNDPROCRET (of all things, you'd think that's the one thing that wouldn't change anything) makes this bug not repro if the hook proc does not return immediately (sleep(0) has no effect, but sleep(1) or counting to a million "fixes" the bug). Calling or not calling CallNextHookEx doesn't seem to make any difference.

Anyone have any ideas for further investigation?
 Issue 527845  has been merged into this issue.
Cc: -shrikant@chromium.org ananta@chromium.org
ananta@ - Since you probably know more about the internals here than anyone, do you have any idea what might be going on?
Cc: jbau...@chromium.org
Labels: Hotlist-Input-Dev
Adding Input-Dev, since the issue could be on that side.
Labels: allpublic
Don't think this is input related. In both cases (working and not working) the code goes through all the code to create the window. It's just that in the bugged case the window is never drawn on screen.

I recorded the sequence of messages that gets sent to the working and bugged case - they're essentially identical, except the bugged case gets into a loop of WM_PAINT-WM_NCPAINT-WM_ERASEBKGND. Not sure if that means anything, or if that's just a coincidence.

Since this case works if the message loop is delayed slightly (such as by installing a hook) I suspect a timing/reentrancy bug somewhere in the compositor or window drawing code.
Window Message Sequence - Sheet1.csv
51.2 KB View Download
Comment 50 Deleted
I'd like to also add that the issue appears to occur with all extension buttons in the top right corner of the browser. Able to right-click, but left-click is not functional. Issue does not seem to matter where the browser window is positioned or what size it is in the secondary monitor either. Just a few new things I tested.
Cc: kulshin@chromium.org
Owner: jbau...@chromium.org
jbauman@ - can you take a look? I've hit the point where I can't make meaningful progress without in depth knowledge of the compositor/rendering code.

I did notice that the window is in fact created, and even responds to click events (if clicking in the right place), but that still doesn't tell me why it isn't being drawn.
Labels: Cr-Internals-PlatformIntegration
Labels: Hotlist-Polish
I also have this bug with a multi monitor setup
Comment 56 by m...@goff.cc, Dec 4 2015
Experiencing this issue on Win10 Pro x64 with Chrome 47.0.2526.73m. On my second monitor only the hamburger menu reliably displays while extensions and the user switcher fail to appear.

Attached is chrome://gpu output.
gpu.html
138 KB View Download
Summary: Dropdowns not drawn/drawn incorrectly (was: Sign Into Chrome Not Responding)
 Issue 545569  has been merged into this issue.
This seems similar to  bug 356648 .
Comment 60 by Deleted ...@, Dec 8 2015
I can confirm i have this issue with a dual AMD GPU setup (A8 APU with HD8570 and HD6450 PCI Card) I am not using AMD Dual Graphics - But Chrome Believes i am according to chrome://gpu ... I have Four Monitor Setup. Monitors connected to APU(Board) display fine, monitors connected to GPU do not show this menu. Turing off Hardware Acceleration does fix this. This has been an issue with all version of windows 10 including early previews. Cannot confirm if 8.1 did the same. 

I am on AMD Driver Version 15.201.1151.1008 and Chrome 47.0.2526.73 m
I would also like to report that turning off hardware acceleration in Chrome does fix this issue.
Comment 62 by Deleted ...@, Dec 10 2015
I was having this same issue recently under Chrome 47 & Chrome Canary 49, and after searching under this forum, turning off hardware acceleration did work for my second monitor under Intel Display. Here is some specs, if it helps narrow anything down. 

Summary
		Operating System
			Windows 10 Pro 64-bit
		Graphics
			1950w (1366x768@60Hz)
			2070W (1600x900@60Hz)
			Intel HD Graphics 4000 (Gigabyte)
			3071MB NVIDIA GeForce GTX 660 Ti (ASUStek Computer Inc)	47 °C
			ForceWare version: 359.06
			SLI Disabled
Comment 63 by m...@janmach.cz, Jan 8 2016
I have the same issue. Not working only on the secondary monitor. Both monitors connected with displayport, AMD discrete card. Problem also with extensions (e.g. AdBlock, left mouse click doesn't work). Sometimes I see only upper left corner of the popup window.


view-source_chrome___gpu.html
28.9 KB View Download
Comment 64 by jpcho...@gmail.com, Jan 21 2016
Another interesting tidbit. 

On a system where this issue manifests itself, you can stretch a chrome window across the screen boundaries and the menus will pop up on the "bad" screen if more of the window is on the "good" screen. If a majority of the window is on the "bad" screen the menus stop working.
Comment 65 by jpcho...@gmail.com, Feb 22 2016
And another tidbit.

If I remote desktop into my workstation with this issue and log back into the local console session, the popups start to work on my secondary monitor.
Comment 66 Deleted
Comment 67 by m...@janmach.cz, Feb 29 2016
I can confirm that with the option "Use hardware acceleration when available" turned off, pop ups work! Thanks.
I would add that disabling hardware acceleration is not a solution... It's a workaround. 
It seems, that this issue is fixed now, in Version 52.0.2730.0 canary (64-bit)! :-)

But I don't know how is it fixed ==> by fix in chrome sources or by an windows update / driver update... 
Comment 70 by jpcho...@gmail.com, May 27 2016
Canary 53.0.2749.2 (64-bit) works!!!!!!

I can confirm a Chrome fix. I have Chrome 51 and Canary 53 installed side by side, and 53 definitely works and 51 still has the pop up issue. 
I have been having a similar issue for a while where the drop down menu for Roboform and AdBlock Plus would not work. The buttons would show pressed, but no drop down. 

Updated to the current stable version (51.0.2704.103 m) and the issue is resolved. 
Comment 72 Deleted
I'm updating my previous comment from May 27.

I'm currently using chrome DEV 53.0.2783.4 dev-m (64-bit).

In a default chrome://flags state, both my user selection popup and my extension menus pop up correctly. However in this default state chrome has disabled all GPU rendering breaking 3D Google Maps and WebGL. 

If I enable "Override software rendering list" in flags, GPU rendering is forced on (for the most part), and the user selection menu still works, however my extension menus are in the broken state again.

Again, if I move my chrome window to my monitor connected to my discreet GPU (AMD HD5450) the extension menus appear fine. Only my Intel GPU do they not get drawn correctly.

I've attached my chrome://gpu output for both situations of the force gpu mode enabled.
force enable gpu report.html
150 KB View Download
default chrome gpu report.html
46.5 KB View Download
Using Chrome DEV Version 55.0.2853.0 dev-m (64-bit).

Everything works! defaulted my chrome://flags and now both google maps and my extension menus are showing up fine. 

The chrome switch user and extension flyouts do not draw.

Chrome Version 58.0.3029.81 (64-bit)
Win10
gpu.html
100 KB View Download
2017-04-29 21_47_00-Settings.png
15.8 KB View Download
Status: Fixed
Probably fixed by r466207.
Sign in to add a comment