New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 33 users
Status: Duplicate
Merged: issue 516349
Owner:
OOO
Closed: Aug 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment
Chrome cuts off external URLs with hash symbol on Windows 10
Reported by thex...@gmail.com, Jul 27 2015 Back to list
UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.107 Safari/537.36

Steps to reproduce the problem:
1. Have Chrome as the default web browser
2. Click on a link with a hash sign in the URL from an external program

What is the expected behavior?
Chrome should open the full link.

What went wrong?
Chrome cuts the URL it gets from the external program exactly at the '#' symbol.

Did this work before? Yes Previous Windows 10 build before RTM build.

Chrome version: 44.0.2403.107  Channel: stable
OS Version: 10.0
Flash Version: Shockwave Flash 18.0 r0

Changing default web browser to IE, Edge or Firefox fixes the issue (it opens full url in these browsers).

Same bug has been fixed before, see #157184.

 
Comment 1 by thex...@gmail.com, Jul 27 2015
This issue is also reproducible by entering an url in windows run window (win+r).
Cc: brajkumar@chromium.org
Labels: Needs-Feedback
Unable to reproduce the issue on Windows 10 using chrome stable - 44.0.2403.107 by following steps mentioned below.

1. Navigated to page http://stackoverflow.com/questions/9127808/how-do-you-include-hashtags-within-twitter-share-link-text
2. Clicked on the second link https://dev.twitter.com/discussions/512#comment-877 which has hash symbol in the middle
3. Observed the page opened fully with hash symbol

thexpaw@ - Is this issue reproducible on chrome canary - 46.0.2466.0 ? Could you please recheck this issue by creating a new profile under chrome://settings, If issue still persists please provide the sample URL of webpage on which link that you are facing the issue.
#Symbol.mp4
1.2 MB Download
Comment 3 by thex...@gmail.com, Jul 28 2015
The problem only occurs with links from external programs (e.g Skype or HexChat). Using Win+R (run window) and pasting an url there also reproduces the issue.

This seems to be common issue on Windows 10 as multiple other people are experiencing same issue.
Cc: pbomm...@chromium.org
Labels: M-46 Proj-Windows10
I see the issue this is being tracked in issue#501166 as updated in  issue#157184 , hope fully in next canary the fix should be there. I will mark the bug accordingly once the other bug is fixed.
Comment 5 by grt@chromium.org, Jul 30 2015
Cc: gab@chromium.org
Status: Available
thexpaw: Thanks for filing a new bug for this. This is the same as  issue 157184 , which was fixed for Win8. That fix doesn't seem to work in Win10.

This will be resolved by having Chrome no longer do the set_delegate_execute codepath introduced in r133333 on new installs, and having the registration removed after an OS upgrade to/past Win10. Gab: is this something you could do?
Comment 6 by gab@chromium.org, Aug 4 2015
Mergedinto: 516349
Owner: gab@chromium.org
Status: Duplicate
Yep, tracked in  issue 516349 
Comment 7 by grt@chromium.org, Aug 24 2015
Cc: ananta@chromium.org
 Issue 157056  has been merged into this issue.
Fix confirmed for Beta at Dutch Chrome forum topic:
https://productforums.google.com/forum/#!topic/chrome-nl/PV5E9rVi_MM
Comment 9 Deleted
Sign in to add a comment