New issue
Advanced search Search tips
Starred by 7 users

Issue metadata

Status: Duplicate
Merged: issue 68177
Owner: ----
Closed: Aug 2010
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
link

Issue 51141: prevent search engines from being added automatically

Reported by 31337h4c...@gmail.com, Aug 4 2010

Issue description

Chrome Version       : 5.0.375.125 (0)
URLs (if applicable) : www.facebook.com, www.filestube.com

What steps will reproduce the problem?
1. Visit Facebook or do a search on FilesTube
2. Check your search engine list, you will have new entries for Facebook and FilesTube

What is the expected result?
Search engines should not be added automatically. At least have a prompt so  the user can decide.
 

Comment 1 by stuartmorgan@chromium.org, Aug 4 2010

Labels: -Area-Undefined Area-UI Feature-Omnibox

Comment 2 by pkasting@chromium.org, Aug 4 2010

Status: WontFix

Comment 3 by 31337h4c...@gmail.com, Aug 4 2010

Any reason the issue is changed to WontFix?

Comment 4 by pkasting@chromium.org, Aug 4 2010

Because auto-adding engines is a critical part of making tab-to-search work, and there's basically no downside in doing it.

Comment 5 by Deleted ...@, Aug 9 2010

It can be very annoying though when you want to search for something relating to a .com but not search the .com itself.

If we cannot have an option to disable the auto-add functionality, can we have an option to disable the space-commits key? 

Example:
walmart.comTABquery searches walmart.com with "query"
walmart.comSPACEquery searches the default search engine with "walmart.com query" like you would normally expect.

Comment 6 by pkasting@chromium.org, Aug 9 2010

Use ctrl-k, or prefix with "?", or press the down arrow to select the "search your default search engine for ___" entry in the dropdown, or reverse the order of the words.

Wanting to search the default search provider with a query that includes a domain name, instead of wanting to actually search on that domain, is uncommon enough that having to press a key to select it seems OK.

Comment 7 by Deleted ...@, Aug 9 2010

? is perfect, thanks for the tip :D - much appreciated

Comment 8 by joopbr...@gmail.com, Mar 23 2011

It's my PC, so I want to have control over what search engines are in my settings.

I don't want search engines added just because I happen to visit that site once in a while.

Chromium was supposed to be Chrome without all that shit happening behind your back.

At least make it so that I can choose if a want this to happen automatically or not, is that so hard?

If this doesn't change it will be one more reason why I won't switch from Firefox to Chromium (which was something I was seriously considering).

Comment 9 by bugdroid1@chromium.org, Oct 12 2012

Project Member
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.

Comment 10 by pkasting@chromium.org, Dec 4 2012

Mergedinto: 68177
Status: Duplicate

Comment 11 by bugdroid1@chromium.org, Mar 11 2013

Project Member
Labels: -Area-UI -Feature-Omnibox Cr-UI-Browser-Omnibox Cr-UI

Sign in to add a comment