New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 51014 link

Starred by 3 users

Issue metadata

Status: Fixed
Owner:
Last visit > 30 days ago
Closed: Aug 2010
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 1
Type: Bug
M-6

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

WebM/VP8 video plays too fast on certain content

Project Member Reported by scherkus@chromium.org, Aug 3 2010

Issue description

YouTube WebM content seems to be created correctly and plays back properly.

Other content such as our sync test content was created using different tools, resulting in video that plays back too fast.

Works properly in Firefox and Opera.  We should be able to play back all WebM content regardless of tools used to create the content.
 
The problem is the altref frames were getting decoded but not producing a valid video_frame, so video_frame.get() would return false and the pts_heap_ would never get popped.

Here is a CL for the fix http://codereview.chromium.org/3086009

Status: Started
Cool -- assigning to you as you have a fix.

Once tested + committed please merge into 472 branch using drover.

Comment 3 by bugdro...@gmail.com, Aug 10 2010

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=55596 

------------------------------------------------------------------------
r55596 | fgalligan@chromium.org | 2010-08-10 11:58:05 -0700 (Tue, 10 Aug 2010) | 9 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/media/filters/ffmpeg_video_decode_engine.cc?r1=55596&r2=55595
   M http://src.chromium.org/viewvc/chrome/trunk/src/media/filters/ffmpeg_video_decode_engine_unittest.cc?r1=55596&r2=55595

Fix av sync for webm files with altref video frames. Altref frames
need to be decoded but they do not produce a valid output frame. The
pts_heap_ was not getting popped for altref frames.

BUG= 51014 
TEST=Play content form sync test and make sure the content plays
back in sync.

Review URL: http://codereview.chromium.org/3086009
------------------------------------------------------------------------

Comment 4 by bugdro...@gmail.com, Aug 12 2010

The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=55905 

------------------------------------------------------------------------
r55905 | fgalligan@chromium.org | 2010-08-12 10:59:09 -0700 (Thu, 12 Aug 2010) | 12 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/472/src/media/filters/ffmpeg_video_decode_engine.cc?r1=55905&r2=55904
   M http://src.chromium.org/viewvc/chrome/branches/472/src/media/filters/ffmpeg_video_decode_engine_unittest.cc?r1=55905&r2=55904

Merge 55596 - Fix av sync for webm files with altref video frames. Altref frames
need to be decoded but they do not produce a valid output frame. The
pts_heap_ was not getting popped for altref frames.

BUG= 51014 
TEST=Play content form sync test and make sure the content plays
back in sync.

Review URL: http://codereview.chromium.org/3086009

TBR=fgalligan@chromium.org
Review URL: http://codereview.chromium.org/3169009
------------------------------------------------------------------------

Status: Fixed
Project Member

Comment 6 by bugdroid1@chromium.org, Oct 12 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 7 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-WebKit -Feature-Media -Mstone-6 Cr-Content Cr-Internals-Media M-6
Project Member

Comment 8 by bugdroid1@chromium.org, Mar 13 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Project Member

Comment 9 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink

Sign in to add a comment