New issue
Advanced search Search tips

Issue 506555 link

Starred by 23 users

Issue metadata

Status: Verified
Owner:
Closed: May 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 1
Type: Bug


Show other hotlists

Hotlists containing this issue:
Hotlist-1


Sign in to add a comment

Curtain mode disconnect after pin in Chrome Remote Desktop on Windows 10

Reported by nw...@log1.net, Jul 2 2015

Issue description

UserAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.130 Safari/537.36

Steps to reproduce the problem:
1. Double click on host computer icon running Windows 10
2. Enter PIN
3. Wait

What is the expected behavior?
Should get the logon screen to be able to enter the password

What went wrong?
Blank Screen followed by disconnect

WebStore page: https://chrome.google.com/webstore/detail/chrome-remote-desktop/gbchcmhmhahfdphkhkmpfmihenigjmpp?hl=en

Did this work before? N/A 

Chrome version: 43.0.2357.130  Channel: stable
OS Version: 10
Flash Version: Shockwave Flash 18.0 r0

I have found that when I try and use Chrome Remote Desktop on Windows 10, it works fine with it's default installation, but when I try and enable curtain mode, I get a blanks screen and then shortly disconnected after entering the PIN
 

Comment 1 by kalman@chromium.org, Jul 24 2015

Labels: -Cr-Platform-Extensions Cr-Services-Chromoting
Curtain mode requires that Remote Desktop is enabled on your computer. I don't have a Windows 10 machine to test, but on Windows 7, it's available via System Properties > Remote.

Make sure that the "Allow connections from computer running any version of Remote Desktop" option is selected.
Labels: Needs-Feedback
Status: WontFix

Comment 5 by keut...@gmail.com, Aug 27 2015

This problem still exists in Windows 10. Settings are okay (allow from any version checkbox is enabled). After entering PIN, the client immediately disconnects. No errors in host-log. Only message is that the client disconnected.

This has worked fine before (even after upgrading from 8.1 to 10), but after doing a fresh Win10 install, and setting the curtain mode registry key, this problem occurs.

I'm on version 45.0.2454.78 beta-m (64-bit). But the stable channel also has this problem. Chrome Remote Desktop version is 45.0.2454.18.
Owner: ajnolley@chromium.org
Status: Assigned
AJ, can you try to repro on Windows 10?
Owner: ----
Status: Untriaged
Yes, this is reproducble with 45.0.2454.18 if curtain mode is enabled. Curiously, I ran into an issue exactly like this on Windows 7 as well, when M45 was ToT. The issue resolved itself after a couple of weeks...

 bug 507927 
Labels: -Pri-2 Pri-1
Owner: weijun@chromium.org
Status: Assigned
Weitao, can you look into this, please?

Comment 9 by mada2...@gmail.com, Sep 24 2015

Same problem here.  Upgraded from Windows 8.1 to Windows 10 and it worked, however after performing a clean Windows 10 installation Chrome Remote Desktop with the curtain mode registry entries immediately disconnects.
Labels: Hotlist-Recharge
This issue likely requires triage.  The current issue owner may be inactive (i.e. hasn't fixed an issue in the last 30 days or commented in this particular issue in the last 90 days).  Thanks for helping out!

-Anthony

Comment 11 by robe...@fvsd.ab.ca, Oct 15 2015

Add me to the list.  Works perfectly on Windows 10 Enterprise until Curtain Mode activated and then immediate disconnect.
I'll also be tuning into this thread - Windows 10 new install - works well without curtain mode (except I cannot "Resize to Fit - checking that box does nothing which is why I'm enabling curtain mode in hopes that it would fix this and let me adopt my chromebook's resolution). 

Comment 13 by dav...@wnmt.com, Jan 18 2016

I have a wide selection on Window OSes: This issue shows for me on a Windows 10 Professional (64-bit) system that was an upgrade from Windows 7 Professional (CRD Curtain Mode never attempted) and Server 2003 R2 Standard (32-bit). Functions correctly with Windows 7, Windows 8.1, and Server 2008 (32-bit).
This issue reproduces for me on Windows 10 Enterprise fresh install.
Owner: joedow@chromium.org
Fixing owner.

Comment 16 by mada2...@gmail.com, Jan 28 2016

Just tried again on a new machine upgraded from Windows 7 Enterprise to Windows 10 Enterprise.  Same result when curtain mode is enabled.  Running version 48 of Chrome.
Cc: gogerald@chromium.org
Confirmed same issue here.  Fresh install of Windows 10 Enterprise 64 bit, worked fine without curtain mode, now it disconnects me right away.  I've tried it both with and without the "Allow connections only from computers running Remote Desktop NLA..." option checked.  This is pretty annoying, since I just upgraded from a laptop to a Chromebook/Desktop combo and now I can't use the Chrome Remote Desktop application.  This is a setup for work so I don't have the option not to run in curtain mode.  My only saving grace is being an advanced user so I can go with crouton and FreeRDP to remote in, but I've found Chrome RD to work better.
Labels: M-51

Comment 20 Deleted

Comment 21 by mada2...@gmail.com, Mar 14 2016

Just updated to Chrome 49.0.2623.87 on my Windows 10 Pro 64 fresh install and the issue persists.  Is there any estimate on when this might be resolved?  Thanks.
My goal is to address this in M51 as this is an important issue to correct.  One caveat is that this might end up in M52 if my current task takes longer than anticipated.

Comment 23 by dav...@wnmt.com, Mar 14 2016

Reiterating my comment 13 above as an aid to troubleshooting, I also have a Server 2003 R2 Standard (32-bit) that I can reproduce the exact issue once the Registry entry for curtain mode is in place. Server 2008, Windows 7, and Windows 8.1 work fine. I realize Chrome support for Server 2003 is ending next month, but as long as it works under Windows 10 too I will be happy.
Labels: -M-51 M-52
This is still next on my list but won't make it for M51.
Status: Started (was: Assigned)
Set up some repro hardware and am debugging the issue now.

Comment 26 by yosin@chromium.org, Apr 25 2016

Cc: yosin@chromium.org
I have a root cause for this.  The default value for the RDP-TCP Security Layer has changed for Windows 10.  RDP connections use either SSL(TLS) or RDP-SL and the default value on previous Windows versions is 'negotiate' (i.e. allow client to dictate the connection security type).  On my fresh Windows 10 install, this value was set to SSL(TLS) which we don't support.  Changing it back to negotiate fixed the problem.

I couldn't find a consistent UI to change the setting (it exists on server but I didn't see it on client OSes) so the most consistent way to get this working again is to set the Security Layer registry key back to 'negotiate' which mirrors the behavior on previous OSes.

Registry Key:
\HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\SecurityLayer

The value I expect for these failures is 2, which correspeonds to SSL(TLS).  Change this value to 1 (negotiate).  No reboot is necessary, you can try establishing a CRD connection immediately.

Here is an article discussing RDP Auth and Encryption for more info on what this change means:
https://technet.microsoft.com/en-us/library/cc770833.aspx

If this works for everyone experiencing this problem, I will get our help documentation updated.

Comment 28 by mada2...@gmail.com, Apr 26 2016

That worked for me.  Thanks Joe!  Appreciate the help!
Thanks a lot. That worked for me too.

The key for the curtain mode i had set was HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome and this doesn't work. Please remember to set the key for curtain mode in following path:

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Policies\Google\Chrome\RemoteAccessHostRequireCurtain


The WOW6432Node section of the registry is for 32-bit apps on 64-bit OSes.  Both registry paths are valid depending on the OS and binary bitness you are running.
Flipping the SecurityLayer flag to 1 also worked for me.  Tested it from a chromebook to an instance of Windows 10 Pro and Windows 10 Enterprise.  Thanks for the fix!

Comment 32 by dav...@wnmt.com, Apr 28 2016

Enabling "Curtain Mode" again did require a reboot after performing this change as well, and now my Windows 10 system has the behavior I want: The remote session is full-screen in CRD, and doesn't have the floating notification (always in the way) to terminate the remote session on the host system. I'm prompted for the system account password rather than the PIN I set up locally, and UAC control of the CCleaner monitor program would come up, but I saw it as an opportunity to disable it to avoid all of the other nagging too.
Project Member

Comment 33 by bugdroid1@chromium.org, May 3 2016

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/0bf730db647d382b272ce899d7eeb01c96a6655d

commit 0bf730db647d382b272ce899d7eeb01c96a6655d
Author: joedow <joedow@chromium.org>
Date: Tue May 03 20:09:01 2016

Adding logic to detect and log invalid RDP settings

This change adds code that checks the values of a set of registry keys which
have specific required values, otherwise we know we cannot establish an RDP
session.  The code will log an error if the incorrect value is found and will
prevent the RDP session from being created.  If for some reason we fail to read
the registry key, a warning will be logged but we won't prevent the attempt to
create an RDP session.

BUG= 506555 

Review-Url: https://codereview.chromium.org/1944513002
Cr-Commit-Position: refs/heads/master@{#391338}

[modify] https://crrev.com/0bf730db647d382b272ce899d7eeb01c96a6655d/remoting/host/desktop_session_win.cc

Status: Fixed (was: Started)
I've added logging to detect this problem in a deterministic way and have put in a request to have the support documentation updated with the new Win 10 info.
Thanks for your work on this Joe. It also appears that curtain mode no longer works on OS X. I'll create a separate issue.
Status: Verified (was: Fixed)
Verified Fixed in 52.0.2743.33
Changing securitylayer worked on Windows 10 x64 ENT, but I cannot get it working on Windows 8.1 x64 ENT. The SecurityLayer registry entry was already set to 1.

Any luck with Windows 8.1 x64 Enterprise?

The registry key should not need to be changed for Windows OSes prior to Win10, unless the default was changed.

I think this is a separate issue, please make sure all of the RDP settings have been updated to enable curtain mode (https://support.google.com/chrome/a/answer/2799701?hl=en) and also make sure you restart the CRD host for the settings to take effect. 
I'm pretty sure they are. They are set from Windows GPO using latest templates. It can be verified in chrome://policy that curtain mode is on. If I change the policy to "Not Configure" push gpupdate, reload policies it changes in Chrome://policy. As soon as curtain mode is removed it works again. Enable the curtain mode policy and I get session ended message right after pin.
Sorry I meant, please verify your RDP settings are correct.  Non-curtain mode does not require RDP to be configured so my guess is that the problem lies there.

Thanks,
Joe
It was UserAuthentication in registry. Set to 1. 0 works. Having this on 1 stops curtain mode from working on both Windows 10 and 8.1.

Excellent!  Glad you were able to get it up and running!

Sign in to add a comment