Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 24 users
Status: WontFix
Owner: ----
Closed: Mar 2012
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
Chrome sandbox instability on Windows 7 Enterprise 64-bit
Reported by doug...@gmail.com, Jul 28 2010 Back to list
Chrome Version       : All, however screen shots and details are from current dev version (6.0.472.0)
URLs (if applicable) : N/A
Other browsers tested:IE 8, FF 3.6
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4:n/a
  Firefox 3.x:OK
         IE 7:n/a
         IE 8:OK

What steps will reproduce the problem?
1.Install any version of Chrome
2.Launch the application with no switches.
3.Application will load with the two blank tabs and the animated icon on the tabs spinning indefinately.

What is the expected result?
1.The application should load with the standard post install two tabs. It should be able to access any URL including browser internal functions such as Bookmark Manager, Downloads, History etc.

What happens instead?
The application loads the two post install tabs with blank backgrounds. The bookmark manager, history, downloads, stats-for-nerds and any public URL all produce a blank tab with the working circle animation on the tab. 

Please provide any additional information below. Attach a screenshot if
possible.

Environment details:
Corporate Environment, conducting application testing on Windows 7 Enterprise 64-bit in preparation for rollout of OS to desktops.
Installed on a HP XW4600 with dual core CPU, 2GB RAM. 

1. Running Chrome with the --no-sandbox switch in the shortcut target results in Chrome operating normally, though minus the sandbox.
2. The task manager loads successfully, but does not show all the tabs running. It also shows that the browser incrementally increases it's usage of RAM, even when all bar one tab are closed. The RAM usage never goes down.
3. The 'Save-As' function of Chrome works and if a blank tab is saved and reopened in another browser like IE, the html document includes the content which was not displaying in Chrome. E.g. Saving the Chrome History, Downloads, Stats for nerds, or www.google.com page shows majority of the graphics and text all laid out as per normally would occur when Chrome works.
4. The application operates fine within the same environment/network when used on a Windows XP SP3 machine.
5. I've attached the following:
a) Screen shot of Chrome with the issue, and the task manager visible (Chrome_issue_on_Win7_64bit.jpg).
b) Screen shot of Chrome with the --no-sandbox applied and the new tab page with icons of recently loaded pages (Chrome_issue_on_Win7_64bit_NO_SANDBOX_1.jpg).
c) Screen shot of Chrome with the --no-sandbox switch applied and the stats for nerds/task manager showing (Chrome_issue_on_Win7_64bit_NO_SANDBOX_2.jpg).
d) Debug log from Chrome when the issue is occurring (Chrome_issue_on_Win7_64bit_debug_log_1.txt).
e) Debug log from Chrome when the issue is not occurring and the --no-sandbox switch is applied (Chrome_issue_on_Win7_64bit_debug_log_2_NO_SANDBOX.txt).
6. Have read numerous threads on the Google Chrome Help Forum and discovered that many users reported a rootkit virus being the cause and an appropriate AV scanner resolving the issue such as Kaspersky's TDSS tool. I've scanned the PC with the TDSS tool and it's clean. I don't believe that this is a virus as the OS is freshly installed for about a week. I have also read solutions which mention .dll compatibility issues with certain applications, however i'm disinclined to start removing many of the applications on our Corporate desktop considering they've all got to be there. My current thought on the issue is that there's some application interogating the 'sandbox' component of Chrome, which Chrome doesn't like and so it packs up. That's a fairly basic perspective but hey, i'm not a guru on the inner workings of the browser, just an avid fan of the results.

I'm very supportive of Google products, especially Chrome, so was understandably gutted when i came across the issue whilst deploying the OS. Any assistance would be greatly appreciated, if there's any questions please post away.

Thanks in advance.

Dougy
 
Chrome_issue_on_Win7_64bit.jpg
135 KB View Download
Chrome_issue_on_Win7_64bit_debug_log_1.txt
6.4 KB View Download
Chrome_issue_on_Win7_64bit_NO_SANDBOX_1.jpg
194 KB View Download
Chrome_issue_on_Win7_64bit_NO_SANDBOX_2.jpg
199 KB View Download
Chrome_issue_on_Win7_64bit_debug_log_2_NO_SANDBOX.txt
75.8 KB Download
Comment 1 by doug...@gmail.com, Jul 29 2010
I'll continue to add any information i spot that might be useful...

Occasionally I receive the pop up error message (Screen shot attached to this post) with the Chrome two tabbed face with the snow flakes over it's head and a scarf around it's neck; which i interpret as 'Chrome is unwell'. 

It has the message: "The following page(s) have become unresponsive. You can wait for them to become responsive or kill them." Under the text is a black square with 'Untitled' next to it and the two buttons, 'Kill pages' and 'Wait'. Kill pages does nothing and wait just gets rid of the box. Despite the one 'Untitled' entry in this error message, i have 7 tabs open. 

Whilst the browser is in the non functional state, the following features do not produce any results:
Spanner Menu -> Tools -> Developer Toolbox
Spanner Menu -> Tools -> JavaScript Console
Spanner Menu -> Print
Spanner Menu -> Tools -> Create Application Shortcut

Any menu option, function or feature which involves rendering on a tab does not work such as extensions, History, Downloads etc.

Menu shortcuts do not work such as CTRL-J (Downloads), CTRL-H (History).

Any menu option which involves producing a little pop out window such as the 'Options' window from the Spanner menu works fine.
E.g.
Spanner Menu -> Options
Spanner Menu -> About Google Chrome (Successfully checks for an update)
Spanner Menu -> Tools -> Clear Browsing Data
Spanner Menu -> Tools -> Task Manager

I mentioned it in the original post, however i just want to mention again that if any of the unrendered tabs are saved to a .html file, the file contains all the appropriate html content which should of been on the tab.

This sort of says to me that the application is communicating fine but is having an issue with rendering the content, though i am not sure what I could do to take that theory forward... perhaps a different brand of graphics card (HP supplied nvidia currently) to see if it's a HW/Software issue with the card, if i had another card...




Chrome_issue_on_Win7_64bit_Sick_ChromeFace.jpg
26.2 KB View Download
Comment 2 by finnur@chromium.org, Jul 29 2010
Labels: not-extensions
Also confirmed for my Windows 7 64-bit Enterprise laptop (Lenovo W510). The no-sandbox workaround works temporarily.
Comment 4 by doug...@gmail.com, Aug 13 2010
I'm not feeling the love here... any advice from the guru stand? Even just a 'I'll get back to you...' or some questions for me?
Comment 5 by redeye...@gmail.com, Aug 30 2010
Confirmed on windows 7 64-bit ultimate laptop (Dell studio 1535). The no sandbox allows the browser to function normally. Also, uninstalling and reinstalling does not fix the issue.
I have the same issue on a Windows 7 Enterprise 64-bit running on a Dell E6500 and Lenovo T410.  We use Symantec End Point Protection 11 but it doesn't log any activity in relation to Chrome starting.  As with others, no-sandbox does allow Chrome to load pages.
Comment 7 by adon...@gmail.com, Sep 22 2010
Win 7 64bits both home basic and home premium work fine on multiple PC and laptop.
To Nicholas, Symantec's antivirus softwares (and some others also) have known issues when sandbox is on, you need to "remove" (turning off won't work) all unnecessary functions and keeps virus scan only. 
Update the core (not AV definition) to newer version may solve.
I'm running Windows 7 Ultimate 64-bit, but chrome runs smoothly.
Did you all try to start using "Safe Mode with networking"? (Hit F8 as the computer is turning on to select that option)
Maybe you have some kind of program running in the background, which wouldn't let Chrome to execute as it's supposed to.
Comment 9 by Deleted ...@, Sep 25 2010
Same issue on Windows Vista Home Basic, Service Pack 2.

Chrome loads with a blank browser window, will not load any pages, and eventually crashes with ~5 minutes or so.  Adding the --no-sandbox switch solved the problem, but obviously don't have the sandbox running now.
Comment 10 by doug...@gmail.com, Sep 27 2010
Regararding comment 8 by Carloset...@hotmail.com

Good suggestion, thanks for the tip though it did not resolve the issue it was still good to test.

I've tested within "Safe Mode with Networking" and confirmed that the issue occurs in that mode as well. As you'd expect in that mode - all non essential applications were not running such as antivirus, graphics apps etc.
Labels: -Area-Undefined Area-Internals Internals-Core
Comment 12 by doug...@gmail.com, Sep 30 2010
Thanks for taking a glance stig, good to know a chromium person is aware of it.
Comment 13 by zeni...@gmail.com, Sep 30 2010
Yup, same problem.  Windows 7 64bit -- I've checked for rootkits as many have suggested but I do not believe that to be the issue and it has not helped.  I've tried disabling av programs (I run avast! 5.05xx).  I've tried re-installing, changing from dev to beta to stable channels.

Nothing avails me and my beloved browser.

I've put a sticky note on the wall to reinstall Win7 but I really don't have the time.  Running with -no-sandbox is noticeably less stable than without and I have problems with flash whilst in -no-sandbox

I'm sad :( I really like chrome and it makes me sad that it won't work =/
Comment 14 by cpu@chromium.org, Sep 30 2010
This is very likely a duplicate of  Issue 24704 . Please look at that bug 
http://code.google.com/p/chromium/issues/detail?id=24704

Also  bug 22699  has steps that people have used to make chrome work. http://code.google.com/p/chromium/issues/detail?id=22699

@dougy22: Having Save As working is very weird. How many Chrome processes do you see in the Windows' Task Manager?

Could you install a Chrome Canary build and add
--log-net-log --enable-logging --log-level=0
to the command line, visit google.com and post the resulting log?
Comment 16 by zeni...@gmail.com, Sep 30 2010
Same issue.  Noticed the same "Save As" behavior.  Nothing is displayed, processor use spikes and chrome hangs.

Here's a log from Chrome Canary build /w --log-net-log --enable-logging --log-level=0
chrome_debug.log
152 KB View Download
Comment 17 Deleted
Comment 18 by zeni...@gmail.com, Sep 30 2010
And there are 2 chrome processes running, one with 50% CPU use (maxing out one of my CPUs) The only way to get it to stop is to kill the process.
Interesting. I didn't thought we would actually navigate anywhere without renderers, but we do!. I just tried that and works as described here.

So, please ignore comment 15.

Now, going back to the real issue... all sandboxed renderers are gone, and that fits pretty well with the other reports already mentioned.

If you can generate a crash dump we could look at that. See http://www.google.com/support/chrome/bin/answer.py?hl=en&answer=107348

... although most of the time the crash is too early to even generate a dump. Maybe a forced crash of the main process has something interesting. 
Comment 20 by zeni...@gmail.com, Sep 30 2010
Not getting any output from Chrome in the event viewer (even when the process is force closed.)

Just checked and Chrome *does* work in safe mode correctly, but does not work when I boot into windows in diagnostic startup with msconfig. (Basic devices and services only)

Is there any information that I'd be able to provide to help diagnose the problem?
To force the generation of a crash see:
http://www.chromium.org/for-testers/bug-reporting-guidelines/reporting-crash-bug

Note that in this case, a simpler way to do it is to use Windows' Task Manager, right-click the process you want to dump and select "Create Dump File". It is quite likely that malware will hide itself when doing this, though.
Hi all,

Does this help? From process explorer (see attached). Looks like it's hanging on "chrome.exe!SetGpuInfo+0x4578b" but I have no idea.

This is the same Windows 7 64-bit Enterprise Lenovo W510 I had the issue on earlier. By the way, using 258.6 Nvidia drivers for my Quadro FX 880M.
Chrome--Hang on Open Bug.png
78.1 KB View Download
Comment 23 by cpu@google.com, Oct 1 2010
kamran, the offset on the top of the stack trace is too large (+0x4578b) for that to be usable but just in case I'll have one of the GPU people to take a look.

Comment 24 by zeni...@gmail.com, Oct 2 2010
@kamran.ayub Wow, thank you! That screen shot was very helpful!  I checked out my own problem in process explorer and looked at the thread's stack and found EXACTLY what was injecting code and breaking Chrome.  

It turns out Airfoil's "Instant Hijack" was the issue as detailed here http://groups.google.com/group/google-chrome-help-troubleshooting/browse_thread/thread/dce3c75416dbd81d/b3dfabf13a9d545d?hl=en&lnk=gst&q=vista+x64#b3dfabf13a9d545d

I've attached a screenshot which you can see clearly points out the issue.

Last time I'm going to my friends's house with his crappy Apple TV. Google ftw.
chromefixed.jpg
218 KB View Download
Comment 25 by doug...@gmail.com, Oct 5 2010
I've found that the current standard release of Chrome DOES WORK with a clean installation of Windows 7 Enterprise 64-bit. Whilst it DOES NOT WORK with my company's packaged/customised installation of Windows 7 Enterprise 64-bit.

Sorry for the confusion, I'd suggest that this issue can be closed as this fresh install proves that there's definately not a compatibility issue with Windows7 Enterprise 64-bit as I reported it and instead the issue I'm observing must be of a differnt nature.

I'll try and isolate the issue within our desktop build a bit further, and if necessary post a new issue.

Thanks for the help.

Dougy
Comment 26 by zeni...@gmail.com, Oct 5 2010
Try process explorer->thread->stack like I'd mentioned, it may be able to point you in the right direction as it did with my problem with identical symptoms.  The problem bug(?) seems to be a general incompatibility with various software that injects code into chrome (the intention being malicious or, likely more commonly, quite benign).

I'm assuming for whatever reason, these various programs prevent the sandbox from executing properly, hence the observed behavior.
Comment 27 Deleted
Labels: Feature-GPU-Internals
Labels: -Feature-GPU-Internals
[undo]
Comment 30 by Deleted ...@, Dec 1 2010
My company is running a product from "BeyondTrust" called "Privilege Manager". This program wasn't actually doing anything on my computer (no rules for changing the process execution were in effect). However, removing this software resolved this problem.
Comment 31 by cpu@chromium.org, Dec 1 2010
dougy22: thanks for letting us know. Sorry we could not be of more help.

hansjust: Good to know. Can you open a bug/issue with BeyondTrust about this? It helps when an actual customer does it and I can't really test that kind of product easily here.

I can also confirm this issue is happening with BeyondTrust installed, though we cannot uninstall it. I will notify the folks in charge of BT and see if they can look into it.
BeyondTrust says this is fixed in a pre-release version. We tested it and it does fix the issue... hopefully if you are in a company, they will upgrade when it gets released.
Comment 34 by Deleted ...@, Dec 7 2010
I have installed the pre-release version 4.9.3 and it appears to have fixed the problem with Chrome. However, unrelated to Chrome, this version now seems to have problems with LANDesk Remote Control client... grrr. At least Chrome works now I guess.
Status: WontFix
Looks like there's nothing to do here.
Same problem with Google Chrome 21.0.1180.89 m on WindowsXP running AVG Free
Project Member Comment 37 by bugdroid1@chromium.org, Oct 14 2012
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 38 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-Internals -Internals-Core Cr-Internals Cr-Internals-Core
Sign in to add a comment