New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 49686 link

Starred by 4 users

Issue metadata

Status: Fixed
Owner:
Not on Chrome anymore
Closed: Aug 2010
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 1
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

Plug-in documents don't load properly

Project Member Reported by progame@chromium.org, Jul 20 2010

Issue description

i only tried it using Acrobat (Chrome PDF Viewer is currently not downloadable in the extensions site).

when plugins are blocked in the content settings, if you open a link to a PDF document, clicking on the load plugin caption doesn't do much and eventually crashes the Acrobat plugin

tested using 6.0.473.0 (53071) under windows XP
 

Comment 1 by prog...@gmail.com, Jul 22 2010

tested it with Chrome PDF Viewer, it didn't crash the plugin like with acrobat but it did not load the pdf (black screen instead)
 issue 50151 

Comment 3 by bauerb@chromium.org, Jul 26 2010

 Issue 50151  has been merged into this issue.

Comment 4 by bauerb@chromium.org, Jul 26 2010

Status: Assigned
Summary: PDF plug-in doesn't work

Comment 5 by bauerb@chromium.org, Jul 26 2010

Labels: -Pri-2 Pri-1

Comment 6 by bauerb@chromium.org, Jul 26 2010

Labels: -Feature-Privacy Feature-Plugins Feature-PDF Internals-Plugins

Comment 7 by bauerb@chromium.org, Jul 26 2010

Labels: -Feature-PDF
Summary: Plug-in documents don't load properly
The PDF plug-in seems to have a separate problem in the current Dev channel ( issue 46929 ). 

Comment 8 Deleted

Comment 9 Deleted

Comment 10 Deleted

Comment 11 by prog...@gmail.com, Jul 31 2010

using 6.0.480.0 Canary build, with plugins disabled in the content settings, and using the PDF Viewer plugin

without the click to play flag nothing happens when i click on a link to a PDF document (try to google for "pdf example" and enter one of the links)

if i use the click to play flag i see the plugin as blocked and as described before clicking on it doesn't load the document.
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=54523 

------------------------------------------------------------------------
r54523 | bauerb@chromium.org | 2010-08-02 02:17:20 -0700 (Mon, 02 Aug 2010) | 6 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/renderer/blocked_plugin.cc?r1=54523&r2=54522
   M http://src.chromium.org/viewvc/chrome/trunk/src/webkit/glue/plugins/webview_plugin.cc?r1=54523&r2=54522
   M http://src.chromium.org/viewvc/chrome/trunk/src/webkit/glue/plugins/webview_plugin.h?r1=54523&r2=54522

Record received data in WebViewPlugin and replay it when loading the real plugin.

BUG= 49686 
TEST=Block all plugins, directly open a page that is displayed by a plugin (an SWF file, or a PDF if the plugin works), and click on the placeholder. The plugin should load normally.

Review URL: http://codereview.chromium.org/3038027
------------------------------------------------------------------------

Status: Fixed
Project Member

Comment 14 by bugdroid1@chromium.org, Oct 12 2012

Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 15 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-Internals -Feature-Plugins Cr-Internals Cr-Content-Plugins
Project Member

Comment 16 by bugdroid1@chromium.org, Apr 6 2013

Labels: Cr-Blink
Project Member

Comment 17 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content-Plugins Cr-Internals-Plugins

Sign in to add a comment