Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Issue 49621 some downloaded files are saved with double extension (ex: file.arj.arj)
Starred by 28 users Reported by cony2...@gmail.com, Jul 20 2010 Back to list
Status: Duplicate
Owner:
Closed: Sep 2010
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 3
Type: Bug-Regression

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
Chrome Version       : 6.0.472.0 (53017)
URLs (if applicable) :
Other browsers tested: IE8
Add OK or FAIL after other browsers where you have tested this issue:
Safari 4:
Firefox 3.x:
IE 7:
         IE 8: OK

What steps will reproduce the problem?
1. Open for example ftp.microsoft.com
2. go to folder /MISC/ for example
3. try to download file PRODUCT.TBL

What is the expected result?
file PRODUCT.TBL to be shown in the download manager / folder

What happens instead?
file PRODUCT.TBL.TBL is shown in the download manager / folder

Please provide any additional information below. Attach a screenshot if
possible.

This is not happening for txt or exe files

 
error.png
49.6 KB View Download
Comment 1 by mkte...@gmail.com, Jul 20 2010
Issue 49480 has been merged into this issue.
Comment 2 by mkte...@gmail.com, Jul 20 2010
Labels: Feature-Downloads
Status: Untriaged
Issue 49480 reported this happening on 6.0.466.0 with .zip and .rar extensions as well.
Just to be clear: 

Reported by marfabilis, Jul 18 (41 hours ago) 6.0.466.0
Reported by cony2you, Today (11 hours ago) 6.0.472.0

30 hours later and I've got a duplicate post LOL..OK
The most important thing is that it can be fixed.

Regards,

Marco

Comment 4 by tha...@chromium.org, Jul 20 2010
Labels: -Pri-2 -Area-Undefined Pri-1 Area-UI Regression
Related to your renaming CL?
Comment 5 by estade@chromium.org, Jul 20 2010
Mergedinto: 48346
Status: Duplicate
once again, not related
Comment 6 by tha...@chromium.org, Jul 20 2010
I'll just blame every new download bug on kinuko :-P
Not fixed yet.
This issue is also occuring with .KEY and .OTF files
Comment 8 by estade@chromium.org, Jul 22 2010
Labels: -Pri-1 -Regression Pri-2 OS-Windows
Mergedinto: -48346
Status: Unconfirmed
my mistake, I don't think this is actually related to bug 48346
Comment 9 by dhw@chromium.org, Jul 22 2010
Issue 49903 has been merged into this issue.
Labels: -Pri-2 Pri-1 Regression
Status: Assigned
on second thought, I am siding with thakis. I guess I got this mixed up with 48346; should have been more careful about duping it.
Hmm the original bug was reported before I submitted my patch, so I don't think this is a regression of my change - or so I hope.  (Trying to look at it but currently I have some problems on my Windows build)

Google Chrome	6.0.472.0 (53024) dev
WebKit:	534.3
V8:	2.3.1
Seems like I hit another bug (issue 49997) while testing this.

I can´t reproduce that bug here.
I don't know why but I cannot reproduce this (double extension) on my build.   Does that have some other conditions to reproduce?

Tested url: ftp://ftp.microsoft.com/MISC/PRODUCT.TBL
Chromium:	6.0.475.0 (Developer Build 53413)
WebKit:	534.3
V8:	2.3.2

Maybe coz you´re using the version 6.0.475.0 (Developer Build 53413)
This issue occurs in 6.0.466 & 6.0.472 (.zip, .rar, .otf, .key and others)
if you choose 'all files', chromium won't automatically add extension.
Status: Available
I was able to repro with the steps from one of the other reports. Right click->save as on one of the .emp links at http://empop.org/modules/downloads/ on Windows (not Linux), it will save with .emp.emp. I managed it with r53429.
Status: Assigned
a bisection reveals the regression to have occurred between r51869 and r51878; I strongly suspect r51870: http://codereview.chromium.org/2893001

Labels: Mstone-6 ReleaseBlock-Stable
I just committed this on behalf of an external contributor.  It would be nice if someone else could debug this as I'm really way overwhelmed right now.
If that's the case, I'd say reverting is the best option, and letting the external contributor fix it and resubmit.
Comment 22 by mkte...@gmail.com, Jul 24 2010
Issue 50122 has been merged into this issue.
Comment 23 by dhw@chromium.org, Jul 26 2010
Issue 50202 has been merged into this issue.
Comment 24 by dhw@chromium.org, Jul 26 2010
Issue 50158 has been merged into this issue.
This needs to be fixed for m6. I'll see that I at least get the regressing CL reverted on the branch.
Comment 26 by mkte...@gmail.com, Jul 26 2010
Issue 50270 has been merged into this issue.
Issue 50449 has been merged into this issue.
6.0.472.11 dev
Not fixed.
Comment 29 by mkte...@gmail.com, Jul 29 2010
Issue 50614 has been merged into this issue.
Can confirm this issue on 6.0.472.11 dev on win7 x64
Issue 50889 has been merged into this issue.
6.0.472.14 dev not fixed :(
Status: Started
Guys, nobody says this has been fixed. Silently star bugs you're interested in. Saying "not fixed" on bugs that are still open doesn't help anyone.
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=54625 

------------------------------------------------------------------------
r54625 | thakis@chromium.org | 2010-08-02 15:56:40 -0700 (Mon, 02 Aug 2010) | 6 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/views/shell_dialogs_win.cc?r1=54625&r2=54624
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/views/shell_dialogs_win_unittest.cc?r1=54625&r2=54624

Win: Don't give some downloads duplicate extensions like .arj.arj

BUG= 49621 
TEST=See bug. Also unittests.

Review URL: http://codereview.chromium.org/3069018
------------------------------------------------------------------------

Labels: ForMerge
Status: Fixed
As usual, "Fixed" means that the fix has landed. It does not mean that the landed fix is on the dev channel yet. That will take a week or two.
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=54803 

------------------------------------------------------------------------
r54803 | thakis@chromium.org | 2010-08-03 13:10:29 -0700 (Tue, 03 Aug 2010) | 9 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/472/src/chrome/browser/views/shell_dialogs_win.cc?r1=54803&r2=54802
   M http://src.chromium.org/viewvc/chrome/branches/472/src/chrome/browser/views/shell_dialogs_win_unittest.cc?r1=54803&r2=54802

Merge 54625 - Win: Don't give some downloads duplicate extensions like .arj.arj

BUG= 49621 
TEST=See bug. Also unittests.

Review URL: http://codereview.chromium.org/3069018

TBR=thakis@chromium.org
Review URL: http://codereview.chromium.org/2868101
------------------------------------------------------------------------

Comment 38 by Deleted ...@, Aug 5 2010
why is that google chrome not load  the specific sight...i mean  nothing at all
fixed with version 6.0.472.22
http://googlechromereleases.blogspot.com/2010/08/dev-channel-update.html

...and confirming, just checked.

This has only been partially fixed. Could this be re-opened?

Steps to reproduce problem:

1. Right-click a .tar.bz2 file 
2. Click Save link as...
2. Save it.
3. You will see it has a duplicate file extension (.tar.bz2.tar.bz2)

PDF Files are OK but I've not tested any other file extension. Downloading the file without using Save link as... does not give a duplicate file extension.
(Quick Note) I am using 6.0.495.0 (Official Build 56152) dev.
(Another Quick Note) Checking "Ask where to save each file before downloading" in Options also gives duplicate extensions (.tar.bz2.tar.bz2)
Comment 43 by thakis@google.com, Aug 22 2010
boellisa…: are you on linux?
No. I'm using Windows XP SP3.
Comment 45 by thakis@google.com, Aug 22 2010
Thanks. Can you check if the problem happens with http://build.chromium.org/buildbot/continuous/win/2010-07-06/51698/chrome-win32.zip as well?
Are you wanting me to test that download or test a file using that version of Chomium?
Comment 47 by thakis@google.com, Aug 22 2010
Please download that version of chromium and then using that version of chromium, download a tar.bz2 file and see if you get a duplicate tar.bz2 extension.
Comment 48 by thakis@google.com, Aug 22 2010
Please download that version of chromium and then using that version of chromium, download a tar.bz2 file and see if you get a duplicate tar.bz2 extension.
Nope. That version doesn't have the .tar.bz2 problem. 

While testing this, I ran into 2 other bugs. They are Issue 53105 (which does not happen in chromium r51698, only Chrome 6.0.495.0 dev) and Issue 53106 (which happens in both chromium r51698 and Chrome 6.0.495.0 dev).
Labels: -Mstone-6 Mstone-7
Status: Available
Comment 51 by kerz@chromium.org, Aug 23 2010
Labels: -ReleaseBlock-Stable
Comment 52 by kerz@chromium.org, Aug 23 2010
Labels: -ForMerge
Comment 53 by kerz@chromium.org, Aug 23 2010
Labels: ReleaseBlock-Stable
Comment 54 by kerz@chromium.org, Aug 23 2010
Labels: -ReleaseBlock-Stable
Labels: -Pri-1 -Mstone-7 Pri-3 Mstone-X HelpWanted GoodFirstBug
Reprioritizing since double-extensions files aren't all that common in the windows world.
Comment 56 by rkat...@gmail.com, Sep 25 2010
Another issue related to double extension:

What steps will reproduce the problem?
Case 1. Open the address: http://www.kattanweb.com/chrome/bug1.zip
Case 2. Open the address: http://www.kattanweb.com/chrome/bug2.ZIP (notice the capital letter extension)

What is the expected result?
In both cases you should download the desired file, keeping the same name

What happens instead?
Case 1: works as expected
Case 2: a file named "bug2.ZIP.zip" is downloaded
Relating to the zip extension bug....what version of windows and what version of chromium? 

I'm windows 7 and just built/ran the latest svn build and I can't reproduce it. Both bug1.zip and bug2.ZIP are downloaded, with no additional extension. 
I think this is another one that would be fixed if we got rid of the extension renaming code. Adam, before we go down that path, do we need a security review?
I'm happy to review the patch for security.  :)
Mergedinto: 57080
Status: Duplicate
Labels: -GoodFirstBug bulkmove Hotlist-GoodFirstBug
Mergedinto: -0
Chrome Version       : 6.0.472.0 (53017)
URLs (if applicable) :
Other browsers tested: IE8
Add OK or FAIL after other browsers where you have tested this issue:
Safari 4:
Firefox 3.x:
IE 7:
         IE 8: OK

What steps will reproduce the problem?
1. Open for example ftp.microsoft.com
2. go to folder /MISC/ for example
3. try to download file PRODUCT.TBL

What is the expected result?
file PRODUCT.TBL to be shown in the download manager / folder

What happens instead?
file PRODUCT.TBL.TBL is shown in the download manager / folder

Please provide any additional information below. Attach a screenshot if
possible.

This is not happening for txt or exe files
Labels: -Regression Type-Regression
Chrome Version       : 6.0.472.0 (53017)
URLs (if applicable) :
Other browsers tested: IE8
Add OK or FAIL after other browsers where you have tested this issue:
Safari 4:
Firefox 3.x:
IE 7:
         IE 8: OK

What steps will reproduce the problem?
1. Open for example ftp.microsoft.com
2. go to folder /MISC/ for example
3. try to download file PRODUCT.TBL

What is the expected result?
file PRODUCT.TBL to be shown in the download manager / folder

What happens instead?
file PRODUCT.TBL.TBL is shown in the download manager / folder

Please provide any additional information below. Attach a screenshot if
possible.

This is not happening for txt or exe files
Project Member Comment 63 by bugdroid1@chromium.org, Oct 13 2012
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 64 by bugdroid1@chromium.org, Mar 9 2013
Labels: -Area-UI -Feature-Downloads -Type-Regression Type-Bug-Regression Cr-UI Cr-UI-Browser-Downloads
Project Member Comment 65 by bugdroid1@chromium.org, Aug 4 2015
The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/d79f1ac6d572f795fd8e2522fe4a731d1f66260c

commit d79f1ac6d572f795fd8e2522fe4a731d1f66260c
Author: petermayo <petermayo@chromium.org>
Date: Tue Aug 04 19:53:44 2015

Reference written files relatively when possible.

The intermediately generated files are children of the output build
directory and shouldn't need long absolute path references that
change more often than necessary.

BUG= 49621 
TEST=Equivalence of build files, see https://code.google.com/p/chromium/issues/detail?id=469621#c3

Review URL: https://codereview.chromium.org/1256043006

Cr-Commit-Position: refs/heads/master@{#341768}

[modify] http://crrev.com/d79f1ac6d572f795fd8e2522fe4a731d1f66260c/tools/gn/ninja_build_writer.cc

Sign in to add a comment