New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 18 users

Issue metadata

Status: Duplicate
Merged: issue 485482
Owner:
Closed: Jun 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 2
Type: ----

Blocked on:
issue 490985



Sign in to add a comment
link

Issue 494620: Video texture does not display

Reported by s...@vrideo.com, May 31 2015

Issue description

Device name: Samsung Galaxy Note 4

Application version: Chrome 43.0.2357.78
OS: Android 5.0.1

URLs (if applicable): http://d8d913s460fub.cloudfront.net/krpanocloud/video/airpano/index.html

Behavior in Android Browser (if applicable):
Video texture is not displayed. Only sound.

Steps to reproduce:
1. Go to http://d8d913s460fub.cloudfront.net/krpanocloud/video/airpano/index.html
2. Click play

Expected result: Video to play on texture

Actual result: Black screen

Console warnings: 

[.WebGLRenderingContext-0xa1160400]RENDER WARNING: texture bound to texture unit 0 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering.
 

Comment 1 by klaus.re...@gmail.com, Jun 1 2015

This bug is new since Chrome 43.0.2357.78.
It seems all Android devices are affected.

Here a very simplified example for this Chrome bug:

http://krpano.com/android/chrome-43-black-video-webgl/

Comment 2 by benjamin...@gmail.com, Jun 1 2015

Same for me on Chrome 43.0.2357.78 (Nexus 5).
Works with Chrome-Dev.

Comment 3 by ecefly...@gmail.com, Jun 1 2015

Yes, this is a critical problem for me too in Chrome 43.0.2357.78.  How could this be suddenly broken?  Please fix.

Comment 4 by ppolise...@chromium.org, Jun 1 2015

Labels: Cr-Blink-WebGL triaged
Owner: skyos...@chromium.org
Status: Assigned
Hello

Thanks for reporting this issue. This issue is reproducible.
Devices used:
Nexus 4(Android Version 5.0), Samsung Galaxy S5(Android Version 5.0)
Chrome stable: 43.0.2357.78
Chrome Dev: 44.0.2403.20

The video plays on Chrome Dev on Nexus 5, after the black space of the video is clicked on. Video does not play on Chrome Stable on Nexus5 and Samsung S5(on both stable and Dev).

Comment 5 by kbr@chromium.org, Jun 1 2015

Blockedon: chromium:490985
Cc: siev...@chromium.org kbr@chromium.org qin...@chromium.org dongseon...@intel.com skyos...@chromium.org
Mergedinto: 485482
Owner: kbr@chromium.org
Status: Duplicate
Apologies for the regression. We have not been running the video-related WebGL conformance tests on our automated testing system until just recently. This is a duplicate of another recently filed bug and I'll request that the fix be merged back to M43.

Comment 6 by dongseon...@intel.com, Jun 2 2015

Sorry for inconvenience. I should test webgl conformance tests. I just tested few sites.
kbr, thx for handling it.

Comment 8 by electrot...@gmail.com, Jan 4 2016

Hi I've updated here with more details. The problem is still an issue with current dev, beta and production browsers version 48/49. My issue is not black screen but complete artefacts. 

https://code.google.com/p/chromium/issues/detail?id=485482

Sign in to add a comment