New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 482932 link

Starred by 18 users

Issue metadata

Status: Duplicate
Merged: issue 617859
Owner:
Last visit > 30 days ago
Closed: Jun 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug



Sign in to add a comment

Chrome remote desktop not playing sound

Reported by charles....@gmail.com, Apr 30 2015

Issue description

Chrome Version       : Google Chrome	41.0.2272.118 (Official Build) m
Revision	94ac154e3d74de6a6a0ea008e7e7b69cd5960cb2-refs/branch-heads/2272@{#458}
OS	Windows 

URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 6:
Firefox 20:
IE 7/8/9/10:

What steps will reproduce the problem?
No sound plays when I try to play a video on my chromebook from my windows 7 desktop through chrome remote desktop.

What is the expected result?


What happens instead?


Please provide any additional information below. Attach a screenshot if
possible.

 
Cc: sergeyu@chromium.org
Labels: Cr-Services-Chromoting
Owner: ajnolley@chromium.org
Hi Andrew, could you please try to repro this? Thanks.
Status: Assigned
I was unable to reproduce this. Sound played correctly from a Peppy; 44.0.2385.3 dev;Platform 7019.0.0 to Windows 7 with Host version 43.0.2357.39. However, I have seen some Chrome OS issues that are specific to a model or more commonly to a range of similar models, such as Intel processors vs ARM processors. Charles.Obba: What is the model of Chromebook? In the meantime, I'll check again on release channel of this device as well.

Comment 5 by Deleted ...@, May 15 2015

I am using the following version of chrome:
Version 42.0.2311.134 (64-bit)
Platform 6812.83.0 (Official Build) stable-channel parrot
Firmware Google_Parrot.2685.37.0

And the following model of chromebook:
Acer Chromebook
Intel Celeron CP 847 @ 1.10 GHz

I checked again with Parrot, 42.0.2311.134 and I can still play sound. 

When connecting to the Windows 7 machine, is the audio icon on the taskbar crossed out to indicate there is no audio, or does the icon indicate that audio is functioning?
The audio icon on the taskbar is not crossed out and is showing that audio is turned and functioning. When I disconnect the remote desktop, the audio from video continues to play through the speakers connected to the windows 7 desktop. 
Status: Untriaged
I have finally been able to reproduce this, from OSX with Beta Channel of Chrome 44.0.2403.30, using the QA app 44.0.2403.25. 
Owner: ----
AJ, was Mac the host or client platform in your test? What OS was the other end of the connection?
I only saw this with a windows Host and Yosemite as client. I was unable to repro with any other client or host. 
Was the host curtained?
No, when curtained it behaves appropriately, in that the audio taskbar icon in Windows shows that audio is disabled, and audio does not work. When not curtained, the audio icon shows that audio should be working, but no audio is remoted. 
Owner: kelv...@chromium.org
Status: Assigned
Kelvin, it looks like this is a client-side issue. Can you take a look?

Comment 15 by tri...@gmail.com, Sep 6 2015

I cannot play audio with:
OSX host
Linux or ChromeOS client

I've played audio just fine with other Windows and Linux hosts using ChromeOS/Linux/Windows/Mac as clients.

Comment 16 by Deleted ...@, Sep 7 2015

@triune: Unfortunately, remote audio is not supported for a Mac host. This bug is about a Windows host.
Same issue here with a 2013 Chromebook Pixel (client) and Windows 10 (host). Audio is only ever played on the host, never on the client.

I have allowed the Chrome Remote Desktop service on the Windows host to interact with the desktop, fully updated and restarted both machines. Still the issue persists.


ChromeOS:
Version 45.0.2454.98 (64-bit)
Platform 7262.57.0 (Official Build) stable-channel link
Firmware Google_Link.2695.1.156

Windows:
Microsoft Windows 10 Pro
10.0.10240 Build 10240
x64-based-PC
Intel(R) Core(TM) i5-3210M CPU

Comment 18 by tri...@gmail.com, Mar 17 2016

I had this issue when connecting to an Ubuntu 12.04 machine. It was upgraded recently to 14.04 and after the upgrade audio began to work.
Having the same issue. Host: Windows 10 Pro, Sound 5.1 CMedia set to 16 bits 44mhz. 
Client is a Pixel 2 Chromebook. Both updated to whatever is current.
But, I'm also trying a Windows 10 client and also get no sound. I don't think it's a client issue.
Read somewhere that sound from a Windows host to an Android device is not supported. Is it still true ? I have a Win10 PC (64 bit) with Chrome and Chrome Remote Desktop installed.  But on my Samsung S6 phone and my LG tablet, I just don't  get any sound from my Win10 PC.  I know CRD is free but it would be great to get the sound from the PC so to understand better what's going on on the host. Thanks !

Comment 21 Deleted

I have the same issue. Windows 10 host and mint Linux client. No audio on Remote Desktop. Allowed service to interact with desktop.

Comment 23 by pgr...@gmail.com, Jun 8 2016

I can confirm the issue using an Acer C720 remoting into Windows 10 and 7 machines. It used to work without an issue. 

Remote Machine 1: Windows 10. Static IP address. Wired connection. Local audio plays fine even when you remote into it. 

Remote Machine 2: Windows 7. Static IP address. Wifi connection. Local audio plays fine even when you remote into it. 

It appears to have started after this version: 

Local Machine Test 1: Acer C720 Version 50.0.2661.103 (64-bit) Platform 7978.74.0 (Official Build) stable-channel peppy Firmware Google_Peppy.4389.93.0 

It continued with this version:

Local Machine Test 2: Acer 720 Version 51.0.2704.79 (64-bit) Platform 8172.47.0 (Official Build) stable-channel peppy Firmware Google_Peppy.4389.93.0

Chrome Remote Desktop Version: 51.0.2704.53 on all machines. 

Tested through wired and wifi, as well as VPN connections. None worked. 

Please let me know if you need additional information. Thank you for your attention to this issue.
I also have this issue on CRD host version 51.0.2704.7. If i revert to the previous version of the host 47.0.2526.18, audio works again. Unfortunately CRD automatically updates me back to the latest version. Does anyone know of a way to prevent the auto-updating in the interim?
This seems to be an issue and I am wondering if the Google Chrome team are addressing the issue. 

Simply put, the update has completely shut down sound on CRD since the past week. And it used to work absolutely fine. CRD is a fantastic service and I hope this can get resolved and fixed soon!
Owner: ajnolley@chromium.org
AJ, I suspect that this is not the same issue that you repro'd last year, but can you take a look and see if you can repro it with the latest release?
I have a Windows 10 desktop and laptop.

No sound connecting to either from ASUS Chromebook Flip 4GB.
I happen to be on 52.0.2743.32 dev chanel - so assumed this was the problem.

But there is no Sound from either of the Windows 10 devices connecting to each other either.
Both are on Chrome 51.0.2704.84 m

CRD version is 51.0.2704.53 on all three devices.

Looking forward to a fix as I use CRD to my desktop for basic audio/video editing away from my desk!

#CBC-RS/TC-watchlist

Comment 29 by smr...@gmail.com, Jun 9 2016

This issue Chrome Remote Desktop not playing sound has returned showing on two Chromebooks accessing two Windows 10 machines remotely. I have tested the problem using two different Chromebooks each attempting to access two different Windows 10 computers (one is a Dell and the other an Asus). Both attempts to transmit sound from the Windows 10 units fail. I have also tested using the same two chromebooks accessing a Window 7 computer remotely. The Windows 7 computer transmits sound satisfactorily in both instances. The two Windows 10 computers transmit no sound. On each of the Chromebooks I am running Version 50.0.2661.104 (64-bit), Platform 7978.76.0 (Official Build) stable-channel auron_yuna.

It is probably not be relevant, but both of the Windows 10 computers which failed to transmit sound using Chromeremote are touchscreen computers (with physical keyboards as well).  All other aspects of ChromeRemote, other than sound transmission, function well on those two Windows 10 computers.

this is reproducible on any CrOS channel with the current released Host and Client. This does not occur with the previous release. I also checked with an M52 Host, 52.0.2743.33 and the issue does not occur. 
This is not just a ChromeBook issue, but is reproducible using CRD between any of my systems regardless of which is the local and which is the remote... from/to my i3HP all-in-one (Win 10), my i7HP laptop (Win 10), my HP ChromeBook -- all of which worked fine UNTIL the latest release, to which irritatingly enough each system upgraded itself automatically...

This is absolutely a bug in release 51 on Windows 10 machines as stepping back down to release 50 fixes the audio issue: https://productforums.google.com/d/msg/chrome/59-pB4bAk0s/2Ekz9V6GAAAJ
Owner: zijiehe@chromium.org
Zijie, can you take a look?
Sorry, it's definitely my fault. A bug was introduced by change https://goo.gl/SUJ5aT, and fixed by change https://goo.gl/X90D1A. This change impacted versions between 2675 to 2706. So M51 is impacted, M52 should be fine.
Duplicate as  http://crbug.com/617859 .
Mergedinto: 617859
Status: Duplicate (was: Assigned)
Issue is still occurring in 53.0.2785.116 m

Using Windows 7 Professional SP1 x86, connecting to:
Win10 Home version 1511 BNuild 10586.589 x64
Hi, CStud...@telkonet.com,
May I know your hardware configuration?

Several issues I can imagine,
1. Starting from M52, the sound volume is controlled by both local and remote machines, so you need to unmute both machines to get the audio playback.
2. A code defect in M53 and earlier version causes the audio playback to be stopped if the default playback device has been changed (Screenshot https://goo.gl/Z68ySr). This issue has been fixed in https://chromium.googlesource.com/chromium/src/+/b40182aceb9f9ab588a296ace041360fa40bac88, and will be published through M54. Before M54 is released, if you do need to change playback device, you have to reconnect the client.
For people that may still be coming here, a workaround for the issue is to put your Windows 10 hosts in curtain mode.

Follow the instructions here: https://www.reddit.com/r/chromeos/comments/5nud7f/enabling_chrome_remote_desktop_curtain_mode_for/ 

(To get to the group policy settings, you need to run gpedit.msc from a command prompt or the 'run' prompt [windows key + R])

Sign in to add a comment