New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 478714 link

Starred by 42 users

Issue metadata

Status: Fixed
Owner:
Last visit > 30 days ago
Closed: May 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 2
Type: Bug-Regression



Sign in to add a comment

Chrome icons aren't working (blank white box instead)

Reported by glaj...@gmail.com, Apr 20 2015

Issue description

UserAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.90 Safari/537.36

Steps to reproduce the problem:
1. Install version 43 or higher
2. Chrome UI Icon is gone from app, tray, and alt+tab UI

What is the expected behavior?
The chrome icon should appear

What went wrong?
This is actually the second time icons have regressed.  First you took away the ability to show the profile-specific icons when alt+tabbing, now the icons are just broken period, showing a blank white box where the icon should be.

Did this work before? Yes Version 42 and lower.  If I go back to stable instead of the beta channel (which I just did), it is fixed.  If I try to re-install beta again (43) it breaks again.

Chrome version: 43.0.2357.18  Channel: beta
OS Version: Mint 17 (3.14.1-031401-generic x86_64)
Flash Version: Shockwave Flash 17.0 r0

I have another Linux VM and I tried going to beta there as well and it broke there.
 
Cc: brajkumar@chromium.org
Labels: Needs-Feedback
Unable to reproduce the issue on Ubuntu 14.04 using chrome - 44.0.2376.0.
Observed the chrome icon appears while switch to tray using alt+tab.

Note - Attached screen-cast for reference

glajchs - Could you please recheck this issue by reinstalling the chrome, If issue still persists provide a screen-cast will help further.
Thanks! 
ChromeIcon.ogv
2.3 MB Download

Comment 2 by glaj...@gmail.com, Apr 30 2015

So I have some more information on this.  I'm seeing this issue on my home machine and work machine (which are both Mint 17 XFCE, which based on Ubuntu 14.04).

I downloaded a stock Ubuntu 14.04 VM and did not reproduce the issue, and then installed XFCE as the window manager and was able to reproduce the issue.

I'm guessing whatever combination of icon Gnome/Unity uses in stock Ubuntu is working but the one XFCE is using does not work.

If you have an Ubuntu VM, the easiest way to install XFCE is to just run "sudo apt-get install xubuntu-desktop".  Then restart, and on the login screen change from the default login to XFCE.  I was able to reproduce the problem in XFCE (no icons), then log out and back in using the default Unity session and the icons worked there.
google-chrome-beta-icon-problem-xfce.ogv
4.1 MB Download

Comment 3 by mdm@chromium.org, May 11 2015

 Issue 484079  has been merged into this issue.

Comment 4 by mdm@chromium.org, May 11 2015

Cc: mdm@chromium.org
Labels: -Type-Bug -Needs-Feedback Type-Bug-Regression
Status: Available
I see this also in the icons in the "tint2" taskbar, even in GNOME. They're all the generic "application window" icon rather than the icon for the active tab in each window.

Comment 5 by mdm@chromium.org, May 11 2015

generic-icon.png
4.5 KB View Download

Comment 6 by mdm@chromium.org, May 11 2015

Looks like this broke somewhere between change 317790 and change 317956.
Owner: xiaolingbao@chromium.org
Status: Assigned
mdm@ and I bisected this to r317927.
Looks the bug surfaced because UpdateWindowIcon is called during widget initialization:
1) DesktopWindowTreeHostX11::InitX11Window() get Chrome icon from ViewsDelegate::views_delegate->GetDefaultWindowIcon(), and then set it to browser by calling SetWindowIcons().
2) Widget::UpdateWindowIcon() is called in BrowserFrame init process (newly introduced by r317927).
3) The function above calls BrowserView::GetWindowIcon() to get the icon, which returns an empty ImageSkia.
4) The empty icon is passed to DesktopWindowTreeHostX11::SetWindowIcons(), which deletes the existing icon because the new one is empty.

This issue does not affect Windows version because HWNDMessageHandler::SetWindowIcons() does not delete existing icon if the new icon is empty. This indicates that we can fix the issue by not deleting the existing icon in DesktopWindowTreeHostX11::SetWindowIcons() if new one is empty. But logically, if BrowserView::GetWindowIcon() can always return the wanted icon is a better fix.

Comment 9 by snas...@gmail.com, May 20 2015

I can confirm the issue, Debian 8/Jessie, Chrome Version 43.0.2357.65 (64-bit)

Comment 10 by e...@genesis.se, May 20 2015

I can confirm this on CentOS 6, Chrome version: Version 43.0.2357.65 (64-bit)
I can confirm this on 14.0, Chrome version: 43.0.2357.65 (64-bit)
Confirmed for Ubuntu 14.04.2 with Xfce 4.12, Chrome Version 43.0.2357.65 (64-bit)
Confirming this issue on Linux Mint 17.1, Chrome Version 43.0.2357.65 (64-bit).
I can confirm the issue, Xfce4, Chrome Version 43.0.2357.65 (64-bit) on Debian jessie/sid.

PS I think  issue #110339  is related/same.
Link: https://code.google.com/p/chromium/issues/detail?id=110339
Status: Fixed
Landed a fix a week ago: https://codereview.chromium.org/1138343003/.
Cc: est...@chromium.org e...@chromium.org
 Issue 110339  has been merged into this issue.
When can we expect to see the fix in chrome-stable?

Comment 18 by laforge@google.com, May 20 2015

Labels: Merge-Approved-44
Could someone merge that to M43 (2357)?

Comment 19 by laforge@google.com, May 20 2015

Labels: -Merge-Approved-44 Merge-Approved-43

Comment 20 by laforge@google.com, May 20 2015

Cc: xiaolingbao@chromium.org lafo...@chromium.org thestig@chromium.org anan...@chromium.org vivianz@chromium.org mmoss@chromium.org phajdan.jr@chromium.org
 Issue 490045  has been merged into this issue.
Status: Assigned

Comment 22 by glaj...@gmail.com, May 21 2015

Oh no, 43 is stable now!  Well they just added the tag "Merge-Approved-43", so I'm guessing the next point release of stable will have this.

Comment 23 by glaj...@gmail.com, May 21 2015

Speaking of icons, is the profile avatar icons being missing from alt+tab/taskbar ever going to be addressed?  This used to work and when it broke it hampered (and still hampers) my productivity.

See  Issue 351712 , Issue 377968,  Issue 475074 .  It seems that in windows the taskbar shows the avatars but alt+tab UI does not, and it shows in neither place in linux (again XFCE for me).

Comment 24 by laforge@google.com, May 22 2015

Labels: -Merge-Approved-43 Merge-Merged-2357
Manually landed - https://codereview.chromium.org/1146013005

Comment 25 by Deleted ...@, May 23 2015

Can confirm on Gentoo Linux with GNOME 2.32, Chromium Version 43.0.2357.65 (64-bit).

Comment 26 by Deleted ...@, May 23 2015

I can also confirm the patch supplied addresses this problem.  Updated gentoo ebuild can be found here: https://bugs.gentoo.org/show_bug.cgi?id=550242
I'm having this same issue under Lubuntu 14.04. 

Comment 28 by Deleted ...@, May 25 2015

Confirming this issue on Ubuntu 15.04 using MATE Desktop Environment 1.8.2 and Chrome Version 43.0.2357.65 (64-bit). 
A somewhat silly but effective workaround is to forcefully set the icon of Google Chrome windows from an external program. I'm using this script:

while true ; do for w in $(wmctrl -l | grep 'Google Chrome$' | cut
-d ' ' -f 1) ; do set-icon.py --img
/usr/share/icons/hicolor/48x48/apps/google-chrome.png --id $w ; done ;
sleep 5 ; done

You will need wmctrl and the set-icon.py script from https://github.com/benizi/dotfiles/blob/master/bin/set-icon.py

For Chromium I think the grep regex needs to be changed from 'Google Chrome$' to 'Chromium$'

Comment 30 by laforge@google.com, May 25 2015

43.0.2357.81 is pushing now and should resolve this issue.

Comment 31 Deleted

Comment 32 by srack...@gmail.com, May 25 2015

Confirmed: Resolved in Chrome 43.0.2357.81 (64-bit) on Ubuntu MATE 14.04.2.
Status: Fixed

Comment 34 by eranm@chromium.org, May 26 2015

Cc: eranm@chromium.org
 Issue 491065  has been merged into this issue.
Cc: sky@chromium.org
 Issue 471707  has been merged into this issue.

Sign in to add a comment