New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 37 users

Issue metadata

Status: Fixed
Owner:
Last visit > 30 days ago
Closed: Apr 2011
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux
Pri: 1
Type: Bug

Blocked on:
issue 47765
issue 49709

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Short audio files doesn't play properly

Reported by rh...@raymondhill.net, Jun 28 2010

Issue description

Chrome Version (from the about:version page):5.0.375.70 (48679) Ubuntu
Is this the most recent version:
OS + version:Ubuntu 10.04 (lucid)
CPU architecture (32-bit / 64-bit):64-bit
Window manager:Gnome
URLs (if relevant):http://www.raymondhill.net/puzzle-rhill/ff35-short-audio.php
Behavior in Linux Firefox:The second sound clip plays only one time out of two, and when it plays, it plays twice
Behavior in Windows Chrome (if you have access to it):

What steps will reproduce the problem?
1. Go to http://www.raymondhill.net/puzzle-rhill/ff35-short-audio.php
2. Play the second sound
3. Keep pressing the play button, the sound plays every other times, and it repeat twice in a burst when it does play

What is the expected result?
The sound plays once when the command play() is send.

What happens instead?
The sound doesn't play at all, then play twice every other times the play() command is issued

Please provide any additional information below. Attach a screenshot
and backtrace if possible.

 
Labels: -Area-Undefined Area-Internals Internals-Video
Labels: ffmpeg
I'll take this to confirm if this is fixed with updated ffmpeg
Status: Started
plays okay with updated ffmpeg (which is not available yet)

Comment 4 by karen@chromium.org, Jul 7 2010

Labels: Mstone-7

Comment 5 by karen@chromium.org, Jul 7 2010

Status: ExternalDependency
i'm going to mark this ext dep since we're waiting for the new ffmpeg to release?
Blockedon: 48037
Labels: -Mstone-7 Mstone-6
Status: Assigned
We're in control of said dependency and fbarchard is planning on updating the library in time for Mstone-6.
Labels: Pri-2
Applying default priority, in the future bugs set w/ no priority will get set to mstone:x pri:3
Labels: -Internals-Video -Area-Internals Feature-Media Area-WebKit
Blockedon: -48037 47765 49709
Labels: -Mstone-6 Mstone-7
We've fixed a bunch of the audio playback issues (so it shouldn't play twice/in bursts), but we're missing the very beginning part of the sound clip due to a bug in FFmpeg.

I've attached the before/after ffmpeg_unittest results based on when FFmpeg was at DEPS r49485 versus tip of tree (currently DEPS r54360)... so we introduced some sort of regression but I think it's the same root issue as  issue 49709 .

Punting out of Mstone-6 as a result.
crbug47761_ffmpeg_49485.txt
2.3 KB View Download
crbug47761_ffmpeg_54360.txt
2.8 KB View Download
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=54796 

------------------------------------------------------------------------
r54796 | scherkus@chromium.org | 2010-08-03 12:32:41 -0700 (Tue, 03 Aug 2010) | 9 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/media/ffmpeg/ffmpeg_unittest.cc?r1=54796&r2=54795

Adding two test cases to ffmpeg_unittest from user bug reports.

 Issue 47761  (short Ogg files don't play) is currently failing and requires fixing FFmpeg.
 Issue 50045  (MP4 moof atom playback issue) is currently passing as expected.

BUG= 47761 , 50045 
TEST=ffmpeg_unittests

Review URL: http://codereview.chromium.org/3043049
------------------------------------------------------------------------

Labels: -Mstone-7 Mstone-8
Labels: Mstone-9
mass bug punt
Labels: -Mstone-9 Mstone-X
Status: Available
I'm seeing similar behavior with short MP3 files (used for sound effects).  Sound will not play twice, or will play only after a long delay.  Sometimes the sound is clipped.  Very erratic.
 Issue 32956  has been merged into this issue.
Labels: -ffmpeg -Mstone-X Mstone-11
Summary: Short audio files doesn't play properly
 Issue 70147  has been merged into this issue.
 Issue 70711  has been merged into this issue.
Labels: -Pri-2 -Mstone-11 Pri-1 Mstone-12
Status: Assigned

Comment 20 by davej@chromium.org, Apr 19 2011

Owner: scherkus@chromium.org
Status: Fixed
Short WAV and MP3 files play properly now with http://codereview.chromium.org/6776024.  OGG files if using the default HTML5 UI controls don't want to play the very first 20ms or so of the file though, which is probably a different issue since before this fix, the file wasn't playing at all.

Committed: http://src.chromium.org/viewvc/chrome?view=rev&revision=81669

Labels: ImportantForGames

Comment 22 by fi...@mxd.cz, May 18 2011

CONFIRMED on Linux: Chromium 13 and Chrome 12 play badly the second try, Firefox 3.5 is okay, Opera 11 is okay
Project Member

Comment 23 by bugdroid1@chromium.org, Oct 13 2012

Blockedon: -chromium:47765 -chromium:49709 chromium:47765 chromium:49709
Blocking: -chromium:59691 chromium:59691
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Blocking: -chromium:59691
Project Member

Comment 25 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Feature-Media -Area-WebKit -Mstone-12 Cr-Content Cr-Internals-Media M-12
Project Member

Comment 26 by bugdroid1@chromium.org, Mar 13 2013

Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Project Member

Comment 27 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink

Sign in to add a comment