New issue
Advanced search Search tips
Starred by 10 users

Issue metadata

Status: Duplicate
Merged: issue 453263
Owner: ----
Closed: Apr 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

Latest Java not working with Chrome 42

Reported by xro...@gmail.com, Apr 14 2015

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.90 Safari/537.36

Example URL:
https://www.java.com/en/download/installed.jsp

Steps to reproduce the problem:
1. Install Java
2. Visit any page using Java
3. 'This plug-in is not supported'

What is the expected behavior?
Java plugin should work.

What went wrong?
Java plugin does not work

Does it occur on multiple sites: Yes

Is it a problem with a plugin? Yes Java 1.8 (latest)

Did this work before? Yes Chrome 41

Does this work in other browsers? Yes 

Chrome version: 42.0.2311.90  Channel: stable
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
Flash Version: Shockwave Flash 17.0 r0

I'm unsure how this slipped through testing, as it breaks a massive chunk of the web.
 

Comment 1 by xro...@gmail.com, Apr 14 2015

wtfchrome.png
68.8 KB View Download
Happens the samething for Adobe ShockWave

Example url: https://www.adobe.com/shockwave/welcome/

Comment 3 by mega...@gmail.com, Apr 14 2015

This is likely related to the deprecation of NPAPI support in Chrome and (if so) is by design.

Comment 4 by mega...@gmail.com, Apr 14 2015

Please read for more details:

http://blog.chromium.org/2014/05/update-on-npapi-deprecation.html
https://www.chromium.org/developers/npapi-deprecation

You may reenable using the chrome://flags switch as described but support is scheduled to be removed in September with Chrome 45.

Comment 5 by xro...@gmail.com, Apr 14 2015

The workaround needs to be made far more visible.  It's also broken piles of other things (as mentioned above, Shockwave), but also unexpected things like Google Earth.
Status: WontFix
As explained in the pages linked above, this is by design. Blocking plugins by default with a relatively high-visibility way to re-enable them was the previous state in the progression of deprecating NPAPI, so having a low-visibility flag is intentional at this stage.

Comment 7 by xro...@gmail.com, Apr 15 2015

I accept that this is a plan moving forward, but what is the progress to replace the NPAPI with something that has similar features so that Java services can continue to work, through another API?  (I haven't been able to find anything about the replacement)
If someone truly wishes to write a plugin, Chrome offers the PPAPI interface that allows for authoring plugins which are sandboxable.

However, ideally, anything people did in the past with NPAPI plugins can be achieved through the web platform.  Capabilities like WebGL, the filesystem API, Service Workers, WebMIDI, and more make the web platform far more comprehensive and compelling than when these plugins were first created.  Chrome also has PNaCl to support cross-compiling code written for non-web platforms to a form runnable in the browser, with fairly minimal porting effort required.  The blog post in comment 4 links to more details.
ALL of the banks and government institutions on Brazil use java for about everything. Really, ALL OF THEM. 
Today I'll be in hell fixing it on a few dozen of small business clients. Thanks a lot.
 Issue 477377  has been merged into this issue.
 Issue 477432  has been merged into this issue.

Comment 12 by tkent@chromium.org, Apr 16 2015

Cc: amineer@chromium.org
Labels: -Cr-Content Cr-Internals-Plugins

Comment 13 Deleted

Comment 14 Deleted

Mergedinto: 453263
Status: Duplicate

Comment 16 by Deleted ...@, Apr 27 2015

+1. Last week = fine. This week = everything to do with Java, Shockwave, Flash etc (i.e. my job) BROKEN.

Why Google, Why?

Comment 17 by Deleted ...@, Apr 28 2015

I don't understand how something so large and sweeping could be done in the "cover of night".  This most recent update (I'm guessing 42), broke functionality of at-least 3 major plugins that the world relies on.  No user education, no proposed workarounds, rather everyone is supposed to take to the forums for their answers?  I find this negligent at best from the chrome team.  As much as I love chrome, I am second guessing switching over to firefox.

Comment 18 by Deleted ...@, Sep 5 2015

I've given these people plenty of time to give us some answer.  I will be switching to firefox, as I am sure nearly everyone else will.  Google Chrome has broken so much with this, whoever idea it was do remove java support, just basically made nearly everyone not even want to use this crap anymore.

Comment 19 by Deleted ...@, Dec 8 2015

Some updates here? Trying to add support for the java 1.8 (which is installed and work for firefix and IE 11

Sign in to add a comment