New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 477001 link

Starred by 9 users

Issue metadata

Status: Duplicate
Owner: ----
Closed: Jun 2016
Cc:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug-Regression



Sign in to add a comment

--single-process flag not supported in Chromium 44.0.2364.0

Reported by lecks...@gmail.com, Apr 14 2015

Issue description

Chrome Version       : 44.0.2364.0
URLs (if applicable) : ANY
Other browsers tested:

What steps will reproduce the problem?
1.Edit the short cut to chromium to include the --single-process flag
2.Try launching chromium
3.

What is the expected result?
Chromium launches with whatever start page is set.

What happens instead?
Watching task manager you can see that a chrome.exe process is started and then closes without ever seeing the browser launch.

Please provide any additional information below. Attach a screenshot if
possible.
Just trying to use the feature documented here:
http://www.chromium.org/developers/design-documents/process-models#TOC-Single-process

 
Which operating system are you using?

Comment 2 by lecks...@gmail.com, Apr 14 2015

Windows Server 2012.

Note: I did notice that there was an issue regarding V8 Proxy resolver and the kSingleProcess flag that was recently resolved (https://code.google.com/p/chromium/issues/detail?id=474654&q=--single-process&colspec=ID%20Pri%20M%20Week%20ReleaseBlock%20Cr%20Status%20Owner%20Summary%20OS%20Modified)

Possible dupe, but haven't been able to verify that eroman's fix resolves the issue I'm seeing.

Comment 3 by lecks...@gmail.com, Apr 14 2015

Found these log files from when Chrome failed to launch. Couldn't interpret anything from them, but maybe someone else more familiar with the project can :)
Report.wer
47.1 KB Download
triagedump.dmp
37.5 KB Download
WER187F.tmp.appcompat.txt
30.2 KB View Download
memory.hdmp
1.6 MB Download
WER191C.tmp.WERInternalMetadata.xml
7.2 KB Download

Comment 4 by lecks...@gmail.com, Apr 14 2015

Also, I tried several previous version of Chromium from the snapshots back through January and all of them exempted the same issue on my Win Server 2012 machine and my Win 8.1 machine.

Most notably, I tried several builds older than 318277 which is what regressed the issue tracked in the bug I linked to earlier. So that leads me to believe with high confidence this is a different issue.
Those files are WER (Windows Error Reporting) report files. Did a "Google Chrome is not responding" or "Google Chrome has stopped working" dialog appear? Windows Error Reporting (WER) is WerFault.exe in Windows/System32

Your current Chromium version is lower than the current Chrome Canary version (canary is slightly older than Chromium). Can you reproduce this issue on the latest Chromium build or the canary build? (You can download Chromium from download-chromium.appspot.com or Chrome Canary from google.com/intl/en/chrome/browser/canary.html)

Thank you for filing a bug!

Comment 6 by lecks...@gmail.com, Apr 14 2015

Yes, this repros with all of the recent versions I've tested with (approx 15 or so ranging from build 272511 all the way to today's most recent snapshot).

Again, the steps I'm doing to repro are: 
Download and extract any snapshot zip.
Create a shortcut for the chrome.exe.
Modify the shortcut Target to include the --single-process flag. 

Alternate repro is to open command line and navigate to directory of chrome.exe and execute "chrome.exe --single-process"
Labels: OS-Windows Type-Bug-Regression
Owner: yoichio@chromium.org
Status: Assigned
Confirmed on 44.0.2387.0 canary (64-bit).
Will further investigate.
Project Member

Comment 8 by bugdroid1@chromium.org, May 8 2015

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/f71a0add64e543c7bb4cf59442b77ec5f3f6978e

commit f71a0add64e543c7bb4cf59442b77ec5f3f6978e
Author: yoichio <yoichio@chromium.org>
Date: Fri May 08 04:03:38 2015

ExtensionFunctionDispatcher should use base::Process::Current() if single process
mode.

Since #323179, ExtensionFunctionDispatcher has used
base::Process::DeprecatedGetProcessFromHandle to callback:
https://chromium.googlesource.com/chromium/src/+/f8d789c4558c7575f4d388d44730d18fdf157
72c
However, base::Process::DeprecatedGetProcessFromHandle(handle) assumes
 |handle| is not current process handle. The assumption brakes if single process mode
 thus chrome can't start with the '--single-process' flag.

BUG= 477001 

Review URL: https://codereview.chromium.org/1113343002

Cr-Commit-Position: refs/heads/master@{#328923}

[modify] http://crrev.com/f71a0add64e543c7bb4cf59442b77ec5f3f6978e/extensions/browser/extension_function_dispatcher.cc

Cc: rponnada@chromium.org
Labels: -Type-Bug Needs-Feedback M-44
Tested this issue on Windows7 using: 44.0.2398.0 with below steps:

1. Command Prompt > chrome.exe --single-process
2. Observed that Chrome is not launched and process in task manager is started & closed.

Please find the attached screen-cast as reference. 
Please let me know, if i missed anything in verification. 

C:\Users\rponnada>
477001.mp4
765 KB Download
There are still many components to be fixed.

Comment 11 by Deleted ...@, Nov 2 2015

I've just tried this on v46.x and still receive the crash on Win 7 and Win 8.1.  Is there a fix coming?  I need to upgrade from my current working version.
Cc: yoichio@chromium.org
Owner: ----
I'm not sure and I don't have enough bandwidth.
It works on Windows 8.1.
Anyone can confirm on your environment?

Comment 14 by smbec...@gmail.com, Jan 28 2016

I just updated to 48.0.2564.97 on Windows 10 and it still crashes. Is there a version that this should work on?

Comment 15 by ajha@chromium.org, Feb 4 2016

 Issue 584133  has been merged into this issue.
Cc: -rponnada@chromium.org msrchandra@chromium.org
@leckster -- Could you please re-check on Latest Stable# 49.0.2623.75 on Windows and provide us the recent update.
Thanks in Advance.
I just updated to 49.0.2623.75 on Windows 10 and it still crashes.
I've updated and still Chrome will not launch. Tried on Win 10 and Win Server 2012. Chrome build 49.0.2623.75
Cc: ashej...@chromium.org
@yoichio: Hey, would you mind checking the above issue ?

@smbecker: Can you please provide us with crash id from chrome://crashes ?

Appreciate the help.

Thank you!

Comment 20 by smbec...@gmail.com, Apr 15 2016

Crash ID ed57f9cc00000000 (714a6fd5-7907-4090-b5fa-62feb55f798a)
Occurred Friday, April 15, 2016 at 9:02:38 AM

Crash ID 8ff8322400000000 (4ee2d13f-096a-433b-a926-537dfe838c73)
Occurred Friday, April 15, 2016 at 9:02:35 AM
Status: Available (was: Assigned)
My confirmation #13 was with my local build.
This issue still happens on canary Version 52.0.2710.0 canary (64-bit).
Labels: -Needs-Feedback
Mergedinto: 597392
Status: Duplicate (was: Available)
Based on the stack trace comparison issue dupe of 597392, hence merging.

Feel free of un-merge, if someone feels otherwise.

Thank you!

Comment 23 by shah...@gmail.com, Jan 21 2018

It's 2018, and Chrome still crashes due to this setting
Is single process mode not supported officially? This is really a useful mode in testing area. It is not working for 3 years, really sad.

Sign in to add a comment