Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 19 users
Status: Duplicate
Merged: issue 441946
Owner: ----
Closed: Jul 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug



Sign in to add a comment
Emoji characters do not show in h1, h2... tags
Reported by francesc...@gmail.com, Mar 8 2015 Back to list
UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.76 Safari/537.36

Example URL:
https://francescbm.com/bugs/emoji-chrome.html

Steps to reproduce the problem:
1. Open the test case website https://francescbm.com/bugs/emoji-chrome.html

What is the expected behavior?
1. A bug emoji should be rendered in every header tag (h1, h2, h3, h4, h5) however it shows an empty white space.

What went wrong?
An empty space is shown instead of the emoji being rendered.

It seems to be platform independent, because I also tested it in Android Lollipop with the latest version of Chrome Stable. The same bug is also observed in OS X using the Chrome Canary version (43.0.2325.0). Both tested in Yosemite and Mavericks.

Does it occur on multiple sites: N/A

Is it a problem with a plugin? N/A 

Did this work before? N/A 

Does this work in other browsers? Yes 

Chrome version: 41.0.2272.76  Channel: stable
OS Version: OS X 10.10.2
Flash Version: Shockwave Flash 16.0 r0

It's quite weird because indeed it works outside h1,h2... tags and also in the developer console if you inspect the header element it shows the emoji there. 

I checked it over Safari and Firefox on OS X and it works on both.
 
safari-emoji.png
74.3 KB View Download
firefox-emoji.png
101 KB View Download
chrome-emoji-osx.png
98.3 KB View Download
android-emoji.png
73.8 KB View Download
Labels: -OS-Mac OS-All Cr-Blink
Status: Untriaged
Confirmed here on Android, I'll check Windows later.
Labels: -Cr-Blink Cr-Blink-Paint
Repo on 41.0.2272.76 Windows7 64
screenshot.png
9.9 KB View Download
Cc: rnimmagadda@chromium.org
Labels: -Type-Compat Type-Bug M-42
Able to repro this issue on Windows 7, 8, 8.1, MAC (10.9.5) & Ubuntu (14.10) for Google Chrome Stable Version - 41.0.2272.76

This is a Non-Regression issue existing from M18.
Comment 4 by tkent@chromium.org, Mar 11 2015
Labels: -Cr-Blink-Paint Cr-Blink-Fonts
Labels: Needs-Feedback
Can someone try this from ToT (Canary) on OS X and Android? I think that this is actually fixed -- can't reproduce on a local build 43.0.2326.0 on Windows 10.
Can repro on OS X 10.10.2 Version 43.0.2328.0 canary (64-bit)
Screen Shot 2015-03-11 at 10.58.16 AM.png
21.9 KB View Download
Labels: -OS-All -Needs-Feedback OS-Mac OS-Android
Removing OS-All then & adding OS-Android & OS-Mac. Probably iOS too, then... who knows about Linux.

Attached a screenshot of 43.0.2328.0 canary on Windows 10.
canary_emjoi.png
9.6 KB View Download
Comment 8 by ja...@kifi.com, Apr 15 2015
For me the issue is triggered by a computed font-weight of 600 or higher (e.g. "bold"). HTML tag doesn’t matter.
Amazing thanks, it's true, if the font-weight is not set to normal, it does not render. This still seems o be a bug though?
Labels: -OS-Android
Working fine and OS-Android.
This could be related to the Emoji issue where due to font bold property Emoji was not rendered which is fixed now in Skia.
Removing OS-Android from list.
Here is a fiddle for me that works (when font-weight is normal) and breaks (when font-weight is bold):
http://output.jsbin.com/conewi

I think the reason it "works" on Windows is because in your screenshot, hichris123, that's not emoji.
That's just unicode characters. Regular unicode characters are fine on all platforms. It's when they are shown as emoji that they break.
As described here, native emoji don't render on OS X when bolded. This has already been reported in https://code.google.com/p/chromium/issues/detail?id=441946.
Comment 13 by n...@chromium.org, Jul 1 2015
Mergedinto: 441946
Status: Duplicate
Sign in to add a comment