Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Issue 46137 Chrome changes my active desktop in Mac OS X
Starred by 22 users Reported by pup...@gmail.com, Jun 9 2010 Back to list
Status: Duplicate
Merged: issue 31821
Owner: ----
Closed: Mar 2011
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
It seems that Chrome, when it finishes loading a web site, will change my active desktop in Mac OS X to the desktop where that Chrome is running. Some pages may trigger this event several times (they have frames maybe?) which is really infuriating:

1- open chrome in desktop 1
2- open web site in chrome in desktop 1
3- move to desktop 2 to do something
4- forcefully moved back to desktop 1
5- move to desktop 2 again
6- moved back to 1 by chrome
7- and so on.
 
Comment 1 by Deleted ...@, Nov 23 2010
I also have this issue, macos 10.6.4, chrome 7.0.517.44. It's pretty annoying.
Comment 2 by Deleted ...@, Nov 24 2010
I can confirm this behavior. OS X 10.6.5, Chrome 7.0.517.44.
Comment 3 by Deleted ...@, Nov 24 2010
I can also confirm that upgrading to the dev version of Chrome, 9.0.587.0 dev, resolves this issue.
Comment 4 by Deleted ...@, Dec 15 2010
Same here. Hugely annoying.
Comment 5 by asbjo...@gmail.com, Dec 16 2010
I don't even see Chrome as an available application for assignment in Spaces' preferences. There's a couple of "Unknown application" entries in there I've tried to modify, but Chrome still only shows on the space that was active when it was launched.
Comment 6 by tman...@gmail.com, Dec 23 2010
Same issue in 8.0.552.231, OSX 10.6.5. Hope it's really fixed in the dev version/beta.
Comment 7 by mylesj@google.com, Feb 3 2011
I see this too. It's very annoying, because it interrupts your workflow.
Comment 8 by moose...@gmail.com, Feb 4 2011
9.0.597.84 still has this problem, though it seems to be to a lesser degree than chrome 8. e.g. Lotus iNotes (browser interface to Lotus Notes email) causes workspace switches.

also, try http://thejournalnews.com. this site quickly redirects to http://lohud.com. but if you type in thejournalnews.com, then switch to another workspace before the redirect, you  will automatically be switched back to the chrome workspace when the redirect does occur.
I experience this problem on several sites very badly; OS X 10.6.6,Chrome 9.0.597.94.  Any time a site loads a new app I am forcibly space-changed, even running an ad-blocking extension.  I have been space-changed 4 times due to this bug just while writing this comment.
Labels: OS-Mac
Mergedinto: 31821
Status: Duplicate
Comment 12 by aala...@gmail.com, Apr 4 2012
Super annoying please fix, already!
Project Member Comment 13 by bugdroid1@chromium.org, Oct 13 2012
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:31821
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 14 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Area-Undefined
Sign in to add a comment