New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 456513 link

Starred by 16 users

Issue metadata

Status: Duplicate
Merged: issue 466667
Owner: ----
Closed: Mar 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

Hardware acceleration doesn't work

Reported by dmitry.o...@gmail.com, Feb 7 2015

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.111 Safari/537.36

Example URL:
youtube.com, maps.google.com, etc

Steps to reproduce the problem:
1. Open Video
2. Put quality to the best
3. Check performance in the Task Manager

What is the expected behavior?
Smooth hardware accelerated video playback or smooth map redraw in Google Maps.

What went wrong?
Chrome doesn't use hardware acceleration when it is possible.

Did this work before? Yes I cant say exactly, but it was more then 3 years ago.

Is it a problem with Flash or HTML5? Both

Does this work in other browsers? Yes 

Chrome version: 40.0.2214.111  Channel: stable
OS Version: 6.3
Flash Version: Shockwave Flash 16.0 r0

It was discussed here #335662. Someone checked it solved. but it doesn't.

I use notebook Asus UX32VD with the latest drivers. Chrome://gpu shows GPU accelerate enabled everywhere. But when I watch for example Youtube HTML5 4K video it use CPU (100% load and a bit laggy). When I use IE11 everything is smooth and about 15% CPU load.

More information:

Graphics Feature Status
Canvas: Hardware accelerated
Flash: Hardware accelerated
Flash Stage3D: Hardware accelerated
Flash Stage3D Baseline profile: Hardware accelerated
Compositing: Hardware accelerated
Multiple Raster Threads: Disabled
Rasterization: Hardware accelerated
Threaded Rasterization: Enabled
Video Decode: Hardware accelerated
Video Encode: Hardware accelerated
WebGL: Hardware accelerated
Driver Bug Workarounds
clear_uniforms_before_first_program_use
exit_on_context_lost
scalarize_vec_and_mat_constructor_args
texsubimage2d_faster_than_teximage2d
Problems Detected
Some drivers are unable to reset the D3D device in the GPU process sandbox
Applied Workarounds: exit_on_context_lost
TexSubImage2D() is faster for full uploads on ANGLE
Applied Workarounds: texsubimage2d_faster_than_teximage2d
Clear uniforms before first program use on all platforms: 124764, 349137
Applied Workarounds: clear_uniforms_before_first_program_use
Always rewrite vec/mat constructors to be consistent: 398694
Applied Workarounds: scalarize_vec_and_mat_constructor_args
Raster is using a single thread.
Disabled Features: multiple_raster_threads
Version Information
Data exported	2/8/2015, 12:08:06 AM
Chrome version	Chrome/40.0.2214.111
Operating system	Windows NT 6.3
Software rendering list version	0
Driver bug list version	7.12
ANGLE commit id	d77bd1632e4c
2D graphics backend	Skia
Command Line Args	Files (x86)\Google\Chrome\Application\chrome.exe" --no-startup-window --flag-switches-begin --enable-experimental-canvas-features --ignore-gpu-blacklist --flag-switches-end
Performance Information
Graphics	5.2
Gaming	5.6
Overall	5.2
Driver Information
Initialization time	69
Sandboxed	false
GPU0	VENDOR = 0x8086, DEVICE= 0x0166
Optimus	true
AMD switchable	false
Desktop compositing	Aero Glass
Driver vendor	Intel Corporation
Driver version	10.18.10.3308
Driver date	9-16-2013
Pixel shader version	5.0
Vertex shader version	5.0
Machine model name	
Machine model version	
GL_VENDOR	Google Inc.
GL_RENDERER	ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
GL_VERSION	OpenGL ES 2.0 (ANGLE 2.1.d77bd1632e4c)
GL_EXTENSIONS	GL_OES_element_index_uint GL_OES_packed_depth_stencil GL_OES_get_program_binary GL_OES_rgb8_rgba8 GL_EXT_texture_format_BGRA8888 GL_EXT_read_format_bgra GL_NV_pixel_buffer_object GL_OES_mapbuffer GL_EXT_map_buffer_range GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_float GL_OES_texture_float_linear GL_EXT_texture_rg GL_EXT_texture_compression_dxt1 GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_EXT_sRGB GL_ANGLE_depth_texture GL_EXT_texture_storage GL_OES_texture_npot GL_EXT_draw_buffers GL_EXT_texture_filter_anisotropic GL_EXT_occlusion_query_boolean GL_NV_fence GL_EXT_robustness GL_EXT_blend_minmax GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_pack_reverse_row_order GL_OES_standard_derivatives GL_EXT_shader_texture_lod GL_EXT_frag_depth GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source
Window system binding vendor	Google Inc. (adapter LUID: 0000000000007c85)
Window system binding version	1.4 (ANGLE 2.1.d77bd1632e4c)
Window system binding extensions	EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size
Direct rendering	Yes
Reset notification strategy	0x8252
GPU process crash count	0
Diagnostics
0
b3DAccelerationEnabled	true
b3DAccelerationExists	true
bAGPEnabled	true
bAGPExistenceValid	true
bAGPExists	true
bCanRenderWindow	true
bDDAccelerationEnabled	true
bDriverBeta	false
bDriverDebug	false
bDriverSigned	false
bDriverSignedValid	false
bNoHardware	false
dwBpp	32
dwDDIVersion	11
dwHeight	1200
dwRefreshRate	60
dwWHQLLevel	0
dwWidth	1920
iAdapter	0
lDriverSize	12100096
lMiniVddSize	0
szAGPStatusEnglish	Enabled
szAGPStatusLocalized	Enabled
szChipType	Intel(R) HD Graphics Family
szD3DStatusEnglish	Enabled
szD3DStatusLocalized	Enabled
szDACType	Internal
szDDIVersionEnglish	11
szDDIVersionLocalized	11
szDDStatusEnglish	Enabled
szDDStatusLocalized	Enabled
szDXVAHDEnglish	Supported
szDXVAModes	ModeMPEG2_A ModeMPEG2_C ModeWMV9_C ModeVC1_C
szDescription	Intel(R) HD Graphics 4000
szDeviceId	0x0166
szDeviceIdentifier	{D7B78E66-4226-11CF-8661-0A35B4C2C435}
szDeviceName	\\.\DISPLAY1
szDisplayMemoryEnglish	1792 MB
szDisplayMemoryLocalized	1792 MB
szDisplayModeEnglish	1920 x 1200 (32 bit) (60Hz)
szDisplayModeLocalized	1920 x 1200 (32 bit) (60Hz)
szDriverAssemblyVersion	10.18.10.3308
szDriverAttributes	Final Retail
szDriverDateEnglish	10/1/2013 12:02:32
szDriverDateLocalized	01.10.2013 12:02:32
szDriverLanguageEnglish	English
szDriverLanguageLocalized	English
szDriverModelEnglish	WDDM 1.3
szDriverModelLocalized	WDDM 1.3
szDriverName	igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll,igdumdim32,igd10iumd32,igd10iumd32
szDriverNodeStrongName	oem6.inf:5f63e5341859ec8c:iIVBM_w81:10.18.10.3308:pci\ven_8086&dev_0166&subsys_15071043
szDriverSignDate	
szDriverVersion	10.18.0010.3308
szKeyDeviceID	Enum\PCI\VEN_8086&DEV_0166&SUBSYS_15071043&REV_09
szKeyDeviceKey	\Registry\Machine\System\CurrentControlSet\Control\Video\{5FFD5A27-9279-4796-8CF3-CF925A2806B6}\0000
szManufacturer	Intel Corporation
szMiniVdd	n/a
szMiniVddDateEnglish	n/a
szMiniVddDateLocalized	n/a
szMonitorMaxRes	
szMonitorName	HP ZR24w Wide LCD Monitor
szNotesEnglish	No problems found.
szNotesLocalized	No problems found.
szOverlayEnglish	Supported
szRankOfInstalledDriver	00DA0001
szRegHelpText	
szRevision	
szRevisionId	0x0009
szSubSysId	0x15071043
szTestResultD3D7English	Not run
szTestResultD3D7Localized	Not run
szTestResultD3D8English	Not run
szTestResultD3D8Localized	Not run
szTestResultD3D9English	Not run
szTestResultD3D9Localized	Not run
szTestResultDDEnglish	Not run
szTestResultDDLocalized	Not run
szVdd	n/a
szVendorId	0x8086
1
b3DAccelerationEnabled	true
b3DAccelerationExists	true
bAGPEnabled	true
bAGPExistenceValid	true
bAGPExists	true
bCanRenderWindow	true
bDDAccelerationEnabled	true
bDriverBeta	false
bDriverDebug	false
bDriverSigned	false
bDriverSignedValid	false
bNoHardware	false
dwBpp	32
dwDDIVersion	11
dwHeight	1080
dwRefreshRate	60
dwWHQLLevel	0
dwWidth	1920
iAdapter	1
lDriverSize	12100096
lMiniVddSize	0
szAGPStatusEnglish	Enabled
szAGPStatusLocalized	Enabled
szChipType	Intel(R) HD Graphics Family
szD3DStatusEnglish	Enabled
szD3DStatusLocalized	Enabled
szDACType	Internal
szDDIVersionEnglish	11
szDDIVersionLocalized	11
szDDStatusEnglish	Enabled
szDDStatusLocalized	Enabled
szDXVAHDEnglish	Supported
szDXVAModes	ModeMPEG2_A ModeMPEG2_C ModeWMV9_C ModeVC1_C
szDescription	Intel(R) HD Graphics 4000
szDeviceId	0x0166
szDeviceIdentifier	{D7B78E66-4226-11CF-8661-0A35B4C2C435}
szDeviceName	\\.\DISPLAY2
szDisplayMemoryEnglish	1792 MB
szDisplayMemoryLocalized	1792 MB
szDisplayModeEnglish	1920 x 1080 (32 bit) (60Hz)
szDisplayModeLocalized	1920 x 1080 (32 bit) (60Hz)
szDriverAssemblyVersion	10.18.10.3308
szDriverAttributes	Final Retail
szDriverDateEnglish	10/1/2013 12:02:32
szDriverDateLocalized	01.10.2013 12:02:32
szDriverLanguageEnglish	English
szDriverLanguageLocalized	English
szDriverModelEnglish	WDDM 1.3
szDriverModelLocalized	WDDM 1.3
szDriverName	igdumdim64.dll,igd10iumd64.dll,igd10iumd64.dll,igdumdim32,igd10iumd32,igd10iumd32
szDriverNodeStrongName	oem6.inf:5f63e5341859ec8c:iIVBM_w81:10.18.10.3308:pci\ven_8086&dev_0166&subsys_15071043
szDriverSignDate	
szDriverVersion	10.18.0010.3308
szKeyDeviceID	Enum\PCI\VEN_8086&DEV_0166&SUBSYS_15071043&REV_09
szKeyDeviceKey	\Registry\Machine\System\CurrentControlSet\Control\Video\{5FFD5A27-9279-4796-8CF3-CF925A2806B6}\0001
szManufacturer	Intel Corporation
szMiniVdd	n/a
szMiniVddDateEnglish	n/a
szMiniVddDateLocalized	n/a
szMonitorMaxRes	
szMonitorName	Generic PnP Monitor
szNotesEnglish	No problems found.
szNotesLocalized	No problems found.
szOverlayEnglish	Supported
szRankOfInstalledDriver	00DA0001
szRegHelpText	
szRevision	
szRevisionId	0x0009
szSubSysId	0x15071043
szTestResultD3D7English	Not run
szTestResultD3D7Localized	Not run
szTestResultD3D8English	Not run
szTestResultD3D8Localized	Not run
szTestResultD3D9English	Not run
szTestResultD3D9Localized	Not run
szTestResultDDEnglish	Not run
szTestResultDDLocalized	Not run
szVdd	n/a
szVendorId	0x8086
Log Messages
[6184:6188:0207/220009:ERROR:gles2_cmd_decoder.cc(10748)] : [.Compositor-08746700]GL ERROR :GL_INVALID_OPERATION : glConsumeTextureCHROMIUM: invalid mailbox name
[6184:6188:0207/220009:ERROR:gles2_cmd_decoder.cc(10748)] : [.Compositor-08746700]GL ERROR :GL_INVALID_OPERATION : glConsumeTextureCHROMIUM: invalid mailbox name
[6184:6188:0207/220009:ERROR:gles2_cmd_decoder.cc(10748)] : [.Compositor-08746700]GL ERROR :GL_INVALID_OPERATION : glConsumeTextureCHROMIUM: invalid mailbox name
[6184:6188:0207/220009:ERROR:gles2_cmd_decoder.cc(6309)] : [.Compositor-08746700]RENDER WARNING: texture bound to texture unit 1 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering or is not 'texture complete'
[6184:6188:0207/220009:ERROR:gles2_cmd_decoder.cc(6309)] : [.Compositor-08746700]RENDER WARNING: texture bound to texture unit 2 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering or is not 'texture complete'
[6184:6188:0207/220009:ERROR:gles2_cmd_decoder.cc(6309)] : [.Compositor-08746700]RENDER WARNING: texture bound to texture unit 3 is not renderable. It maybe non-power-of-2 and have incompatible texture filtering or is not 'texture complete'
GpuProcessHostUIShim: The GPU process exited normally. Everything is okay.
 
Labels: Needs-Feedback
@Dmitry.O.Kuznetsov: Could you please help us the screen-cast for the issue observed. Since when we played a video on Youtube with highest quality, we are not facing any issues on Google Chrome Stable Version - 40.0.2214.111

Also, could you provide us the video you were watching on Youtube & Map Location you were trying to access, which would help us in triaging it further.

Thank you.
@rnimmaga: I captured a video. You can see a CPU usage in both browsers. Also you cant see, but in Chrome it plays very laggy, and its very smooth in IE.
 
https://www.youtube.com/watch?v=i_d0FXhAJnk

Map location doesnt matter. It always redraw slowly with my 50Mbps internet speed.

If you need some more information please let me know.
And I can add that it was played using HTML5 in both browsers. And it doesnt matter 4K or 1080p. It always use CPU for decoding.
@Dmitry.O.Kuznetsov, on windows OS, 4k video will not use GPU decoding, it is by design. GPU decoding on windows is available to resolution between 48X48 and 1920X1080.
Even in S/W decoding, video shouldn't paly laggy. I can't repro this issue in my chrome 42.0.2298.0 with both 1440p and 2160p4k.
I used the same video https://www.youtube.com/watch?v=xDMP3i36naA
can you provide chrome://gpu info?
@yini...@chromium.org, well, let's say that 4k video wont use GPU decoding, so why so huge difference between IE and Chrome in CPU load? In Chrome its like slideshow.

Btw CPU load difference for 1080p is the same as for 4k.

chrome://gpu info is provided in the first message for this issue.
Also I can add that forcing MP4/AVC playback doesn't work for me.

I am going to make a new video with more details, like stats for nerd where you can see that half frames were lost.

Comment 7 by make...@gmail.com, Feb 12 2015

It's the same with Flash: https://code.google.com/p/chromium/issues/detail?id=456421

Chrome doesnt use GPU acceleration and results in 50-70% CPU load for 1080p streams and about 40-50% for 720p videos. The funny thing, Firefox has the same problem, and of course IE11 works perfectly fine (2-5% CPU load).

Also, why does no one care on my ticket and here someone answered?
I made a new video with "stats for nerd" and Resource Monitor enabled:
https://www.youtube.com/watch?v=OC4-Sv5QEds
Chrome browser:
1. 4K, Flash player (plays laggy)
2. 4K, HTML5, Force MP4/AVC disabled (plays laggy)
3. 4K, HTML5, Force MP4/AVC enabled (plays laggy)
4. 1080p, HTML5 (plays smooth)
5. 1080p, HTML5, Force MP4/AVC enabled (plays smooth)
6. 1080p, Flash player (plays smooth, but high CPU usage)

Comment 9 by ericde@chromium.org, Feb 12 2015

Cc: renganat...@chromium.org fgalligan@chromium.org

Comment 10 by Deleted ...@, Feb 15 2015

Hello, I have the same problem with both 32/64 bit version of Google Chrome. Video playback of both Flash and HTML5 are laggy. 

Playback works without any issues in Internet Explorer 11 
Also I want to add some more details.
VP9 decoding uses about 10 times more CPU than AVC for me. And sometimes videos on Youtube still play VP9 instead of AVC where its available. 
VP9.jpg
405 KB View Download
AVC.jpg
427 KB View Download
@Dmitry, can you provide your hardware configuration? I tried on my Windows 7 machine with the video you provided https://www.youtube.com/watch?v=xDMP3i36naA, I do see smooth playback.
4k video expect capable hardware to play.
@yini, ok, I use a laptop Asus UX32VD, which configuration you can found on the official website: http://www.asus.com/Notebooks_Ultrabooks/ASUS_ZENBOOK_UX32VD/specifications/
Also I can be more accurate:
Intel® Core™ i7 3517U Processor
IPS FHD (1920x1080)
Integrated Intel® HD Graphics 4000 
NVIDIA® GeForce® GT 620M

I also added 8Gb DDR3 so I have 10Gb in total.
I changed 500Gb HDD to 256Gb SSD.

Do you need more information?

Btw, the second time in this thread developers ask me about things that were provided in the first message...

Comment 14 by Deleted ...@, Feb 26 2015

I have the exact same issue. Same video (https://www.youtube.com/watch?v=tJGnHB3rtMU) playing in 4K will play smoothly in IE at 2-3% cpu usage but very laggy in chrome at ~50% cpu usage.
Stats for nerds says chrome uses VP9 and IE uses AVC.
GPU load is not affected in either scenario.

Hope you can solve this, I really don't want to use IE ;)

System info:
Chrome: 40.0.2214.115 m
CPU: AMD FX-8350 4ghz
mem: 16gb 1333mhz
GPU: GTX 680 GTX
Mainboard: ASUS Sabertooth 990FX R2.0
Disk: 128gb Intel SSD
Internet connection: Ethernet 60/30 Mbit
I also have another kind of issue on playing 5K video on YouTube using Flash.
Instead of the image I can see only green square.

The video example is here: https://www.youtube.com/watch?v=nRt4Duf7GoI
5kFlashIssue.jpg
127 KB View Download
I am not able to repro this issue in any chance but if you still repro the 4k laggy playback, can you try to launch chrome with --disable-d3d11, let me know if it solve your problem. 
BTW, on windows OS, IE does use GPU for 4k H264 video but Chrome does not. That is chrome's next goal to provide GPU decoding for 4k MP4 video. 
@yini, "--disable-d3d11" solved nothing...
I still have had this laggy playback since about 3 years ago. 4k played smoothly using Flash Player once.

Btw I had this issue on Windows 7, then on Windows 8, then Windows 8.1.
I have another computer that based on ION motherboard and it has the SAME issue. Actually, I am not the only one who have it. People write everywhere about this problem. And it is possible to repro this issue, but you need a similar hardware.

I downloaded a 4K video from YouTube and tried to play it using different players and most of these play it using 1-5% CPU without additional configuration.
I tried WMP, VLC, MPC-HC. And only MPC-HC played laggy until I checked UHD hardware decoding in settings (screen attached).
MPC-HC_settings.jpg
143 KB View Download
Struggling with this too (Lenovo y50 4K screen + gtx860m + up-to-date chrome)...I think NVIDIA's crappy optimus technology is where to start looking. Just a hunch, no proof...My contention is that butter-smooth playback in ie11 is linked to the discreet gpu actually being used, but not in chrome...My 2 cents. Still not fixed.
Cc: w...@chromium.org
chris, on windows, is the below hardware capable of playing 4k video smoothly in S/W decoding? 
Intel® Core™ i7 3517U Processor
IPS FHD (1920x1080)
Integrated Intel® HD Graphics 4000 
NVIDIA® GeForce® GT 620M
added 8Gb DDR3 so I have 10Gb in total.
changed 500Gb HDD to 256Gb SSD.

I am not able to repro this issue in my windows desktop with 32G RAM.  Customers complain laggy playback and high CPU usage experience on both 4k vp9 and mp4 codec. Here are sample video
vp9: https://www.youtube.com/watch?v=nRt4Duf7GoI
mp4: https://www.youtube.com/watch?v=xDMP3i36naA

I want to add I think important details.

IE always uses HTML5 + AVC codec for 4K video, but Chrome uses ONLY HTML + VP9 or Flash player for 4k video. Maybe it is the reason?

Btw 5k playback doesnt work at all (everywhere).
Example: https://www.youtube.com/watch?v=nRt4Duf7GoI
Even in the comments below the video people write about it.

Comment 22 by Deleted ...@, Mar 8 2015

Same problem for me. When watching twitch streams at 60 fps / 1600+ resolutions the CPU usgae is through the roof compared to Firefox (usally 50% of what chrome uses) and IE (even better). It's horrible.
Status: Available
chris, can you take a look with  the hardware in comment #20, do we expect seeing slow decoding on 4k video?

Comment 24 by w...@chromium.org, Mar 11 2015

Sorry, I missed this. I can't say whether that hardware should be capable of decoding 4k vp9. 

As mentioned, Chrome will likely be served vp9 on Youtube, while IE will get h264. See  Issue 464774  for supporting higher resolution hardware decoding.
Mergedinto: 466667
Status: Duplicate
I open a new bug to track VP9 4k video playback having high dropped frame issue. It is because H/W decoding is not provided in vp9. With H264 H/W decoding, this issue not repro.

Same problem here for both vp9/mp4. On youtube.com, also on twitch.tv .
High CPU usage across all 4 cores.

1080p - 60% CPU usage, smooth
4k - close to 100% CPU usage, shutter

motherboard - Gygabyte GA-P35C-DS3R
CPU - Intel Core 2 Extreme X9650
Memory - 8GB
GPU - Nvidia GTX 970

I started to notice after i upgraded to 4k screen. In IE works with 10% cpu usage.

Not same as  bug 466667 , switching to mp4 with some addons did not help.
There's no Hardware Decoding in Google Chrome on any computer. AT ALL.

You can tell me whatever you want: you can tell me that there's an acceleration, you can tell me to update my drivers and you can tell me that my computer is crap, but there's NO Hardware Decoding AT ALL. On ANY system, ANY video card, ANY processor, ANY PLANET.

This what I wanted to say, now I can rest in peace.
The same here. I'm on a low spec system (Celeron n2830) and:
1) IE plays 720p60 and 1080p60 butter smooth.
2) Chrome stutters like crazy with the same video. Tried hardware accel on and off and even forcing Flash playback. No luck so far.

I'm on Win 8.1 64bit all drivers updated.


Seems like Chrome ignores the CPU/GPU acceleration for video decoding. IE doesn't. CPU is so high playing those videos on chrome that the computer becomes useless. On IE I can play the video and work in other apps with no performance hit.

Comment 29 by Deleted ...@, Jun 3 2015

I have  this  exact problem on my new Asus Transformer. It is a low-budget tablet/laptop with 1,6GHz Atom, but that shouldn't matter here. On Firefox or IE I can watch 1080p60fps with no problems, and on Chrome over half of the frames are dropped and Chrome uses up 100% of my CPU.

I also disabled the hardware acceleration on chrome, in chrome://flags and I also tried it from advanced settings. I checked from chrome://gpu and it says that video decoding is still Hardware Accelerated... this on version 43.0.2357.81 m

For now it is unusable for me to watch youtube through Chrome, ad it is a shame.
Bought a new GTX 750 Ti. Same problem. It's a Chrome issue. Please Google fix it!

Comment 31 by Deleted ...@, Jun 11 2015

Did you guys enable "Override software rendering list"? It can be found in chrome://flags/
Of course we have. That's just not working on ANY hardware. If you got it working can you record your screen while you watch a 4K video on youtube while your task manager is open on the performance tab showing the cpu load? Thanks.
A 1080p video would be even good, but if you have a great CPU the load cannot be noticed (that's why I requested a 4K video). So if you can test it on a "normal CPU" (ex. a slow dual core cpu) and a monster video card (such as a Radeon R7 or GTX 970) it would be nice. You can notice the massive cpu load on chrome and 0% of cpu load on Internet Explorer. This is bad for laptops. Still waiting for a solution.
After the last Chrome update (Version 43.0.2357.124 m (64-bit)) if I force to use Flash then it uses GPU decoding for 4k video and I haven't lags. But by default it uses HTML5 which plays laggy using CPU.
HTML5 should use Hardware Decoding by default, but Chrome/ium does not.

Comment 36 by Deleted ...@, Jun 11 2015

In my tests, I have found that Chrome does hardware accelerate media whenever possible and typically falls back to software decode (more CPU), when a) there is no hardware support for the codec or b) the hardware fails to accelerate despite advertising that it does. (A GPU driver update once caused my entire Win 7 machine to start to crawl on Chrome)

About YouTube: It looks like YouTube uses two codecs - H.264 and the newer codec VP9. Based on my tests, YouTube seems to prefer VP9 codec (They detail their reasons in this blog --  http://youtube-eng.blogspot.com/2015/04/vp9-faster-better-buffer-free-youtube.html

So, if you're seeing more CPU usage, It could be that what you're watching is actually being served VP9. It looks like the latest Galaxy S6 and NVIDIA Shield seem to have VP9 hardware acceleration and more GPUs are claiming they will soon. Intel doesn't seem to have a solution yet, or at least I didn't find any. 

While I typically like the better visual quality of VP9 (sweet spot seems to be 720p@60), I can see that in some cases, you might be CPU constrained. In those cases, I have found h264ify to be a good solution to ensure I get the H.264 stream from YouTube. https://chrome.google.com/webstore/detail/h264ify/aleakchihdccplidncghkekgioiakgal?hl=en-US

Also, the latest dev channel seems to be helping a bit w/ reduced CPU and power usage. 

Hope this helps.
That's not possible that a GTX 970 or a R9 295X2 do not support newest codecs. That means that Chrome will never work with any video card. Again, it's a chrome issue. Drivers are fine.

Comment 38 by Deleted ...@, Jun 11 2015

https://forums.geforce.com/default/topic/806676/question-is-vp9-decoded-in-hardware-on-any-nvidia-gpus-/

Seems to claim that NVIDIA still doesn't support GPU decode of VP9 and I couldn't find something similar for Radeon cards either. 

http://www.digitaltrends.com/computing/intel-gives-home-theater-enthusiasts-gift-h-265-vp9-hardware-decode-support/ claims that Intel seems to have added "partial" VP9 and HEVC decode. So, not fully accelerated, but might still see some benefits. 

> Again, it's a chrome issue. Drivers are fine.

I don't see how we can blame Chrome here. 

As a platform, they support a set of codecs (and are the only ones who seem to push new technology with VP9 support). YouTube prioritizes which codecs it needs to use (VP9 and then H.264) 

And as users, if we don't agree with YT's prioritization, we have options (see extension linked earlier) to modify that. 

I personally think that this is almost an insane amount of control given to the users about a platform and I really like it. 
So if NVIDIA and AMD don't make VP9 Hardware Acceleration there MUST be a reason. Chrome uses VP9, then H264. But if VP9 is not supported by both, why should we use VP9 and then H264? I can't understand. H264 seems to be better then, since it is supported by Intel, NVIDIA and AMD.
Anyway, I have tested it right now on 4 pcs and it seems that h264ify solves all the problems and makes all videos hardware accelerated. Thanks for posting this: I didn't know this extension.

Comment 41 Deleted

Comment 42 by Deleted ...@, Jul 3 2015

hi

I have acceleration enabled

Override software rendering list Mac, Windows, Linux, Chrome OS, Android
Overrides the built-in software rendering list and enables GPU-acceleration on unsupported system configurations. #ignore-gpu-blacklist
Disable

I have a GTX 970 and I5 4430.

this video does not use the hardware acceleration (on 4k I get 40% cpu load and 6% GPU load.

https://www.youtube.com/watch?v=HPp9WB4IstQ#t=41

on the IE 11 I have hardware acceleration -  CPU load 5% and GPU load 36%

why does Chrome not use hardware acceleration and IE does?
Clipboard123x.jpg
2.3 MB View Download
That's because Google Chrome uses a codec called VP9 (as we mentioned above) which is totally unknown to AMD and NVIDIA (I don't know why, but there must be a reason... maybe this codec sucks?). If you install the h264ify extension, Chrome will use CPU plus GPU for decoding because it forces the use of H264 (which is one of the enormous range of codecs that NVIDIA and AMD support). The bad thing is that you will get also high CPU usage on slow systems like netbooks because it uses CPU + GPU, but this time the video won't lag. Anyway, on Adreno and PowerVR video cards (for phones and tables) there's complete VP9 acceleration for both decoding and rendering.

Comment 44 by Deleted ...@, Jul 29 2015

I've a similar problem on atom n550 + GPU ion2.I.E works perfects on h264,but chrome and Firefox very lag on vp9.
Thanks for plugin h264ify.Regards

Comment 45 by axfe...@gmail.com, Oct 15 2015

For what it's worth, it seems that I can only get hardware decoding to work in Chrome on Youtube if I use BOTH the "Disable Youtube HTML5 Player" extension (which forces it to use Flash, not that I have any great love for Flash) and the "h264ify" extension. Not sure why their html5 player seems hardcoded not to use hardware acceleration.

Comment 46 by axfe...@gmail.com, Oct 15 2015

Unfortunately, the flash player doesn't seem to do 60fps, so this isn't quite a comprehensive workaround.
On Firefox there's complete H.264 acceleration on latest update. Sill no HW acceleration on Chrome.
Same here, IE11 runs the videos with 1080p 60fps on youtube smooth, but on the chrome it freezes all of the time.
same problem, in chrome://gpu it says 

[10728:10132:0204/113721:ERROR:gpu_video_decode_accelerator.cc(370)] : HW video decode not available for profile
any progress on this issue?

Comment 51 Deleted

Comment 52 Deleted

Comment 53 by slava...@gmail.com, Apr 27 2016

Have this problem after installing Hyper-V role service (on Win10 Pro), when doing system restore to the point it worked, its working again.
Probably does not work through a hypervisor type-1 in parent partition.
Can someone explain:

Chrome shows barely half the accelerated codecs -Skylake does VP9 and h264/265

In Chrome:
szDXVAHDEnglish	Supported
szDXVAModes	ModeMPEG2_A ModeMPEG2_C ModeWMV9_C ModeVC1_C
szDescription	Intel(R) Iris(TM) Graphics 540

In DXVA Checker:
HEVC_VLD_Main10: DXVA2/D3D11, SD / HD / FHD / 4K
VP9_VLD_Profile0: DXVA2/D3D11, SD / HD / FHD / 4K

Comment 55 Deleted

Sign in to add a comment