New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 454396 link

Starred by 23 users

Issue metadata

Status: Duplicate
Merged: issue 331571
Owner:
Last visit > 30 days ago
Closed: Feb 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 2
Type: Bug

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment

Play Store "market://" link is no longer working on any Android device (do not redirect to Play Store app)

Reported by alex.tro...@spotme.com, Feb 2 2015

Issue description

UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.94 Safari/537.36

Steps to reproduce the problem:
1. Open market://details?id=com.android.chrome in Chrome on Android
2. 
3. 

What is the expected behavior?
Open Chrome App in Play Store App

What went wrong?
"This web page is not available" message

WebStore page: market://details?id=com.android.chrome

Did this work before? Yes Chrome v 18 for Android

Chrome version: 40.0.2214.94  Channel: stable
OS Version: Android (4.1-5.0)
Flash Version: Shockwave Flash 16.0 r0

http://stackoverflow.com/a/28279849/3134602

I was testing "market://details?id=" url on different devices with different OS/Play Store/ Play Services/ Browsers. looks like it's related to browser but not OS or Play Services.

Initially I updated Play Services and Google Play Store and my old Chrome (v18) was opening "market://details?id=com.android.chrome" url fine.

Afterward I had updated my Chrome (v18) to version 40. And it's not working any more.

Meanwhile, FireFox and default "Browsers" still opens this url and redirects to Google Play Store app.
 
Labels: -OS-Mac OS-Android
Same problem here
Owner: tedc...@chromium.org
Status: Available
tedchoc@ - Can you please comment?

Comment 4 Deleted

Comment 5 by beni...@gmail.com, Feb 3 2015

Same here
Actually I noticed that when I have a goo.gl 302 redirect to the market:// schema, I get the market:// address in the address bar, with message "The Web Page is not Available". Hitting " Reload Page" doesn't help. If I then tap on the address bar, and hit "Enter", then Google initiates a search for the above term.
Same issue please look into this.

Comment 8 by Deleted ...@, Feb 16 2015

Same issue please look into this.
We are also having an issue, to a user it looks like a problem with the site

Cc: tedc...@chromium.org
Mergedinto: 331571
Owner: jaekyun@chromium.org
Status: Duplicate
Also see:
https://code.google.com/p/chromium/issues/detail?id=451956

The change was made so that typing in the omnibox should never redirect you to an external intent.

Comment 11 Deleted

To clarify, with chrome from now on - market:// will never work?

Is there any way to redirect a user to the Google Play store?
From the omnibox, no, there is no plans to allow external redirects.  If typing in the omnibox, the user is showing a strong intent to stay within chrome, so we made the decision to not allow external redirects (too many of them led to what we believed to be bad user experiences).

Clicking on a link should still behave as before and redirect to market:// links.
I hope there is an update or clarification on this issue.
As it stands, how can I programmatically redirect a user to the play store? 
There is no plans to support a redirect without a user gesture.

Comment 18 by Deleted ...@, Jun 25 2015

We have a simple webview in our app that includes links to our other apps in the play store. According to Google's developer docs (http://developer.android.com/distribute/tools/promote/linking.html), the correct method is to use market://, which we're doing. 

If Google is no longer supporting deep linking, even for the Play Store app, shouldn't they update their developer docs? Or if the developer docs are correct but the behavior is broken (users with Android 5+ are getting the error that is the topic of this thread), isn't it a bug, at least with regard to deep links to the Play Store app?
Chrome has never stopped supporting deep linking. An Intent navigation was blocked only when it was redirected from a user typing.

Moreover an Intent navigation with an external URL is allowed since M43, and so the market:// URI will work anyway.

FYI, this kind of restriction is applied only to Chrome, not to WebView.

Comment 20 by dcic...@gmail.com, Nov 8 2015

Don't understand why play store not working and you tube
Im tired of being hacked with ur help.I hate googles lack of security,or investagation skills.u dont care about privacy issues.david dumetz is not my admin.there shud be no host ..his adsense account is promoting his criminal acts of hacking and posting ones dàta on his website.916-889-2200,ddumetz916@gmail.com.is a Hacker.
Labels: Restrict-AddIssueComment-EditIssue

Sign in to add a comment