New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 452896 link

Starred by 7 users

Issue metadata

Status: Duplicate
Merged: issue 451956
Owner:
Last visit > 30 days ago
Closed: Jan 2015
Cc:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 2
Type: ----



Sign in to add a comment

intent urls broken if URL entered manually (Chrome 40.0.2214.89)

Reported by konstant...@citrix.com, Jan 28 2015

Issue description

A web page that redirects to an intent URL results in an error message in Chrome 40 (instead of launching the installed app). This is reproducible if the URL is entered manually in the browser.

Device: Samsung Galaxy Nexus
OS: Android 4.2.1; Galaxy Nexus Build/JOP40D
Application Version: Chrome 40.0.2214.89

Device: Sony Xperia Z3
OS: Android 4.4.4; D6603 Build/23.0.1.A.5.77
Application Version: Chrome 40.0.2214.89

Device: Samsung Galaxy S4
OS: Android 4.4.2; GT-I9505 Build/KOT49H
Application Version: Chrome 40.0.2214.89

URL: http://lastpageofthe.net/chrome40bug.html

Behaviour in Android Browser: launches GoToMeeting app as expected 
(if intent: urls are supported, which the case at least since Android 3)

Steps to reproduce:
1. Install GoToMeeting App from Play Store (it's free):
    https://play.google.com/store/apps/details?id=com.citrixonline.android.gotomeeting
2. Open http://lastpageofthe.net/chrome40bug.html

Expected result:
GoToMeeting app opens (as it is installed).

Actual result:
Error page saying that "intent:" is an unknown URL scheme (see attached image)
 
chrome40-intent-bug.png
81.2 KB View Download
Labels: M-40
Owner: tedc...@chromium.org
Status: Assigned
Cc: tedc...@chromium.org
Mergedinto: 451956
Owner: jaekyun@chromium.org
Status: Duplicate
This behavior was changed as part of this:
https://code.google.com/p/chromium/issues/detail?id=331571

tldr: If typing in the omnibox, Chrome will no longer launch an external app because it is going against their attempt to navigate to the given URL, which we feel is the strong desired behavior when interacting with the omnibox.

With that said, the error page is something we are going to address in an upcoming release.
Hey guys,

I work for a company called Branch (branch.io) which provides links for mobile devs. This is a pretty big change for companies who want to link to their app and might not have a mobile website.. We're getting reports of users pasting our links into Chrome and seeing these ugly error messages.

What can we expect for the developers who don't plan on building a web experience but still want links to their app?

Alex
Hi!

I'm having the same issue here. I guess the only solution is to provide a button for the user to click.

Cheers,
Kosta

Sign in to add a comment