New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 9 users

Issue metadata

Status: WontFix
Owner:
Last visit > 30 days ago
Closed: Jan 2015
Cc:
EstimatedDays: ----
NextAction: ----
OS: Android
Pri: 2
Type: ----



Sign in to add a comment
link

Issue 451956: Intent Scheme are not working anymore

Reported by si...@zeek.me, Jan 26 2015

Issue description

Device name:

From "Settings > About Chrome"
Application version: 40.0.2214.89
OS: 5.0.1 (also 4.1.2)

URLs (if applicable): http://dl.zeek.me

Behavior in Android Browser (if applicable): Open Native App if exist or Open Play Store



Steps to reproduce:
1. Tap the url http://dl.zeek.me in the chrome url bar
2. You'll get an error "unknown_uri_scheme".

3. Open a new tab, then click on the historic link that appears on your screen (or just search for the link in your historic and tap on it).
4. The intent work smoothly

Expected result:
Open Native App if exist or Open Play Store

Actual result:

When Tapping url in url bar, it's not working. But when tapping from historic or other place, it is working.
 
Screenshot_2015-01-26-12-08-08.png
63.6 KB View Download
Screenshot_2015-01-26-12-07-48.png
126 KB View Download

Comment 1 by kravula@google.com, Jan 26 2015

Cc: klo...@chromium.org
Owner: tedc...@chromium.org
Status: Assigned
tedchoc@ please comment on this issue

Comment 2 by tedc...@chromium.org, Jan 26 2015

Cc: tedc...@chromium.org
Owner: jaekyun@chromium.org
We recently made a change that typing in URLs into the omnibox should never trigger external intents, so this sounds like working as intended based on the changes.

Adding jaekyun@ who did the work.

Comment 3 by jaekyun@chromium.org, Jan 26 2015

Status: WontFix
Ted is right. In  http://crbug.com/331571  we decided not to start an Intent if the original navigation is started from a user's typing because we thought that generally a user wouldn't expect to leave Chrome when typing a URL into the omnibox.

Comment 4 by klo...@chromium.org, Jan 26 2015

FYI, we will change the behavior a little bit. In you type the url, the page will stay in that url instead of navigating to the error page in the future Chrome.

Comment 5 by si...@zeek.me, Jan 27 2015

Hi thanks for you quick answers.
I can understand the behavior you gave, it can make sense.

But then I have another bug to share.

Let's say I'm sending the link http://dl.zeek.me via Whatsapp App. It will open the browser but Chrome will fire the same error... And no one typed the address in the URL bar.

Can you explain why? How to pass this error? 

Thanks!

Comment 6 by jaekyun@chromium.org, Jan 27 2015

simon@, I tried to reproduce your case with Whatsapp App and several Chrome versions, but I failed.

When I tested with Chrome version 40.0.2214.89, clicking http://dl.zeek.me via Whatsapp App redirected to http://www.zeek.me .

And when I tested with Chrome version 39.0.2171.99 and 41.0.2272.34 (internal dev version), clicking the URL launched Chrome, and then launched Google Play app showing the Zeek app.

Could you please elaborate more how to reproduce your issue? On which Chrome version did you see the problem?

Comment 7 by si...@zeek.me, Jan 28 2015

Hi,

the reason why you can't see the bug anymore is because I scripted a bypass that check if Chrome/40 is present on User Agent, then it will redirect to the website instead of throwing an error.

I will created a specific file for the Chromium team to run some tests:
here is the address: http://dl.zeek.me/chromium.html

Please try the same issue as before. Send the link on Whatsapp App or even something else (mail etc.)
The intent will not work and throw the same error as before.

Thanks

Comment 8 by jaekyun@chromium.org, Jan 28 2015

I tested the new URL with GMail and Chrome v40.0.2214.89 on my nexus 7 device having android L, but I couldn't see any error page. I was able to see only a small "Z" icon.

Could you please share a video capture?  On what device did you see the issue?

Comment 9 by jaekyun@chromium.org, Jan 28 2015

I tested again with my nexus 5 device having android L, but I could't see any error page either.

BTW, http://dl.zeek.me/chromium.html has syntax error. '}' should be added after line 43.

So I tested with "http://www.pandora.com" which does similar thing with your site. I confirmed that Google Play was started normally when the site was loaded.

Comment 10 by si...@zeek.me, Jan 29 2015

Hi,

sorry for these painful and no sense mistakes.
I checked and rearrange my code.
And I found the problem again.

Case 1: You don't have the Zeek App.
On Whatsapp App (or anything else where the link will be), clicking on the link http://dl.zeek.me/chromium.html will redirect me to the Play Store, which is fine.

Case 2: You have the Zeek App

On Whatsapp App (or anything else where the link will be), clicking on the link http://dl.zeek.me/chromium.html will open a sort of modal, asking if the user want to open the link with Chrome or Zeek. Click on just once with Chrome, and you'll get the same error as before.

From what you explained before, about tapping the URL and the omnibox, I can understand. But Here the user is not tapping the URL, he's clicking and following a link.

I tested with Nexus 5, 5.0.1, and last version of Chrome.

For your testing, you can download the app here:
https://play.google.com/store/apps/details?id=com.marketplaceapp&hl=en

Comment 11 by tedc...@chromium.org, Jan 29 2015

 Issue 452896  has been merged into this issue.

Comment 12 by jaekyun@chromium.org, Jan 29 2015

I understood what you have seen correctly.

But, the case 2 is also intended because we decided not to leave Chrome if a user selects Chrome as a viewer among all the possible applications.

Comment 13 by konstant...@citrix.com, Jan 30 2015

How is a web page supposed to know whether it can open an intent: url? 

I would like to direct users to the app if possible (as this is the best user experience for users in this case), but avoid that error page (as this is a very bad user experience).

Comment 14 by jaekyun@chromium.org, Jan 30 2015

Sorry, but there isn't any way in web content to detect whether an Intent URI will be processed or not.

One good news is that the page will stay in the current URL instead of navigating to the error page in the future Chrome. So users will not see an error page anymore.

Comment 15 by konstant...@citrix.com, Jan 30 2015

Ok, I think that's reasonable. When do you think you can ship that fix?

Comment 16 by jaekyun@chromium.org, Feb 1 2015

That will be available from M42.

Comment 17 by konstant...@citrix.com, Feb 2 2015

@jaek: Thank you!

Sign in to add a comment