Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 11 users
Status: Duplicate
Merged: issue 43400
Owner:
User never visited
Closed: May 2010
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
Extensions using Google Analytics async crash on Mac (and Debian)
Reported by jstri...@gmail.com, May 24 2010 Back to list
Chrome Version       : 6.0.408.1 (Official Build 47574) dev


What steps will reproduce the problem?
1. Add Google Analytics to your extension's background page (you can even
use the snippet from here:
http://code.google.com/chrome/extensions/tut_analytics.html)
2. Install the extension on Mac dev builds (I've also heard reports that
this breaks on Debian too, but haven't confirmed).

What is the expected result?
Extension and Google Analytics should work. This works fine on Ubuntu and
Windows.

What happens instead?
 - Extension consumes 100% CPU and blows up to 500-600 MB of memory.
 - Extension pages (options, browser actions) can't be loaded.
 - Extension either crashes or you need to disable it.

Please provide any additional information below. Attach a screenshot if
possible.

I've attached a screen shot and a test case extension (all it does it have
a background page with analytics .. using a fake account code ... and have
an options page).

Here is the background page being used (you can replace the account with a
real one and it still doesn't work):

<html>
  <script>
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-XXXXXXXX-X']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript';
ga.async = true;
    ga.src = 'https://ssl.google-analytics.com/ga.js';
    (document.getElementsByTagName('head')[0] ||
document.getElementsByTagName('body')[0]).appendChild(ga);
  })();
  </script>
</html>

Here are some mailing list posts for reference:

http://groups.google.com/a/chromium.org/group/chromium-extensions/browse_thread/thread/9eca2c772b6bdbbf/9d0347982fa967c7?lnk=gst&q=analytics+mac#9d0347982fa967c7
http://groups.google.com/a/chromium.org/group/chromium-extensions/browse_thread/thread/290a81213fb50e50#

 
Screen shot 2010-05-24 at 5.31.53 PM.png
10.5 KB View Download
chrome_crasher.crx
1.1 KB Download
Comment 1 by pl.duh...@gmail.com, May 26 2010
I confirm that the problem can be also reproduced on Debian.
Labels: -Area-Undefined Area-UI Feature-Extensions OS-Mac
Status: Assigned
This looks like it could be related to 42792. Hence my assignment to you, Aaron.
Comment 3 by cnan...@gmail.com, May 26 2010
Glad to see I wasn't the only one having problems with this. I was getting emails about 
my extension not working on newer Mac releases, so I emailed them a version with Google 
Analytics removed, and now it is working fine for them.
Comment 4 by jieqiw...@gmail.com, May 26 2010
My user reports a workaround for this bug: open the popup page (chrome-extension://), and then click the icon 
again. It will work from then on. 


Comment 5 by aa@chromium.org, May 27 2010
Andy: did you mean related to 43400? It certainly does seem to be related. Not going to mark duplicate until I 
confirm that (the symptoms seem slightly different).
Comment 6 by aa@chromium.org, May 27 2010
Mergedinto: 43400
Status: Duplicate
Same symptom when I run it in os x as 43400 so going to go ahead and call it a dupe.
Project Member Comment 7 by bugdroid1@chromium.org, Oct 12 2012
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:43400
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 8 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Area-UI -Feature-Extensions Cr-Platform-Extensions Cr-UI
Sign in to add a comment