New issue
Advanced search Search tips
Starred by 3 users

Issue metadata

Status: Duplicate
Merged: issue 29427
Owner: ----
Closed: Jun 2010
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
link

Issue 44460: CSS3 inset box shadow does not follow border-radius

Reported by tomaspol...@gmail.com, May 18 2010

Issue description

Chrome Version       : 6.0.408.0 (47482)
URLs (if applicable) : www.webdesignerwall.com/demo/css3-search-form.html
Other browsers tested: Firefox 3.6
Add OK or FAIL after other browsers where you have tested this issue:
Safari 4:
  Firefox 3.x: OK
IE 7:
IE 8:

What steps will reproduce the problem?
1. Open a webpage that has a block element with both a border-radius and a 
inset box shadow. Something like this:

#element{
	-moz-border-radius: 1.5em;
	-webkit-border-radius: 1.5em;
	border-radius: 1.5em;
	-moz-box-shadow: #999 3px 3px 10px inset;
	-webkit-box-shadow: #999 3px 3px 10px inset;
	box-shadow: #999 3px 3px 10px inset;
}

What is the expected result?
The element should display correctly. The drop shadow should follow the 
rounded corners and not overlap element's boundaries.

What happens instead?
You see the drop shadow is applied to the squared element's container, does 
not follow the rounded corners.

Please provide any additional information below. Attach a screenshot if
possible.

If you take a look at this post, which explains how to do a CSS3 form with 
drop shadows and rounded corners:

www.webdesignerwall.com/tutorials/beautiful-css3-search-form/

You'll see that the final result should look like this:

www.webdesignerwall.com/wp-content/uploads/2010/05/search-form-preview.gif

But in the current Chromium nightly build looks like this:

dropbox.bootlog.org/shadow-radius-error.png

You can test the live example over here:

www.webdesignerwall.com/demo/css3-search-form.html

Hope you can take a look at this!
 

Comment 1 by brandonc...@gmail.com, Jun 20 2010

Comment 2 by thakis@chromium.org, Jun 20 2010

Mergedinto: 29427
Status: Duplicate

Comment 3 by bugdroid1@chromium.org, Oct 12 2012

Project Member
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:29427
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.

Comment 4 by bugdroid1@chromium.org, Mar 11 2013

Project Member
Labels: -Area-Undefined

Sign in to add a comment