New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 4 users

Issue metadata

Status: Duplicate
Merged: issue 442318
Owner: ----
Closed: Jan 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug-Regression



Sign in to add a comment

When saving certain pdf files using Chrome, the files become corrupt.

Reported by adamho...@yahoo.com, Dec 3 2014

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; rv:11.0) like Gecko

Steps to reproduce the problem:
1. Open Chrome
2. Preview certain PDF documents with the Chrome PDF viewer plugin
3. Click the save (floppy disk) icon.
4. Attempt opening the saved pdf.

What is the expected behavior?
The pdf file opens correctly and is not corrupt. 

What went wrong?
 When reopening a saved pdf file there is an error saying file is corrupt. 

Did this work before? Yes October 2014

Chrome version: <Copy from: 'about:version'>  Channel: n/a
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
Flash Version: Shockwave Flash 15.0 r0

In particular I have noticed it happening with pdf files downloaded from an online mapping software called Surety Customized Online Mapping Software. www.agridatainc.com

Disabling the Chrome PDF Viewer and enabling Adobe Reader plugin allows a successful save of a pdf from preview mode.

Saving the pdf with any other browser does not reproduce issue. 
 Issue 62460  seemed to be a similar issue.
 
Larger Parcel Aerial Tract 3A 3B 3C.pdf
32.0 KB Download
Cc: chinta@chromium.org
Labels: Needs-Feedback
This issue is not reproducible on Windows 7 with latest Stable 39.0.2171.71, Beta 40.0.2214.10 and Dev 41.0.2236.0.

I downloaded the attached PDF and it is failed to open in chrome and Pdf reader. Seems that attached PDF is corrupted.

adamhoime@:
Can you please retest the issue by dowloading the any pdf from the given site.
Also could you please mention on which chrome version you noticed this issue.
We produce an online software system that generates pdfs in the browser and we are finding that all chrome customers are also experiencing this issue with saving the pdfs to their local machine. It is reproducible every time we generate a pdf from our system in the browser. Happy to provide access to a test system if it means we can get this fixed because it is causing a lot of problems with the latest Chrome update.
Labels: Cr-Internals-Plugins-PDF
It would be helpful if the test system access is provided. Please provide us the access details and detailed steps to reproduce the bug with the test system. Also please mention the versions of chrome you are facing the issue so far.

Comment 4 by adamho...@yahoo.com, Dec 12 2014

I am not experiencing the issue on my particular machine GC version 39.0.2171.95 m. However, many of our clients are reporting this. I was able to get the version of one of the affected clients. 
39.02171.71m  
Using Windows 8
Browser appeared to not be using any add-ons. 

Operating system does not appear to make a difference as it has been reported on Windows 8, windows 7, and Mac(not sure which OS version)

You can access a trial version of our program at www.agridatainc.com and logging in with the following credentials:
Username:ChromeTest@test.com
Password: chrome1

Click on FSA Map in the right panel and use the View as PDF option.

Comment 5 by gre...@gmail.com, Dec 17 2014

We are experiencing this problems too in the website echevarne.com We create online pdf's that are working fine in FF or IE, but they become corrupted when saved using pdf built-in feature in Chrome.

This problem only exists in version 39 of Chrome.

Comment 6 by rob@robwu.nl, Jan 22 2015

Labels: -Needs-Feedback
Mergedinto: 442318
Status: Duplicate
Already fixed in Chrome 41, follow  issue 442318  and the linked duplicates at the end for more details.

Sign in to add a comment