Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 48 users
Status: Verified
Owner:
User never visited
Closed: Oct 2010
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Linux, Mac
Pri: 2
Type: Bug
M-8

Restricted
  • Only users with EditIssue permission may comment.



Sign in to add a comment
using analytics in extension causes it to not work on Mac and Linux
Reported by tumto...@gmail.com, May 6 2010 Back to list
Chrome Version       : 5.0.375.29 dev
URLs (if applicable) :
https://chrome.google.com/extensions/detail/bfbameneiokkgbdmiekhjnmfkcnldhhm
https://chrome.google.com/extensions/detail/hndfgfengoiooldicmmapepfdamlceio
OS version               : 10.6.3
Behavior in Safari 3.x/4.x (if applicable):
Behavior in Firefox 3.x (if applicable):
Behavior in Chrome for Windows: The very same extensions DO work

What steps will reproduce the problem?
1. Install one of the extensions above (I assume those are just a few examples of extensions that 
won't run on (my version of) Chrome for (my version of) Mac OS)
2. Click the browser_action or page_action button (popup)

What is the expected result?
The popups can't be accessed, so the extension isn't usable

What happens instead?
Most of the time nothing happens, sometimes an empty popup opens. When trying to acces the 
console log of the background page, often the extension crashes or the console is completely 
empty.
 
Labels: -Area-Undefined -Pri-2 Area-UI Pri-1 Feature-Extensions
Status: Assigned
Comment 2 Deleted
Comment 3 by tumto...@gmail.com, May 8 2010
I found out today that the bug occurs if the background page isn't loaded!
If I access the background page myself the extension starts working. I found out that by ordering the entries in 
the manifest file differently the background page does load, so it sometimes doesn't correctly load the 
background page.
Status: Started
Comment 5 Deleted
OK. Here's what I've figured out so far...

o This behavior is only reproducible in Release mode. In Debug it works fine.
o It only will occur if you have not had the extension installed before r42022 by Darin (http://codereview.chromium.org/1090002/show) explaining the 
intermittent repro cases. Meaning that any Release mode build from 42022 with a clean profile will exhibit this behavior, but a 42022 build with a profile 
that already had this extension installed is just fine.
o I've attached a diff of the profile folders for a working vs. not working 42022 build. Nothing shouts out as being suspicious.

This is all very strange.

Next steps - We need to see if this is reproducible on other platforms. Finnur, any chance you can see if the behavior is the same on Linux?

Darin, any insights as to why this could be happening right as your change was checked in?

profiles.diff
1.9 KB View Download
Comment 7 by finnur@chromium.org, May 13 2010
I'm not a Linux expert, I just play one on TV. :)

I tried this on official Linux dev build and I could not see any issue with these 
extensions. I should point out, however, that the Facebook extension does not have a 
popup window; clicking the icon takes you to Facebook's website. The Web Developer 
extension worked fine on Linux (shows a dynamicly changing popup window).
I can confirm we're having the same issue with a number of our Extensions:

https://chrome.google.com/extensions/detail/mdonfjaemnemdnnpebbcelibeocdmkai
https://chrome.google.com/extensions/detail/fhmdaecjgjckkkphaejljjneimlfgfdh

These all work fine on Windows, but on Mac (OS X 10.6.3 / 5.0.375.53) it appears as 
reported that the background page is not loaded. Loading the background page directly 
from its chrome-extensions:// url does then corrects the problem.

@tumtoons - how exactly did you solve the issue? Where within the manifest did you move 
the background_page from/to? I would guess this isn't a permanent fix, but even a 
temporary resolution would be useful! 
Comment 9 by aa@chromium.org, May 25 2010
I see this and can help with it tomorrow when I'm in front of my mac. Is this issue present in the about-to-
become-stable 5.0?
Thanks very much, unfortunately I'm not on a Mac, so can't confirm
exactly which revision the bug first appeared in, but it's definitely
visible and reproducible on 5.0.375.53
Status: Assigned
Yes it is in the stable version.

Thanks, Aaron.

Assigning to you for now, but assign it back if necessary.
Comment 12 by aa@chromium.org, May 27 2010
So all these extensions use google analytics. The analytics script seems to be fetched OK. The extension seems to 
load fine so long as I comment out _trackPageView(). As a workaround developers could remove that line. I'll 
keep looking tomorrow. 
Comment 13 by aa@chromium.org, May 27 2010
 Issue 44941  has been merged into this issue.
Comment 14 by aa@chromium.org, May 27 2010
I'm not sure what to do next here. I can repro this easily with the attached extension on Chrome for OS X 
5.0.375.55 (Official Build 47796). But when I build the same revision from the release branch from source in 
Release mode, it never repros. I'm using a clean profile in both cases.

I can't repro on linux at all.

Adding some mac masters for suggestions on anything else that could be different between the Chromium I 
build locally from the release branch and the Google Chromes in the wild.
test.zip
2.0 KB Download
Comment 15 by leons...@gmail.com, May 28 2010
Same problem on Linux with Chrome 5.0.375.9 dev, when using Google Analytics inside 
extension.
Comment 16 by leons...@gmail.com, May 28 2010
@aa your test extension reproduces error on my configuration.
I can confirm this on Linux. Same happens here since a few months ago. Now using 
6.0.412.0 (47875) on Ubuntu Hardy 32 bit on my box here, the test extension also 
reproduces this bug.

Also tried another extension using analytics on Karmic 32 bit and Lucid 64 bit with 
clean profiles using latest daily builds from the Ubuntu team, all are affected.

Comment 18 Deleted
Comment 19 by aa@chromium.org, May 28 2010
All of the extensions that exhibit this problem use analytics. And disabling the analytics code definitely fixes the 
problem.
Update: if the extension itself doesn't use analytics but injects an IFRAME element 
into the browser action popup page, setting the src attribute to a remote URL which 
page uses analytics, the same issue happens.

Comment 21 by aa@chromium.org, Jun 1 2010
I have a theory on this bug. To help me validate it, can people who have seen crashes with this bug please 
send me their crash report client_id string. You can find it by following these instructions:

http://www.chromium.org/for-testers/bug-reporting-guidelines/reporting-crash-bug

Search for 'client_id'. I don't need you to follow all the steps there, I just need the client_id string.

Thanks!
The extension doesn't crash on my PC. When I enable, it starts using more and more 
memory (always up to 530MB) and uses 100% CPU. This lasts for around 30 secs, then 
suddenly the used memory goes back to 4MB, CPU to 0% but it won't work after then 
either.

OS version: OS X 10.6.3
client_id: 8C95B52F-AB69-1D02-F82B-ED16A4B09CE3

Crash happens when I open the background page manually from the extensions page. I open 'background.html' 
> script tab. The tab is empty and within 10 seconds the extension crashes.

p.s thanks for the update on Google Analytics, I can make extensions work with a bit less effort now :-)
@tumtoons - thanks
@aa - my client_id: 720A0029-DDF6-D32E-E990-E0988366A940

 Issue 45259  has been merged into this issue.
Summary: using analytics in extension causes it to not work on Mac (was: NULL)
Labels: OS-Linux
Summary: using analytics in extension causes it to not work on Mac and Linux (was: NULL)
I've just upgraded my chromium to 6.0.440.0~svn20100617r50068-0ubuntu1~ucd1~lucid and this bug seems to be fixed. Can you confirm?
Comment 29 by alm...@gmail.com, Jun 18 2010
My Google Chrome version is 5.0.375.70 and I dont find any way of upgrading
it to your version, it says it is up to date.
Another problem I see, is that with google Chrome over Mac, I lose the info
of the forms... Nor over Windows or Firefox.

Regards.
Comment 30 by tumto...@gmail.com, Jun 18 2010
6.0.427.0 dev for Mac
build is up to date, bug remains
@almu84, @tumtoons: i'm using the daily build by the ubuntu team, your versions are older than mine.
Comment 32 by jstri...@gmail.com, Jun 22 2010
@dulphy.hu: Are you sure you reproduced it on Ubuntu? I've been running Ubuntu 9.10 64-bit and have never seen the bug, but it's been around on my Mac machine for a while. I also heard reports of it affecting Debian.
@jstritar: Yes, I'm sure.

Since my latest update I've tried with chromium version 6.0.444.0~svn20100621r50329-0ubuntu1~ucd1~hardy (on ubuntu hardy 32bit) too and the bug still exists.

On my other PC running version 6.0.440.0~svn20100617r50068-0ubuntu1~ucd1~lucid (on ubuntu lucid 64bit) the issue doesn't happen anymore.

Comment 34 by karen@chromium.org, Jun 24 2010
Labels: karen624move Mstone-X
It looks like we've conclusively found this doesn't work for 6.0.* on Mac or Linux. If it's specifically caused by Google Analytics there is a temporary work-around, but it's not an ideal long-term solution to not be able to track Mac or Linux users.

Should we flag this to the Analytics team, or is it a Chrome issue? Has the underlying reason for this bug been identified?
I'm using 5.0.375.99 Ubuntu linux. Google Analytics works fine. But not working the same version on Mac
@aa, just reproduced this on a Macbook with the sample extension located at
http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/extensions/docs/examples/tutorials/analytics/

client_id is: F250486A-77C4-6698-4409-D98B89A567C3
Comment 38 by mbre...@gmail.com, Sep 3 2010
+1 on  Mac with Chrome 6.0.472.53. While Chrome/Os X doesn't crash, the extension sure dose. No client_id.
Comment 39 Deleted
Comment 40 by fcap...@gmail.com, Sep 9 2010
The chrome extensions gallery now includes automatic analytics. 
Look at this:
http://www.google.com/support/chrome/bin/answer.py?answer=188739
Does anyone know how this new "automatic analytics" works? How is it integrated/called from within the extension?
@edward.dbarrow
@fcap...
This only track traffic on the extension page (just like website in Google Analytics). And it does not track the traffic on the extension self.
For extension must you create inside a analytics script (http://code.google.com/chrome/extensions/tut_analytics.html)
Comment 43 Deleted
@cnanney
Read this news post http://blog.chromium.org/2010/09/get-more-data-about-your-extensions.html
For questions about this new feature, we encourage you to visit our developer discussion group and share your feedback with us.https://groups.google.com/a/chromium.org/group/chromium-extensions/topics
Labels: -Mstone-X Mstone-7
I don't think we want to ship this bug.  Here's a nice description of the problem:

http://stackoverflow.com/questions/3586863/google-chrome-extension-mac-compatibility

As far as I can tell, any extension that uses Google Analytics will go into an infinite loop and crash on Mac.  Bad times.
I don't think we want to ship this bug.  Here's a nice description of the problem:

http://stackoverflow.com/questions/3586863/google-chrome-extension-mac-compatibility

As far as I can tell, any extension that uses Google Analytics will go into an infinite loop and crash on Mac.  Bad times.
Comment 47 by aa@chromium.org, Sep 13 2010
Labels: -Mstone-7 Mstone-8
Sad :(
Comment 48 by fcap...@gmail.com, Sep 21 2010
How is it possible such a bug is being completely ignored? It's been reported back in May 06, 2010...that's 4 months and a half!
Some more information about this issue (the following tests have been made on Ubuntu 9.04 with Chrome 6.0.472.63):

My extension (Hover Zoom) makes use of Analytics on the background page and so far I had to test the client's OS (if on Windows then use Analytics). I was puzzled by the Virtual Keyboard extension (by Google) that also uses Analytics without this kind of test: https://chrome.google.com/extensions/detail/mpphfcjpaldmedbbomcdhgonmhjngfig

After some tests, I figured that the main difference was the name of the global Analytics variable, which is "_gaq" by default. In this extension it is named "gaq". I've tried renaming the variable as well in my extension and it fixed the problem. Now, I haven't tested if the tracking still works...
Comment 51 by aa@chromium.org, Sep 28 2010
Status: Available
#48: It wasn't completely ignored. I spent quite a bit of time investigating it, but it was very difficult for me to reproduce in a debuggable way. (adam, I was not seeing it consistently -- maybe it has gotten worse?)

If any developers can reproduce this and would like to take a shot at it, I'd love help.
Comment 52 by aa@chromium.org, Sep 28 2010
Status: Assigned
Adam has kindly offered to take a fresh look at this.
Comment 53 by aa@chromium.org, Oct 4 2010
Labels: Pri-2
This is now at the top of my list.  Attempting to reproduce with the same extension.
I can't reproduce with the same extension.  Trying https://chrome.google.com/extensions/detail/ankgjoopnopeoeljehjkighfcfefalcg
Can't produce with that extension.

> This behavior is only reproducible in Release mode. In Debug it works fine.

Ah, I'll try Release.
I can't reproduce in Release either...
Status: Fixed
It seems like this bug got fixed somehow, either on our end or on the analytics end.  I used to be able to reproduce the issue with an older version of ankgjoopnopeoeljehjkighfcfefalcg, but I can't even reproduce the issue with that version on the same Chrome profile where I originally saw the issue.

If you're still able to reproduce this problem in version 7.0.544.0 or later, please let me know.

Thanks everyone!
Comment 59 by mbre...@gmail.com, Oct 7 2010
From about 6.0.472.63, the analytics doesn't seem to crash Chrome instantly, as it did in other versions. However, given some time, it should cause it to crash. Also, unlike in previous versions, where the script took down the whole browser, in this version chrome should shows the "This extension crashed" message, and handle it gracefully.
"Block Mixed Content" does not include analytics code. 
@mbrevda can you try with version 7.0.544.0 or later?
@jieqiwang The version we put in the gallery doesn't because of this issue.  Originally, we had analytics to help developers find mixed content on their site but pulled the feature at the last minute.  I'm testing with the older version where I saw the bug in the first place.
Labels: Verifier-Deepakg
Verified label updated by AutoAllocator, contact AmolK or KrisR for details
Try this: https://chrome.google.com/extensions/detail/eclhcdahmojonioaafifipekhighmlgo  

It doesn't work on Mac or Linux in current version (6.0.472.63), or 7.0.544.0 in release mode, is fine in debug.
Status: Assigned
Tumblrer for Chrome - https://chrome.google.com/extensions/detail/eclhcdahmojonioaafifipekhighmlgo worked for me.

But I still get a blank bubble for The Next Web - https://chrome.google.com/extensions/detail/fhmdaecjgjckkkphaejljjneimlfgfdh.

Checked in 8.0.551.0 (Official Build 62110).

It seems fixed for most though.
Status: Verified
I see the latest news on Next web now. Marking as verified, not sure why I didn't got a blank bubble yesterday.

Marking as verified.
Comment 67 Deleted
A user of a my extension ( https://chrome.google.com/extensions/detail/ofoaoaloeipdofknnaapbmdddddioklg ) reports that using a MAC the popup doesn't open.

Project Member Comment 69 by bugdroid1@chromium.org, Oct 12 2012
Labels: Restrict-AddIssueComment-Commit
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 70 by bugdroid1@chromium.org, Mar 10 2013
Labels: -Area-UI -Feature-Extensions -Mstone-8 Cr-Platform-Extensions M-8 Cr-UI
Project Member Comment 71 by bugdroid1@chromium.org, Mar 13 2013
Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Labels: hasTestcase
Sign in to add a comment