New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 432595 link

Starred by 5 users

Issue metadata

Status: Fixed
Merged: issue 480716
Owner:
Last visit > 30 days ago
Closed: Apr 2017
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

Office editor extension not working under Server 2008 R2 and Citrix environment

Reported by josuej@chromium.org, Nov 12 2014

Issue description

Chrome and platform version of an affected device (found by navigating to 'chrome://version'): 38.0.2125.111 (Official Build 290379) m 

Issue description: When user adds the Office Editor extension to chrome browser and try to open a Word, Excel or PPT file from drive, nothing appears to happen. They are working in a terminal server environment with Windows 2008 R2 installed and virtualizing via Citrix Xenapp 6.5. When we test it on Windows Server 2012 R2, Windows 7, Windows 8 and Windows 8.1 there are no issues. 

All troubleshooting steps already taken: 
- We tried Canary and Chrome Beta 
- Incognito mode 
- 64bit of Chrome 
- Removed and add the extension. 

Time/date the issue first occurred: They are testing with it so the first reports we received were on 28 of October. 
Is the issue reproducible in the Canary edition of Chrome: Yes 
Is it reproducible in incognito mode? Yes 
Is it reproducible in beta Chrome? Yes 

Send me a screenshot or screen cast reproducing the issue. There is nothing to see. You only see a new tab be opened and it keeps loading(Customer response). 
- Windows Process Explorer logs attached
- Verbose logs Attached

Step-by-step instructions on how to reproduce the issue: Try to add it on any server with Citrix Xenapp 65 and open any office file. 
Are you able to reproduce this issue using a different extension: No this is the only extension with the issue so far. 

Logs: https://drive.google.com/a/google.com/file/d/0B75z-E3P1iqoY0g1WHVYZ0RPSk0/view?usp=sharing (RESTRICTED VIEW)
 

Comment 1 by sa...@chromium.org, Nov 13 2014

Labels: -Cr-Platform-Extensions Cr-Platform-Apps-Default-ChromeOffice-Point Cr-Platform-Apps-Default-ChromeOffice-Sheet Cr-Platform-Apps-Default-ChromeOffice-Word
Status: Untriaged
Cc: saswat@chromium.org pastarmovj@chromium.org
Labels: Enterprise-Triaged Needs-Feedback
Owner: josuej@chromium.org
Adding saswat and pastarmovj to CC in case they have ideas regarding this issue being specific to Citrix environment.

I'll leave this with the apps team for now.

josuej: Can you please clarify which extension you're referring to (exact name and extension ID)? There is none under a name of "Office Editor".
Please see the link

Office Editor https://chrome.google.com/webstore/detail/office-editing-for-docs-s/gbkeegbaiigmenfmjfclcdgdpimamgkj?hl=nl

Also note that the Extension works fine on Windows Server 2008R2 without Citrix XenApp 65 installed on.
It only occurs on W2K8R2 servers with Citrix XenApp 65 installed on.

Labels: -Needs-Feedback
Owner: pastarmovj@chromium.org
Status: Assigned
msmit: Thanks for clarifying.

Assigning to pastarmovj for now to repro and gather diagnostic information.
It seems like the NaCl client has crashed with a illegal op error 
[1808:4188:1107/172718:ERROR:nacl_process_host.cc(311)] NaCl process exited with status -1073741795 (0xc000001d)

I don't know what limitations does Citrix pose on the apps that are run inside XenApp.

@Santosh: Do you know about what restrictions does the XenApp environment has that could be leading to that?
Cc: kurtz@chromium.org
Added kurtz@ for visibility.
Labels: fileOpening
After syncing up with Citrix they suggested that if this is an issue with XenApp the customer should reach to Citrix support and report this issue and they will investigate and offer a fix.

@josuej: Can you please reach out to the customer to contact Citrix support about that. Keeping this bug up to date too will be very useful too.
Thanks guys for investigating. We will create a support case with the support of Citrix.
If they find a solution for this matter I will also post it here.
Cc: -saswat@chromium.org
Owner: saswat@chromium.org
Reassigning to Saswat to close once we fill in the bug with information on the resolution or reassign to an engineer if there is work to be done on Chrome's sign.

Comment 11 by wfh@chromium.org, Jun 30 2015

Mergedinto: 480716
Status: Duplicate
likely same root cause as 480716
We have thousands of users that are affected by this but. Please create a fix. The Google EXT Office Editing for Docs, Sheets, and Slides is broken is our Citrix env for every user. 
Cc: wfh@chromium.org
Owner: blumberg@chromium.org
Status: Assigned (was: Duplicate)
Replacing the owner of the bug with one that is active.

I can reproduce the bug as still present. It seems like NaCl can't load or start its sandbox in Citrix 6.5 even with the --allow-no-sandbox-job flag. The extension can be installed but fails to load even on Chrome 32 bit which otherwise works on Citrix 6.5. Therefore removing the duplicate status and reopening the bug. 
Cc: georgesak@chromium.org
Cc: dslo...@chromium.org
Status: Fixed (was: Assigned)
We believe we found the root cause of this issue. Can you please follow these steps and help us confirm/verify this is the case?

On Citrix XenApp 6.5 Google Chrome has to be added to the exclusion list for hooks injection to prevent issues with the 64 bit executables of the browser as documented in Citrix Article CTX107825[https://support.citrix.com/article/CTX107825].  To accomplish this, please create or update the string value with name ExcludedImageNames with the text chrome.exe,nacl64.exe in HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\CtxHook. This workaround is not needed with Citrix XenApp 7 or newer.

See attached image as an example.
citrix1.png
135 KB View Download
Does that work with 32bit Chrome.exe also?

is that screen shot correct?
It's supposed to be under the AppInit_DLLs key..

For the 32-bit version

Key: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\CtxHook\AppInit_Dlls\<Feature>
Value Name: Flag
Type: REG_DWORD
Value: 0

For the 64-bit version

Keys:
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\CtxHook\AppInit_Dlls\<Feature>
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\CtxHook\AppInit_Dlls\<Feature>
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\CtxHook64\AppInit_Dlls\<Feature>
They are showing a status of "fixed". I hope Google replies to this thread to answer your questions, Neal.
Hi,

the <feature> keys you are refering to are mentioned in the second part of the linked doc. They describe how to turn off specific hook dlls for all programs which is not what we suggest you do. 

Instead we suggest you use the ExcludedImageNames value which is described at the top of the linked document to prevent Citrix from injecting only in the Chrome processes. This is also depicted in the screenshot correctly. It has been taken from our testing environment where this is fixing the issue.


Re c#18: We do read new comments on fixed bugs too ;-)
We arhttps://bugs.chromium.org/p/chromium/issues/detail?id=432595#c15 resolved issues in our test environment but we are looking for external verification for Citrix 6.5 on Win2008r2 64-bit. Please let us know your results.

Thank you!

I'm confirming it works with chrome.exe 64bit.

Is there a fix for chrome.exe 32bit?

We tested chrome.exe 32bit with the registry and it didn't work.

Thanks

Have you put both chrome.exe and nacl64.exe in the list? The second is explicitly needed for the 32 bit version of Chrome.
I tried again on two test citrix servers with 32bit chrome and the registry settings.   The extension fails to convert like the 64bit version of chrome using the same extension.  Attached are my registry settings:

4-17-2017 10-59-03 AM.png
13.0 KB View Download
4-17-2017 10-58-41 AM.png
18.8 KB View Download
The particular extension that worked with the 64bit chome with the registry mod is:
chrome-extension://gbkeegbaiigmenfmjfclcdgdpimamgkj/views/app.html

but fails with 32bit chrome.
Attached is the final result of the extention trying to load (google logo flahses for a bit) and then blank web page
4-17-2017 11-12-33 AM.png
60.7 KB View Download
Hello Google Team. I want to underscore how there needs to be solution for the 32 bit version of Chrome. We have thousands of users affected. 
Can you try also setting the same value under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\CtxHook as the documentation from Citrix suggests. In our environment this doesn't seem to be needed but depending on your setup it might be needed.
Hi bsmith,

have you had a chance to try the suggestion from comment #27?

Best,
Julian
Yes, that registry entry is also in place.

Just to reiterate:  It works with 64bit Chrome.exe
And doesn't work with 32bit Chrome.exe

In your environment are you running 32bit Chrome.exe?  What version?

Thanks


"Can you try also setting the same value under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\CtxHook as the documentation from Citrix suggests. In our environment this doesn't seem to be needed but depending on your setup it might be needed."


Yes I verified both 32 and 64 bit Chrome separately.
The 32 bit version of chrome was installed from the MSI installer
the version as shown in chrome://version is Google Chrome 57.0.2987.133 (Official Build) (32-bit).

I have thing for you to check please - open Chrome directly on the server and run the word extension. Then open task manager and take a screenshot of the command lines of Chrome related processes like in the attached image (sort by the command line column to get them close to each other). Feel free to black out anything unrelated. Then do the same from a remote session.

PS. As long as you are not on Chrome 58 the --allow-no-sandbox-job is still required regardless of the config changes proposed in the comments above.
PPS. I just verified that chrome 58.0.3029.81 works well too.

Interesting you mention the "--allow-no-sandbox-job " option is required.

It's actually aways worked for us in test/dev using this command.

We are trying to get it to work without doing this since it's advised by Google not to use the no-sand box command due to security issues.

So are you saying that with Chrome 58, you don't need this command.
Or are you saying that for both Chrome 57, and 58 you need to do the "--allow-no-sandbox-job " command parameter for Chrome 32bit?

Thanks

Yes for 57 it is needed to run chrome as a published app  both for 32 and 64 but installations, but you should differentiate between the option "--no-sandbox" which is a clear no go for security and "--allow-no-sandbox-job" which although it contains the same words has significantly different implications and effect. It  preserves 99% of the sandbox capabilities. That said from chrome 58 onwards this flag is not required.

Labels: Hotlist-ConOps
Do not mean to hijack the thread but the impacted users in my enterprise are not using Citrix.  We're having this problem with our standalone users.  Is there a fix for regular domain member machines?

Signed: Getting Desperate
Re c #34: It will be easier for us to investigate if you would file your issue as a separate bug. Please use the provided template to give information about the exact configuration you have and what is the exact issue you have. I will follow up there and try to help you get back on track :)

Sign in to add a comment