New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 42157 link

Starred by 3 users

Issue metadata

Status: WontFix
Owner: ----
Closed: Mar 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: ----
Pri: 2
Type: Bug



Sign in to add a comment

<a onclick=""> reveals not functioning

Reported by michael....@gmail.com, Apr 20 2010

Issue description

Chrome Version       : 5.0.375.9 (Official Build 44625) dev
URLs (if applicable) : www.gowalla.com, www.vpnaccounts.com/subscirbe
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4: OK
  Firefox 3.x: OK
IE 7:
IE 8:

Mac OS X 10.6.3

What steps will reproduce the problem?
1. For Gowalla, go to page and click Sign In. Overlay should appear for entering credentials.
2. For VPN Accounts on subscribe page click 'More' on one of the options. Details momentarily 
flash but then disappear
3.

What is the expected result?

Overlay or content is revealed by the onclick

What happens instead?

Overlay/revealed content momentarily flashes but then disappears again

Please provide any additional information below. Attach a screenshot if
possible.

 
n.b. above URL should be www.vpnaccounts.com/subscribe.html
For Gowalla, issue actually only seems apparent from blog page gowalla.com/blog. The clicking results in a 
change of URL to gowalla.com/blog# but no overlay. This is similar behaviour to that seen on the VPN Accounts 
Subscribe page. 
Labels: -Area-Undefined Area-Compat-Web NeedsReduction
Works for me in Chrome 7.0.503.0 (Mac) and 9.0.587.0 (Windows), the same as in Firefox 3.6.2 (Mac) and 4.0 beta (Windows).

Note: at gowalla.com/blog I don't see sign up link.

Successfully reproduced in Chrome 9.0.576.0 dev on Ubuntu and Safari 5.0.2 on Mac
using the URL www.vpnaccounts.com/subscribe.html which was provided in comments
Seems like a :focus issue.
Opening bug in webkit https://bugs.webkit.org/show_bug.cgi?id=52102

Test case:

<!doctype html>
<html>
<head>
<style>
	a span {
		display: none;
	}
	
	a:focus span {
		display: block;
	}
</style>
</head>
<body>
	<a href="#">Click me to reveal - <span>some stuff</span></a>
</body>
</html>
Above was a duplicate of https://bugs.webkit.org/show_bug.cgi?id=18425

Comment 9 by priyaj...@gmail.com, Feb 10 2011

Labels: -Area-Compat-Web -NeedsReduction Area-WebKit WebKit-Core
Status: ExternalDependency
Labels: Mstone-X kgmoved5_4
Project Member

Comment 11 by bugdroid1@chromium.org, Mar 10 2013

Labels: -Area-WebKit -WebKit-Core Cr-Content Cr-Content-Core
Project Member

Comment 12 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink

Comment 13 by tkent@chromium.org, Jul 15 2015

Labels: -Cr-Content-Core

Comment 14 by tkent@chromium.org, Mar 23 2016

Components: -Blink Blink>HTML>A
Labels: -Mstone-X mstone-X
Status: WontFix (was: ExternalDependency)
We fixed this some time ago.

Sign in to add a comment