New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 421206 link

Starred by 2 users

Issue metadata

Status: Duplicate
Merged: issue 389566
Owner: ----
Closed: Oct 2014
Cc:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug



Sign in to add a comment

While fetching an HTML import, new elements have computed style display:none

Reported by m...@janpaulposma.nl, Oct 7 2014

Issue description

UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.124 Safari/537.36

Example URL:
http://jsfiddle.net/q173ugow/2/

Steps to reproduce the problem:
1. Create a "fake" HTML Import that will time out: `<link rel="import" href="//1.2.3.4/nothing-here.html">`
2. While it is loading, trigger some function (e.g. with setTimeout)
3. In this function, create a new element, add it to body, and inspect its style, particularly "display"

What is the expected behavior?
The computed style for the element should have display:block for block elements or display:inline for inline elements, etc.

What went wrong?
For some reason, the new element has display:none. What's worse, it stays hidden, even after timeout.

Did this work before? N/A 

Chrome version: 37.0.2062.124  Channel: stable
OS Version: OS X 10.9.3
Flash Version: Shockwave Flash 15.0 r0

This doesn't happen for <link rel="stylesheet"> or <script src="...">
 
Labels: -Cr-Internals-Network Cr-Blink-CSS
Cc: msrchandra@chromium.org
Labels: Needs-Feedback
@me -- Verified the above provided URL in Mac OS X 10.9.5 on Chrome Stable# 37.0.2062.124 (Official Build 281580) and was not reproducible. I was getting the expected result.
Attaching a screenshot for your reference. 
Please let me know if i have missed anything.
421206.png
126 KB View Download
You'd have to remove the comments around the last line, which I intentionally commented out to prevent a very long first time page load (because it tries to get a file from a non-existing server). Have you done that when trying to reproduce?
Any update on this?

Here's another example URL that shows the incorrect behaviour right away, but keep in mind that it takes a while to load because of the non-existing host: http://jsfiddle.net/q173ugow/3/

Comment 5 by tkent@chromium.org, Oct 15 2014

Cc: morrita@chromium.org
Labels: -Cr-Blink-CSS Cr-Blink-WebComponents
Mergedinto: 389566
Status: Duplicate

Sign in to add a comment