New issue
Advanced search Search tips

Issue 412299 link

Starred by 3 users

Issue metadata

Status: Duplicate
Merged: issue 412414
Owner: ----
Closed: Sep 2014
Components:
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug



Sign in to add a comment

Parts of the UI keep disappearing in a Chrome app

Reported by abhijitk...@gmail.com, Sep 9 2014

Issue description

Chrome Version       : 37.0.2062.94
OS Version: OS X 10.9.4
URLs (if applicable) :
Other browsers tested:
  Chrome Canary - same problem

I'm working on a Chrome app called Postman (https://chrome.google.com/webstore/detail/postman-rest-client-packa/fhbjgbiflinjbdggehcddcbncdddomop). While using Postman on a Macbook with a retina display, a weird problem keeps cropping up.

Sometimes (about 1 in 20 clicks), clicking on a UI element makes half the UI vanish. The 'Elements' tab of dev tools shows the correct structure - all the divs are there, with display: block. They're just not rendered. Resizing the window by a tiny amount forces a redraw, and all elements become visible again. (I'm currently using Chrome v 37.0.2062.94)

There are no errors printed in the console.

I've attached two screenshots.

Steps to reproduce - (inconsistent)
1. Install Postman on a Macbook with a retina display
2. Use the app for a while. After clicking a button, large parts of the UI disappear.

What is the expected result?
>>All UI operations work without making half the page invisible.

What happens instead of that?
>>Occasionally, large parts of the screen disappear.


Please provide any additional information below. Attach a screenshot if
possible.

UserAgentString: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.94 Safari/537.36

 
postman_screenshot.png
118 KB View Download
Screenshot 2014-09-08 09.42.05.png
810 KB View Download
Labels: Cr-Platform-Apps-API
Owner: ccameron@chromium.org
Status: Assigned
Assigning to ccameron@ for triaging, I was able to repro this on m37 as well.
Owner: ----
This sounds like a duplicate of  issue 412414 .
Also check the GPU memory usage in task manager or with the FPS meter.
Mergedinto: 412414
Status: Duplicate
Ya, this looks like duplicate of 412414, I can't reproduce neither 412414 or this bug in my current canary (39.0.2152.0 (Official Build 96d38dadb4ef427e56542c7316b755d47de680e4-refs/heads/master@{#294156}) canary)

@abhijitkane, can you check current canary if this reproduces in version 39?
For 37, merging this issue with 412414

Comment 7 Deleted

Comment 8 by Deleted ...@, Sep 12 2014

I'm a POSTMAN user following on this issue. Got current Mac canary (Sep 12, 10am) and issue still there. Screenshot attached. The issue happens after selecting/making a few requests from left column/pane. Also, closing and reopening the left column seems to fix it.
Chrome-POSTMAN issue.png
367 KB View Download

Comment 9 by Deleted ...@, Sep 19 2014

I'm also having the same issue with Chrome 37.0.2062.120 as of Sep 18, 2014.
I've got the same issue - but just resizing the window makes all the assets reappear (probably due to a repaint?)
This issue is still happening on Chrome 39 as well as Canary inside Postman on Retina displays. We have been trying to figure out what the issue is but still no luck: https://github.com/a85/POSTMan-Chrome-Extension/issues/705. A lot of users have reported this problem. We tried using a node-webkit wrapper and the problem did not occur there.

Comment 12 by Deleted ...@, Jan 24 2015

We went through all elements that had overflow: scroll; and added -webkit-transform: translate3d(0,0,0); to force better hardware acceleration on those elements.

That fixed the problem. Full detail is posted at http://blog.getpostman.com/index.php/2015/01/23/ui-repaint-issue-on-chrome/

To sum it up - the issue seems to be around GPU-composting of scrolling elements (when scrollbar occupied right padding) in very high resolutions.

Sign in to add a comment