New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 407945 link

Starred by 57 users

Issue metadata

Status: Fixed
Owner:
Closed: Aug 2014
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 0
Type: Bug



Sign in to add a comment

Multi-byte characters not displayed in Chrome

Project Member Reported by kotah@chromium.org, Aug 27 2014

Issue description

Version: Chrome 37.0.206294.m
Other browsers tested: IE (OK)

We have multiple reports from Enterprise users that Japanese characters are not displayed (see test1.jpg) since they updated Chrome to M37 this morning. So far the issue has been observed in Gmail, Sites and some non-Google websites (ex. Yahoo). Clearing cache and Cookies / re-installing Chrome / disabling all extensions do not solve issue.

We are still checking if the issue persists across multiple OS versions, and across other multi-byte characters (ex. Chinese, Korean etc)

What steps will reproduce the problem?
1. Update to Chrome 37.0.206294.m
2. Open Gmail or Google Sites

What is the expected result?
Properly display Japanese


 

Comment 1 by kotah@chromium.org, Aug 27 2014

Cc: -a deleted user amineer@chromium.org
Labels: Hotlist-Enterprise Cr-Blink-Fonts

Comment 3 by tkent@chromium.org, Aug 27 2014

Cc: e...@chromium.org
Not just Japanese character. Chinese characters also be affected.

Chrome Version: 37.0.2062.94 unknown-m (64-bit) stable version
Windows version: Windows 7 Professional 64-bit

On nearly all websites, Chinese character are not rendered
Not only Google's websites, feedly with chinese news, Yahoo News, etc
Capture.PNG
41.0 KB View Download

Comment 5 by kotah@chromium.org, Aug 27 2014

Summary: Multi-byte characters not displayed in Chrome (was: Japanese characters not displayed in Chrome )
Changed title as the issue occurs with both Japanese and Chinese

Cc: cpu@chromium.org
I can't repro this on 37.0.2062.94 (beta) OSX, and I also can't repro on 37.0.2062.94 x64 (beta + stable) Win7, with either Japanese or Chinese sites.
Here is another example of the problem.

In Traditional Chinese version of Facebook login page, the characters are not rendered properly.

Even in the source code, the words are not rendered.

But the string in it can be copied and paste to a text editor and shown properly.

Seems the string data isn't lost but just render issue
Capture.PNG
58.1 KB View Download
Labels: Needs-Bisect
Let's see if QA can reproduce / bisect.  kotah@, can you reproduce this on demand as well?  If so, what platforms?

Comment 9 Deleted

Comment 10 by kotah@chromium.org, Aug 27 2014

No I haven't been able to repro yet.

Some users also reported that the issue disappeared after disabling DirectWrite in chrome://flags.

Comment 11 by Deleted ...@, Aug 27 2014

This is Version 37.0.2062.94 m

Non-bolded font in Japanese is not showing up.
Printscreen.png
171 KB View Download

Comment 12 by Deleted ...@, Aug 27 2014

Yes, ko...@chromium.org is correct


But it is ENABLE the DirectWrite Windows in chrome://flags


but all the font now looks different.
Some people reported that using the same link for the stable 64bit Chrome download (https://www.google.com/intl/en/chrome/browser/?platform=win64) to reinstall the 32 bit version will not solve the rendering problem.

The solution they point out is completely uninstall 64bit Chrome, go back to the localized page of Chrome download page (for example: http://www.google.com.hk/intl/zh-TW/chrome/) to install back the original 32 bit version. This will install 32 bit Chrome with no Chinese character render issue.

Comment 14 by jacht...@gmail.com, Aug 27 2014

Chinese (Big 5) also cannot display

Comment 15 by Deleted ...@, Aug 27 2014

Version 37.0.2062.94 unknown-m (64-bit)
Asian languages not shown (from pages I have seen...Traditional Chinese, Simplified Chinese and Japanese. 
Labels: -Pri-1 Pri-0 M-37
Owner: kenjibaheux@chromium.org
Let me try to drive this until we get a repro.
Emil, anything you would like us to get about these users? chrome://gpu/?
Cc: sentaro@chromium.org
Cc: nikeda@chromium.org
Labels: Hotlist-ConOps
ko and pof.jc are correct

- go to chrome://flags/
- find "Disable DirectWrite"
- click the "Enable", so it should be "Enable the disable DirectWrite" lol
- relaunch Chrome
- everything fixed (at least for me)

it seems the problem exist no matter which version (32bit or 64bit) you are using.
and yes, as the "flag" mention, seems only Windows version has this issue.
Rough user report volume so far...
- 200+ Japanese Google Feedback reports today (8/27). 
- 400+ pageviews on Japanese Help Forum threads (typically ~30PV)
- 50+ pageviews on Korean Help Forum threads (typically ~5 PV)
- 10+ phone inquiries at Taiwan hotline
- Additional reports from Enterprise users (@kotah can comment more on this) 

Main Help Forum thread to track user reports are: 
Japanese: https://productforums.google.com/forum/#!category-topic/chrome-ja/4sep6K7vqTk
Korean: https://productforums.google.com/d/msg/chrome-ko/v0LSsvMYsG0/EwcbCjtzXx4J
Looks similar to  crbug.com/377932 

A few more examples from forum: 
User 1
PC: FUJITSU LIFEBOOK A572/E
OS: Windows 7 Pro SP1 32bit
Disabling Directwrite solves the problem

User 2
(Looks like he is reporting from a company with multiple computers with same model) 
PC:FUJITSU ESPRIMO D581/C  
OS:Windows7 Professional x64
But some people with the same PC, same OS don't have the same problem. 
Disabling directwrite solves the problem. 

http://www.yahoo.co.jp/ often displayed poorly, but enlarging the font also solves the problem. 
News link from yahoo.co.jp (like this one: http://news.yahoo.co.jp/pickup/6128741) usually works fine, even without disabling directwire. 
No problem with displaying https://webfont.fontplus.jp/service/fontlist regardless of Directwrite status. 

Forum URL: https://productforums.google.com/forum/#!category-topic/chrome-ja/YuUEEy3A9uU

Unable to reproduce this issue on reported version of chrome#37.0.2062.94 (Official Build 290621) as well as on Latest Canary#39.0.2137.2 (Official Build 7ab4749e7d33) on Win7 64bit, Mac OS X 10.9.4 & Linux Ubuntu 12.04.

PS: Attached the GPU info related to Win7 64bit.

Thank you!
GPU_Win.txt
5.9 KB View Download

Comment 23 by wfh@chromium.org, Aug 27 2014

 Issue 408086  has been merged into this issue.
I'm having this issue with Korean chars in GMail, Facebook and Korean sites.
FB_Chrom37_BlankKorChars.png
262 KB View Download
Chrom37_BlankKorChars2.png
85.4 KB View Download
BTW, I'm running
Chrome 37.0.2062.94 m (32-bit)
Window 7 Professional 64-bit
blissfool, does the suggestion provided in comment #19 (disabling directwrite) fix the issue?
Yep. I've just tried it and it helped. Chars are displaying correctly when DirectWrite is disabled.

Also, while it was enabled, changing the font size (either reduce or enlarge through zoom function) made the chars appear as well. Hahaha. Weird.
Cc: chrome-cron@chromium.org
Labels: OS-Windows
+Chrome TPMs
Cc: scottmg@chromium.org
Cc: bunge...@chromium.org
Per https://code.google.com/p/chromium/issues/detail?id=396624#c18 and the "zooming fixes it" it seems like it could be related to the forcing of bitmap glyphs for legibility.

Comment 32 by e...@chromium.org, Aug 27 2014

If you are seeing this bug could you please report the version of the dwrite.dll file? The easiest way to find it is to open a terminal (Start > Run > "cmd") and then executing the following command:

wmic datafile where name="C:\\Windows\\system32\\DWrite.dll" get version

Comment 33 Deleted

Mine is:
Version
6.1.7600.16972
In the VM where I see it, it's 6.1.7601.17514.

Comment 36 by e...@chromium.org, Aug 27 2014

Having tested on all windows system I could find I get 6.2 or 6.3 on all.

win7: 6.2.9200.16571
win8: 6.3.9600.17111
I am interested to know which font is being requested, and where it is installed on the user's machine.

For someone experiencing this issue, are there any fonts listed in the registry at HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts\ which have an 'interesting' path? The easiest way to determine this is to run

reg query "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts" | findstr "\\"

at a command line and see if there is any output.
Here is my result:

    Gulim (TrueType)    REG_SZ    C:\Program Files (x86)\HNC\HOfficeViewer80\Shared80\Fonts\WinFont_Enu\Gulim.TTF
    GungsuhChe (TrueType)    REG_SZ    C:\Program Files (x86)\HNC\HOfficeViewer80\Shared80\Fonts\WinFont_Enu\GungsuhChe.TTF
    Gungsuh (TrueType)    REG_SZ    C:\Program Files (x86)\HNC\HOfficeViewer80\Shared80\Fonts\WinFont_Enu\Gungsuh.TTF
    DotumChe (TrueType)    REG_SZ    C:\Program Files (x86)\HNC\HOfficeViewer80\Shared80\Fonts\WinFont_Enu\DotumChe.TTF
    GulimChe (TrueType)    REG_SZ    C:\Program Files (x86)\HNC\HOfficeViewer80\Shared80\Fonts\WinFont_Enu\GulimChe.TTF
    BatangChe (TrueType)    REG_SZ    C:\Program Files (x86)\HNC\HOfficeViewer80\Shared80\Fonts\WinFont_Enu\BatangChe.TTF
Cc: -scottmg@chromium.org kenjibaheux@chromium.org
Owner: scottmg@chromium.org
Status: Assigned
The white listing will need to be adjusted.
(https://bugzilla.mozilla.org/show_bug.cgi?id=626299) Here is discussion on Mozilla sometime back about very similar issue. It appears that on some versions (or for unknown reasons) some font sizes are represented using bitmaps rather than glyphs. Which pose a problem in terms of how do we decide which way go for rendering character sided by side with different font sizes, which will look significantly different if there are bitmaps instead of glyphs.


Cc: vivianz@chromium.org ananta@chromium.org scottmg@chromium.org shrikant@chromium.org
 Issue 396624  has been merged into this issue.
It seems there's two separate issues then.

The one we can reproduce is identical to https://bugzilla.mozilla.org/show_bug.cgi?id=626299#c27. In particular, Skia is requesting CLEARTYPE_3x1 but for whatever reason DWrite has only 1x1 bitmaps.

The second (whitelisting outside of system fonts), Shrikant we do that now, is that right? Did that make it to Stable or only in Dev?
(To be more explicit, on the VM where I can repro:

C:\Users\Scott>reg query "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Font
s" | findstr "\\"
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts

C:\Users\Scott>
I tested with Firefox and had no problems, only have this problem since this morning.

Issue with: Korean and certain Japanese characters being invisible (some Japanese characters can be seen).
Not an issue: Thai and Chinese

This issue isn't specific to a certain website but to EVERY website.

Windows 7
Google Chrome Version 37.0.2062.94 m
Direct Write version is, I think, 6.1.7600.16972
We believe we have a way to work around this issue. https://codereview.chromium.org/515533005/ . This is only an "M37 fix" not a full fix.

In the short term if you're experiencing this issue, you can navigate to chrome://flags/#disable-direct-write then click "Enable" and then click "Relaunch Now" at the bottom. (Try to remember to turn it back off at some point though!)

Comment 46 by Deleted ...@, Aug 27 2014

yahoo.co.jp
无标题.jpg
236 KB View Download

Comment 47 by hcm@chromium.org, Aug 27 2014

Cc: hcm@chromium.org

Comment 48 by hcm@chromium.org, Aug 27 2014

Cc: reed@google.com

Comment 49 by Deleted ...@, Aug 27 2014

I also have the same issue. Win. 7 chrome on this patch will not display Japanese hiragana and katakana characters. The temporary fix from scottmg worked.
Cc: -bunge...@chromium.org
Labels: -Needs-Bisect Merge-Requested
Owner: bunge...@chromium.org

Comment 52 by amin...@google.com, Aug 27 2014

Labels: merge-questions-applied

Please note that all merge requests must have been on or rolled into trunk
for at least 24 hours to be considered for merging (to ensure full bot
coverage and give an opportunity for any necessary reverts to occur).

To help facilitate this request, if you could please answer the following:
--------------------------------------------------------------------------
1) Has this change been on trunk for at least 24 hours?

2) Has this change shipped to at least one canary release (where applicable)?

3) Has anyone verified that these changes resolve the issue and cause no new
   crashes (via chromecrash/) or regressions?

4) Why is this necessary for this milestone?

Thanks!

(this message is auto-generated each time the merge-request label is
applied; if you have previously answered these questions kindly disregard)

Comment 53 by Deleted ...@, Aug 28 2014

Thanks for this link!

I just found out yesterday and updated to 37.x but it seems the asian language rendering is not working, but did the following to address the issue : 

1. goto chrome://flags 
2. ENABLE the flag for "disable directwrite" 
3. relaunch CHROME

You should be OK, but i hope google would update this, this iteration is really promising and its quite have a fast rendering ability.

I have a attached a sample screenshot of the chrome flags

ChromeIssue.png
60.5 KB View Download
A customer reports that they were able to resolve the issue by applying the Windows update KB2670838 (which seems to be related to DirectWrite). It may be worth trying if KB2670838 is not yet applied to your Windows machine.

Comment 55 by Deleted ...@, Aug 28 2014

The workaround provided in #53 works fine for me. 

Besides Chinese characters not showing in google search input, there some other pages in English cannot display on my side. The whole page are white. however if copy&paste the content to text editor, the content does exist. 
Hello all,

We now have a tentative fix in the latest canary for Mac and Win64 for this - 39.0.2138.3.  If you are experiencing this issue and can try installing it from http://www.google.com/intl/en/chrome/browser/canary.html and testing, it would be greatly appreciated.

Thanks!

Comment 57 by piuc...@gmail.com, Aug 28 2014

Sweet, the new canary seems to work.
On the left, Chrome 37, on the right the latest canary
canary japanese.png
156 KB View Download
have the same problem, cant view korean and chinese wording properply

Version 37.0.2062.94 unknown-m (64-bit)
Windows 7 Home Premium 64bit
Cc: ashej...@chromium.org
 Issue 408479  has been merged into this issue.
 Issue 408433  has been merged into this issue.
 Issue 407988  has been merged into this issue.
Cc: rponnada@chromium.org eseidel@chromium.org
 Issue 394763  has been merged into this issue.
 Issue 407987  has been merged into this issue.
FWIW I was reporting this since https://code.google.com/p/chromium/issues/detail?id=25541#c153 and https://code.google.com/p/chromium/issues/detail?id=25541#c158 I'm glad to be fixed though finally
Cc: pbomm...@chromium.org
Unable to reproduce the above issue on Windows 7(32 & 64 Bit) and 8, with chrome version "37.0.2062.102", Chinese and Japanese web pages are rendered correctly. Tried below websites.
1. yahoo.co.jp
2. Sina.com.cn
3. amazon.co.jp
4. Baidu.com
5. People.com.cn
6. youku.com

Comment 67 by Deleted ...@, Aug 28 2014

I'm using Windows 7 64bit and chrome v37 32bit and 64bit
having the browser language Traditional Chinese, it seems that some multibyte character under Directwrite enabled won't display correctly in broswer content page.
But suddenly I remember that at some time Windows 7 released a system update called kb2670838, at that time installed that update which broke firefox Directwrite acceleration. So I uninstalled that update.
But at this time, after installed that update, my firefox and chrome is happily running with Directwrite.
If new 37 will fix this issue?
I think the best workaround for now is to disable DirectWrite for now and re-enable it when the fix is released:
1. goto chrome://flags 
2. ENABLE the flag for "disable directwrite" 
3. relaunch CHROME

You can install Windows update mentioned above - KB2670838 - but be sure to read the "Compatibility issues on certain computers that have hybrid video cards" section so it wouldn't cause issues with your system. There seems to be quite a number people having issues with that update due to hardware incompatibility:
http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_update/kb-2670838-the-evil-update/08bfdb2b-6896-4c34-89c2-16896a25dc3d

Comment 70 by Deleted ...@, Aug 28 2014

Running V37.0.2062.94 m here, on Win7 64bit and the Disable DirectWrite fix didn't show any change, still experiencing errors on Japanese hiragana/katakana display What else could I try? 
hee.JPG
52.9 KB View Download
ktaru101: Installing http://support.microsoft.com/kb/2670838 appears to fix the issue for some, you could try that. We'll also be pushing a change that will hopefully fix it over the coming days.
@ktaru101 - Did you restart chrome after disabling it?

Comment 73 by Deleted ...@, Aug 28 2014

Thank you scottmg@chromium.org
It solves the issue for me.

Comment 74 by Deleted ...@, Aug 29 2014

Google Chrome	37.0.2062.94 (Official Build 290621) unknown-m
OS	Windows 
Blink	537.36 (@180557)
JavaScript	V8 3.27.34.14
Flash	14.0.0.177
User Agent	Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.94 Safari/537.36
Command Line	"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --profile-directory="Profile 1" --flag-switches-begin --disable-direct-write --flag-switches-end
Executable Path	C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
Profile Path	C:\Users\Alex\AppData\Local\Google\Chrome\User Data\Profile 1
Variations	24dca50e-c4e4c5f
ca65a9fe-91ac3782
5a3c10b5-e1cc0f14
5e29d81-f23d1dea
3ac60855-486e2a9c
246fb659-7158671e
f296190c-b52e3392
4442aae2-6e3b1976
ed1d377-e1cc0f14
75f0f0a0-d7f6b13c
e2b18481-6754d7b7
e7e71889-4ad60575

This is my Chrome version. As you can see from the screenshot, left side, a lot of button missed their names...
2014-08-29_103509.jpg
213 KB View Download
Just updated to "37.0.2062.102 unknown-m (64-bit)" and Korean chars appears to be displayed correct on sites I've previously tested.
Status: Fixed
#75 Thank you for confirming. I've also noticed it appears to be OK in .102.
Is it really fixed?

My Chrome is automatically updated to "Version 38.0.2125.24 unknown-m (64-bit)"
so I try to disable the "disable directwrite" and revisit those websites again, characters gone just like before.

note, I haven't installed the "KB2670838" update.
Cc: matthewyuan@chromium.org
Labels: M-38
beta may still show the issue as that is updated weekly.  however, it's also possible the fix hasn't been merged in there yet.  adding m-38 milestone and cc'ing m38 tpm to ensure this fix has made it.

Comment 79 by yap7...@gmail.com, Aug 31 2014

change this maybe work.

Comment 80 by Deleted ...@, Sep 2 2014

我的更新還是有問題~
版面變大且字是模糊

2014-09-02_104643.jpg
298 KB View Download
Labels: -Merge-Requested
Already merged into 38 branch, no merge needed.

Comment 82 by Deleted ...@, Sep 9 2014

螢幕快照 2014-09-09 下午5.39.29.png
512 KB View Download

Comment 83 by Deleted ...@, Sep 9 2014

0167697771

Comment 84 by Deleted ...@, Sep 16 2014

it's still cannot resolve the problem, and Chinese language can't display.
why this bug is fixed if it is not?

window.navigator.userAgent = "Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.8 Safari/537.36"
chrome_fucking_buggy.png
331 KB View Download
You have a very old version of the product, msangel - can you please ensure Chrome is updated by going to "About Chrome" then trying again?

Comment 88 by hac...@gmail.com, Apr 2 2015

I don't think this bug is solved, or there is a new one when it comes to asian signs.

Visit the following site and look at the video name and description:
https://www.youtube.com/watch?v=m_Zj2tG9DuA

The signs display correctly in the tab title, but not on the page itself. I am on Windows 8.1. Works well in iexplore and Firefox.

Comment 89 by Deleted ...@, Jun 30 2015

This bug is not fixed as of build 43.0.2357.130 m.
DWrite.dll info attached.  
Windows 10
Chrome: Version 44.0.2403.155 m 

Found problem while typing an interobang (https://en.wikipedia.org/wiki/Interrobang#Entering_and_display)
Only 3 displayed an interobang on that table.
Capture.PNG
16.2 KB View Download
Having this problem with 43.0.2357.130 on 64-bit Linux, and can't find any DirectWrite option in flags

Comment 92 by e...@chromium.org, Dec 28 2015

Re 91, triffid.hunter:
DirectWrite only applies on Windows. If you are having this problem in Linux the most likely culprit is either that you don't have a font with the required glyphs or that your version of opentype or fontconfig is too old.

Comment 93 by Deleted ...@, Dec 28 2015

I am having this issue with Version 48.0.2564.10 dev (64-bit) and Chinese characters, but it's recent (since we changed to Bootstrap-based design templates). 

Chinese characters are not rendering for me here:
http://kingcounty.gov/depts/elections/chinese.aspx

It is NOT happening here:
https://www.google.co.jp/
http://www.amazon.co.jp/
http://www.bbc.com/zhongwen/simp
https://www.google.com.hk/
http://www.amazon.cn/



chinese-not-rendering-html-meta.png
124 KB View Download
chinese-not-rendering.png
1.4 MB View Download
@eae Chinese glyphs render perfectly in every other program on my system, including the system titlebar on chromium if I enable it.

Comment 95 by e...@chromium.org, Dec 28 2015

triffid.hunter: Could you please file a new bug and include a screenshot and, if possible, the names of the fonts used to render the page in question?

Sign in to add a comment