New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 2 users

Issue metadata

Status: Duplicate
Merged: issue 338500
Owner: ----
Closed: Jun 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Feature

Blocked on:
issue 338500



Sign in to add a comment

[MediaStream] Deprecating label & stop()

Reported by v.kes...@samsung.com, Aug 25 2014

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0

Steps to reproduce the problem:
Deprecate label attribute and stop() in MediaStream.
As per the spec http://dev.w3.org/2011/webrtc/editor/getusermedia.html#mediastream
both the above attributes have been deprecated for sometime now.

What is the expected behavior?
Deprecate label and stop()
Use UseCounter to check the current usage statistics and let everyone know that label and stop will be deprecated and removed in the near future and the same should not be used.

What went wrong?
Nothing. Need to deprecate

Did this work before? N/A 

Chrome version: 36.0.1985.143  Channel: n/a
OS Version: Ubuntu 12.04
Flash Version: Shockwave Flash 14.0 r0
 
Cc: grunell@chromium.org
Labels: -Type-Bug -OS-Linux Type-Feature OS-All Cr-Blink-WebRTC
Thanks for filing a bug for this. SGTM to add UseCounters for the deprecated attributes and labels.
Project Member

Comment 2 by bugdroid1@chromium.org, Sep 22 2014

The following revision refers to this bug:
  http://src.chromium.org/viewvc/blink?view=rev&rev=182408

------------------------------------------------------------------
r182408 | v.keshav@samsung.com | 2014-09-22T11:19:55.565113Z

Changed paths:
   M http://src.chromium.org/viewvc/blink/trunk/Source/core/frame/UseCounter.h?r1=182408&r2=182407&pathrev=182408
   M http://src.chromium.org/viewvc/blink/trunk/Source/modules/mediastream/MediaStream.idl?r1=182408&r2=182407&pathrev=182408

Measure current usage statistics for MediaStream label and stop() before going for deprecation.
As per spec, both label and stop have been deprecated.
Spec = http://dev.w3.org/2011/webrtc/editor/getusermedia.html#mediastream

BUG= 407039 

Review URL: https://codereview.chromium.org/535733005
-----------------------------------------------------------------
Cc: tnakamura@chromium.org jansson@chromium.org
Labels: M-39
Status: Started
v.keshav@ - can this be considered fixed with Blink change 182408?
Labels: -M-39
No, the change in comment #2 only adds measurement (UMA) to the attribute and function. We need to gather stats before deprecating it.

Comment 5 by vrk@chromium.org, Sep 24 2014

Labels: -Cr-Blink-WebRTC Cr-Blink-GetUserMedia
Summary: [MediaStream] Deprecating label & stop() (was: Deprecating label & stop())
There's an existing bug about removing stop():  http://crbug.com/338500 
Blockedon: chromium:338500

Comment 9 by phil...@opera.com, Jun 24 2015

Mergedinto: 338500
Status: Duplicate
I'm marking this as a dupe of  issue 338500 , which has morphed into the tracking bug for deprecation and removal of these bits.

Sign in to add a comment