New issue
Advanced search Search tips

Issue 405366 link

Starred by 35 users

Issue metadata

Status: Untriaged
Owner: ----
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Bug



Sign in to add a comment

Media keys are not registered by Chrome

Reported by jamesb.a...@gmail.com, Aug 20 2014

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/37.0.2062.76 Safari/537.36

Steps to reproduce the problem:
1. Install the Play Music extension (https://chrome.google.com/webstore/detail/google-play-music/fahmaaghhglfmonjliepjlchgpgfmobi)
2. Leave the keyboard shortcut bindings as default (Media Play/Pause etc.) in the settings
3. Open the extension and try to play/pause or skip a track

What is the expected behavior?
The music player should respond to the keyboard.

What went wrong?
The media keys specifically are not registered by Chrome, but other shortcuts such as 'Alt-Right Arrow' are registered correctly.

Did this work before? No 

Chrome version: 37.0.2062.76  Channel: beta
OS Version: 6.3
Flash Version: Shockwave Flash 14.0 r0

The keyboard I am using is a Microsoft Sidewinder X4. Also reported as an issue using a Sidewinder X6 or Logitech K350. Thread on the issue here https://productforums.google.com/forum/?utm_medium=email&utm_source=footer#!msg/chrome/8xc-vDS6hBE/5cUrLY6pdTkJ
 

Comment 1 by ben...@gmail.com, Sep 23 2014

I have the exact same issue with a Corsair Vengeance K95 keyboard.

Tried with Chrome version: 37.0.2062.120 m  Channel: stable
I have the same issue with the Microsoft Sidewinder X4.

Chrome version: Version 37.0.2062.124 m
Same issue with MS Ergonomic Keyboard 4000 (with Microsoft Mouse & Keyboard installed, Win 8.1). I can't even bind the key - if I go into keyboard shortcut settings, pressing my play/pause button acts as though I didn't press anything at all. Works fine in Spotify, etc. 

Comment 4 by Deleted ...@, Nov 12 2014

Same for me, also Sidewinder x4! Chrome Shortcuts does not recognize the media keys. Issue occurs since I installed Windows 8.1 - it worked with Windows 7.

Comment 5 by rmarq...@gmail.com, Nov 12 2014

Identical to comment #3: Same issue with MS Ergonomic Keyboard 4000 (with Microsoft Mouse & Keyboard installed, Win 8.1). I can't even bind the key - if I go into keyboard shortcut settings, pressing my play/pause button acts as though I didn't press anything at all.

Comment 6 by Deleted ...@, Dec 2 2014

I am also experiencing this issue with a Microsoft Wireless Keyboard 2000 in Windows 8.1. The keys work fine in Chrome in Ubuntu 14.10 on the same hardware, so I assume this to be a Windows-specific bug.

Comment 7 by Deleted ...@, Dec 26 2014

Same issue with a Microsoft Wireless 2000 in Windows 7 64-bit.
I believe the problem here is actually the keyboard and mouse manager apps by microsoft and logitech.  Most people have this problem resolved when they uninstall those apps, but for people that actually need the functionality, chrome should probably still work with them installed.

Comment 9 by Deleted ...@, Feb 16 2015

Same issue on Lenovo X1 Carbon (1st generation). Media keys (built in keyboard) do not work.
System: Gnome Ubuntu 14.10
Please fix that ASAP, issue is pretty old now and I would really like to control my play music with media keys.

Comment 10 by jlhob...@gmail.com, Feb 25 2015

same problem here on sidewinder x4

Comment 11 by Deleted ...@, Mar 5 2015

Same Problem here with Microsoft Sidewinder X4 and Chrome Version 40.0.2214.115 m
i was able to get the keys to work by using the workaround suggested above: uninstall the Microsoft mouse and keyboard software/drivers and it should work. 
I can confirm that uninstalling Microsoft Keyboard and Mouse Center fixed the issue on my Windows 8.1 system running Chrome v40

Comment 14 Deleted

Comment 15 by Deleted ...@, Mar 23 2015

Another confirmation.
Had MouseKeyboardCenter_64bit_ENG_2.3.188 installed, media keys not working.
Uninstalled Mouse&Keyboard Center, media keys started working.

Comment 16 by Deleted ...@, Mar 31 2015

Yet another confirmation. Uninstalling Microsoft Keyboard and Mouse Center fixed the issue for me too.

Comment 17 by Deleted ...@, Apr 15 2015

Another confirmation with Microsoft Sidewinder X4, and not one but TWO WORKAROUNDs:
(The following worked for me when nothing else did, can't promise they'll work for you but maybe this can help Google solve this):

1. Run As Admin:
1.1 - Close all Chrome and player instances
1.2 - Close all background processes as well (using Task Manager)
1.3 - CTRL+SHIFT+Click the Chrome icon, and confirm running as Administrator.
1.4 - Media keys suddenly work

2. Configure other shortcuts
2.1 - Goto chrome's extension settings and click on "Keyboard Shortcuts" in the bottom.
2.2 - Change the Media Keys next to "Google Play Music" to actual keyboard shortcuts like CTRL+P for play/pause, CTRL+N for next and CTRL+B for previous (or any other shortcuts, whatever you like)
2.3 - Using your Keyboard's software, record those keystrokes as macros and bind them to the Media keys.

Neither of those solutions is pretty or ideal, but at least we have a lead.

Comment 18 by Deleted ...@, Jun 6 2015

#17 eladav...@gmail.com

THANK YOU!!! It worked for me!

I have Logitech g510 gaming keyboard.
Up, problem is still there ( Logitech MK700 ).

Is it possible to fix this without uninstalling Logitech Keyboard Management Software ( because I have also a Mouse from them configured for Gaming purpouses ) and without even running Chrome as Administrator because of security purpouses?

THank you in advance.
We are seeing a large number of complaints about this issue on Google Play Music. Many users who are experiencing the problem have the Play Music chrome app installed in mulitple profiles, but not all of them. Internal bug for Music is b/19844751.
Labels: OS-Linux OS-Mac
Status: Untriaged
Labels: -OS-Windows -OS-Linux -OS-Mac OS-All

Comment 23 by Deleted ...@, Jun 27 2015

uninstalling microsoft mouse and keyboard center solved the issue for me...
running chrome as administrator fixed it for me

Comment 25 Deleted

Hot damn I finally found a fix for microsoft keyboards that doesn't require disabling iType, running in admin-mode, or uninstalling software!!!!  Add some macros, then within intellitype, set the macros on each mediakey and presto!  See the link below (which apparently also includes fixes for logitech keyboards as well)

http://steinerd.com/developments/hacks/media-keys/
Thank you Kevin, that works and it's the final fix I was searching for until Chrome or Logitech does not fix this problem officially! :)

Comment 28 by Deleted ...@, Aug 25 2015

Thanks Kevin! Works great.
Media keys have been working well forever on any Logitech Gaming Sofware-compatible device I've had (G510 currently), but have NOT worked on devices that require the Logitech SetPoint (K400R) or Logitech Options (K830) software is installed.

Unfortunately, both these software products do not allow rebinding of the media keys in the interface - they're explicitly set and seem to work fine in all other OS applications EXCEPT Chrome (VLC, Media Player).

Comment 30 by mkell...@gmail.com, Sep 16 2015

I also have a MS Ergonomic Keyboard 4000, and also found that uninstalling the MS software allowed the play/pause key to work. Unfortunately, I needed to use that software to remap other keys (the "browser back" and "browser forward" is my current preference) to the "Media Previous Track" and "Media Next Track" functions -- there aren't dedicated keys for skipping tracks on this keyboard.

If any sort of log dumps, running any test programs, etc would help narrow down why this feature doesn't work with the Microsoft software installed, I'd be glad to provide extra information.

Comment 31 by Deleted ...@, Sep 17 2015

I had this problem om Windows 10 and a Corsair k75 keyboard. Solved this by Restarting the HID Human Interface Service and setting it to Automatic start.

Followed the guide here under Method 3.
https://support.microsoft.com/en-us/kb/932875

Comment 32 by Deleted ...@, Sep 19 2015

Kevin thank you! That completely works! You need to make sure the Google extension is on global and that it is set for the appropriate media keys AND use the macros provided in the link, and it works flawlessly after years of just giving up on that function of my keyboard.

Relevant link: 
http://steinerd.com/developments/hacks/media-keys/

Comment 33 Deleted

Comment 34 by r...@hayle.org, Dec 22 2015

Same issue with Chromium 47.0.2526.73, Ubuntu 15.10 (64-bit).

Disabling the system keyboard shortcuts seems to "free up" the key, allowing Chromium to bind to it, but this disables all other apps from using the keys.  Chromium isn't properly registering for these keys the same way other apps do, since normally multiple apps (Rhythmbox, Totem, etc.) can bind to these keys simultaneously.

Comment 35 by ilake@google.com, Jan 20 2016

For those with Logitech SetPoint problems on Windows, these instructions to register Google Play Music into their hardcoded list of supported apps worked perfectly for me: https://gist.github.com/julianxhokaxhiu/f5ea4bb922e3ab1d7fec
I also have this issue. Windows 10 64 Bit, using a Corsair K70 RGB. It worked when I was on Windows 8.1, then I upgraded and now it doesn't work.

The media keys work if I set the scopes to "In Chrome" - but they will not work when it is set to "Global". If I register keyboard shortcuts to random keys like Ctrl+R, etc, they work in Global.
Same problem with Microsoft Comfort Curve Keyboard 2000 and Microsoft Ergonomic Keyboard 4000.

Same solutions (run as admin or uninstalling drivers).

BUT, I am not using Play Music extension, I have this issue using "StreamKeys Extension" (https://chrome.google.com/webstore/detail/streamkeys/ekpipjofdicppbepocohdlgenahaneen).
For me installing the latest Microsoft Mouse and Keyboard Center(2.8.106.0) fixed the problem. At least for now.
Installing the latest Microsoft Mouse and Keyboard Center (2.8.106.0) also fixed for me. 

I don't use a microsoft keyboard or mouse; both are logitech currently. When I open Microsoft Mouse and Keyboard Center it says "No supported device detected", but for some reason just having the new version has made my (logitech) keyboard media keys work in Chrome 
Installing the latest Microsoft Mouse and Keyboard Center (2.8) also fixed for me. 

Comment 41 Deleted

Same issue: media keys work in other Windows 10 apps, but not Chrome. Tried multiple keyboard brands. Can "fix" the issue by running Chrome as administrator.

VLC media keys work flawlessly without admin. They depend on Qt for multimedia keys (I just grepped VLC source). See:

vlc/modules/gui/qt/util/customwidgets.cpp
Qt::Key_MediaPlay - http://doc.qt.io/qt-4.8/qt.html
"Key events for multimedia keys are ignored by default." - http://doc.qt.io/qt-4.8/qkeyevent.html

Good luck! Seems like this should be a high priority for Play Music team.

Comment 43 by bour...@gmail.com, Aug 25 2017

+1 on recent versions of Microsoft Mouse & Keyboard Center working with Steamkeys flawlessly. (This is using 3.0.337.0 64-bit)

Comment 44 Deleted

Components: Platform>Extensions Blink>Media
Components: -Blink>Media
Dropping Blink>Media as it is an Extensions issue.
Labels: Needs-Feedback
Is this still an issue? I tried to repro it on a macbook, however play/pause seems to work. Tested on m63.
This is still an issue. I recently switched devices, and on the new one the Media buttons don't work via StreamKeys.

I highly suspect this is Windows 10 specific, as I never had such issues under Linux (and haven't seen anyone complaining about this running on MacOS).
As a final repro-step I tried if the media keys work if I change it to 'In Chrome' - where they finally worked. Now I set it back to global, and continue to work. Makes me happy for now, hopefully anyone of you as well.
If you're ok with this workaround, should this issue be closed or are others still reporting problems

Sign in to add a comment