New issue
Advanced search Search tips
Starred by 1 user

Issue metadata

Status: Duplicate
Merged: issue 348436
Owner: ----
Closed: Sep 2014
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Compat



Sign in to add a comment

SVG doesn't respond to CSS media queries unless specified in pixels

Reported by sara.sou...@gmail.com, Aug 17 2014

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.143 Safari/537.36

Example URL:
http://codepen.io/SaraSoueidan/pen/0a0d22dcc6c83f8e80ddbc841792bf17

Steps to reproduce the problem:
1. Create an SVG and specify media query conditions using pixels and some using em
2. Reference the SVG somewhere using <img>
3. Resize the screen to see how SVG responds to media queries

What is the expected behavior?
The SVG should get the style rules specified in the media query rule set even if the screen size inside the media condition is specified using em.

What went wrong?
Only styles specified inside a media query condition using pixels are applied.

Does it occur on multiple sites: N/A

Is it a problem with a plugin? No 

Did this work before? N/A 

Does this work in other browsers? Yes 

Chrome version: 36.0.1985.143  Channel: stable
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
Flash Version: Shockwave Flash 14.0 r0

This is a pen referencing the SVG: http://codepen.io/SaraSoueidan/pen/0a0d22dcc6c83f8e80ddbc841792bf17
Resize the screen to a small size. The tree color should change from light green, to dark green, then orange, then pink.

This is the SVG itself with the media queries specified inside it: http://codepen.io/SaraSoueidan/pen/379828d454325e9e45d4410cc873e563?editors=100
I've set the first media query in pixels so u can see the SVG respond to it, and the rest using em. In Firefox, all styles are applied from all the media conditions. In Chrome, only the first query using pixels is applied.
 
Labels: Cr-Blink-SVG
Project Member

Comment 2 by bugdroid1@chromium.org, Aug 22 2014

------------------------------------------------------------------
r291547 | dmazzoni@chromium.org | 2014-08-22T23:11:14.976492Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/chromeos/accessibility/spoken_feedback_browsertest.cc?r1=291547&r2=291546&pathrev=291547
   M http://src.chromium.org/viewvc/chrome/trunk/src/ui/aura/test/ui_controls_factory_aurax11.cc?r1=291547&r2=291546&pathrev=291547

Add test for ChromeVox keyboard commands.

This is just a couple of quick sanity checks to prevent future regressions
like the one in the linked bug. It tests both a Search+Shift shortcut and
the corresponding Prefix Key shortcut.

Adds support for sending the meta modifier key in
aura/x11 tests.

BUG= 404470 

Review URL: https://codereview.chromium.org/490443002
-----------------------------------------------------------------
Project Member

Comment 3 by bugdroid1@chromium.org, Aug 22 2014

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/cf2b255e1de2a23d28aa6bc3ef9b4e58d869e8e0

commit cf2b255e1de2a23d28aa6bc3ef9b4e58d869e8e0
Author: dmazzoni@chromium.org <dmazzoni@chromium.org@0039d316-1c4b-4281-b951-d872f2087c98>
Date: Fri Aug 22 23:11:14 2014

Add test for ChromeVox keyboard commands.

This is just a couple of quick sanity checks to prevent future regressions
like the one in the linked bug. It tests both a Search+Shift shortcut and
the corresponding Prefix Key shortcut.

Adds support for sending the meta modifier key in
aura/x11 tests.

BUG= 404470 

Review URL: https://codereview.chromium.org/490443002

Cr-Commit-Position: refs/heads/master@{#291547}
git-svn-id: svn://svn.chromium.org/chrome/trunk/src@291547 0039d316-1c4b-4281-b951-d872f2087c98

[modify] https://chromium.googlesource.com/chromium/src.git/+/cf2b255e1de2a23d28aa6bc3ef9b4e58d869e8e0/chrome/browser/chromeos/accessibility/spoken_feedback_browsertest.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/cf2b255e1de2a23d28aa6bc3ef9b4e58d869e8e0/ui/aura/test/ui_controls_factory_aurax11.cc

Project Member

Comment 4 by bugdroid1@chromium.org, Aug 23 2014

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/744746cc51ef81c8f8d727fafa46b14d1c03fe44

commit 744746cc51ef81c8f8d727fafa46b14d1c03fe44
Author: agable <agable@chromium.org>
Date: Sat Aug 23 20:51:12 2014

Revert of Add test for ChromeVox keyboard commands. (patchset #6 of https://codereview.chromium.org/490443002/)

Reason for revert:
Broke interactive_ui_tests on chromium.chromiumos waterfall: http://build.chromium.org/p/chromium.chromiumos/builders/Linux%20ChromiumOS%20Ozone%20Tests%20%282%29/builds/1291

Original issue's description:
> Add test for ChromeVox keyboard commands.
>
> This is just a couple of quick sanity checks to prevent future regressions
> like the one in the linked bug. It tests both a Search+Shift shortcut and
> the corresponding Prefix Key shortcut.
>
> Adds support for sending the meta modifier key in
> aura/x11 tests.
>
> BUG= 404470 
>
> Committed: https://src.chromium.org/viewvc/chrome?view=rev&revision=291547

TBR=dtseng@chromium.org,sky@chromium.org,dmazzoni@chromium.org
NOTREECHECKS=true
NOTRY=true
BUG= 404470 

Review URL: https://codereview.chromium.org/500833002

Cr-Commit-Position: refs/heads/master@{#291576}

[modify] https://chromium.googlesource.com/chromium/src.git/+/744746cc51ef81c8f8d727fafa46b14d1c03fe44/chrome/browser/chromeos/accessibility/spoken_feedback_browsertest.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/744746cc51ef81c8f8d727fafa46b14d1c03fe44/ui/aura/test/ui_controls_factory_aurax11.cc

Project Member

Comment 5 by bugdroid1@chromium.org, Sep 4 2014

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/3299e1cf26232b831441987ae90d442b21ab6def

commit 3299e1cf26232b831441987ae90d442b21ab6def
Author: dmazzoni <dmazzoni@chromium.org>
Date: Thu Sep 04 00:22:19 2014

Add test for ChromeVox keyboard commands.

This is just a couple of quick sanity checks to prevent future regressions
like the one in the linked bug. It tests both a Search+Shift shortcut and
the corresponding Prefix Key shortcut.

Adds support for sending the meta modifier key in
aura/x11 tests.

BUG= 404470 

Committed: https://src.chromium.org/viewvc/chrome?view=rev&revision=291547

Review URL: https://codereview.chromium.org/490443002

Cr-Commit-Position: refs/heads/master@{#293234}

[modify] https://chromium.googlesource.com/chromium/src.git/+/3299e1cf26232b831441987ae90d442b21ab6def/chrome/browser/chromeos/accessibility/spoken_feedback_browsertest.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/3299e1cf26232b831441987ae90d442b21ab6def/ui/aura/test/ui_controls_factory_aurax11.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/3299e1cf26232b831441987ae90d442b21ab6def/ui/aura/test/ui_controls_factory_ozone.cc

Project Member

Comment 6 by bugdroid1@chromium.org, Sep 4 2014

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/14b630c415923f86f1cdf44f600aa4539a7d4737

commit 14b630c415923f86f1cdf44f600aa4539a7d4737
Author: vadimsh <vadimsh@chromium.org>
Date: Thu Sep 04 02:03:09 2014

Revert of Add test for ChromeVox keyboard commands. (patchset #7 id:120001 of https://codereview.chromium.org/490443002/)

Reason for revert:
Broke interactive_ui_tests on Linux ChromiumOS Ozone: http://build.chromium.org/p/chromium.chromiumos/builders/Linux%20ChromiumOS%20Ozone%20Tests%20%282%29/builds/1626/steps/interactive_ui_tests

Failing tests:
ChromeVoxNavigateAndSelect_0
ChromeVoxPrefixKey_0
ChromeVoxPrefixKey_1
ChromeVoxShiftSearch_0
ChromeVoxShiftSearch_1

Original issue's description:
> Add test for ChromeVox keyboard commands.
>
> This is just a couple of quick sanity checks to prevent future regressions
> like the one in the linked bug. It tests both a Search+Shift shortcut and
> the corresponding Prefix Key shortcut.
>
> Adds support for sending the meta modifier key in
> aura/x11 tests.
>
> BUG= 404470 
>
> Committed: https://src.chromium.org/viewvc/chrome?view=rev&revision=291547
>
> Committed: https://chromium.googlesource.com/chromium/src/+/8cab2737f1cb6e6011b0946f6bef5027868602c0

TBR=dtseng@chromium.org,sky@chromium.org,dmazzoni@chromium.org
NOTREECHECKS=true
NOTRY=true
BUG= 404470 

Review URL: https://codereview.chromium.org/535283004

Cr-Commit-Position: refs/heads/master@{#293251}

[modify] https://chromium.googlesource.com/chromium/src.git/+/14b630c415923f86f1cdf44f600aa4539a7d4737/chrome/browser/chromeos/accessibility/spoken_feedback_browsertest.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/14b630c415923f86f1cdf44f600aa4539a7d4737/ui/aura/test/ui_controls_factory_aurax11.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/14b630c415923f86f1cdf44f600aa4539a7d4737/ui/aura/test/ui_controls_factory_ozone.cc

Project Member

Comment 7 by bugdroid1@chromium.org, Sep 8 2014

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/91703961c10dfa0f452999ed7cb87945ea817362

commit 91703961c10dfa0f452999ed7cb87945ea817362
Author: dmazzoni <dmazzoni@chromium.org>
Date: Mon Sep 08 07:22:39 2014

Add test for ChromeVox keyboard commands.

This is just a couple of quick sanity checks to prevent future regressions
like the one in the linked bug. It tests both a Search+Shift shortcut and
the corresponding Prefix Key shortcut.

Adds support for sending the meta modifier key in
aura/x11 tests.

BUG= 404470 

Committed: https://src.chromium.org/viewvc/chrome?view=rev&revision=291547

Committed: https://chromium.googlesource.com/chromium/src/+/8cab2737f1cb6e6011b0946f6bef5027868602c0

Review URL: https://codereview.chromium.org/490443002

Cr-Commit-Position: refs/heads/master@{#293687}

[modify] https://chromium.googlesource.com/chromium/src.git/+/91703961c10dfa0f452999ed7cb87945ea817362/chrome/browser/chromeos/accessibility/spoken_feedback_browsertest.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/91703961c10dfa0f452999ed7cb87945ea817362/ui/aura/test/ui_controls_factory_aurax11.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/91703961c10dfa0f452999ed7cb87945ea817362/ui/aura/test/ui_controls_factory_ozone.cc

Project Member

Comment 8 by bugdroid1@chromium.org, Sep 8 2014

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/b2a7771b89853f75969d43c108de588213b79714

commit b2a7771b89853f75969d43c108de588213b79714
Author: arv <arv@chromium.org>
Date: Mon Sep 08 14:17:35 2014

Revert of Add test for ChromeVox keyboard commands. (patchset #8 id:140001 of https://codereview.chromium.org/490443002/)

Reason for revert:
Broke Linux ChromiumOS Tests (dbg)(3)

http://build.chromium.org/p/chromium.webkit/builders/Linux%20ChromiumOS%20Tests%20%28dbg%29%283%29/builds/1199

Original issue's description:
> Add test for ChromeVox keyboard commands.
>
> This is just a couple of quick sanity checks to prevent future regressions
> like the one in the linked bug. It tests both a Search+Shift shortcut and
> the corresponding Prefix Key shortcut.
>
> Adds support for sending the meta modifier key in
> aura/x11 tests.
>
> BUG= 404470 
>
> Committed: https://src.chromium.org/viewvc/chrome?view=rev&revision=291547
>
> Committed: https://chromium.googlesource.com/chromium/src/+/8cab2737f1cb6e6011b0946f6bef5027868602c0
>
> Committed: https://chromium.googlesource.com/chromium/src/+/ad123c3ac76fadc625a9dff66960743d0df253ba

TBR=dtseng@chromium.org,sky@chromium.org,dmazzoni@chromium.org
NOTREECHECKS=true
NOTRY=true
BUG= 404470 

Review URL: https://codereview.chromium.org/550183002

Cr-Commit-Position: refs/heads/master@{#293718}

[modify] https://chromium.googlesource.com/chromium/src.git/+/b2a7771b89853f75969d43c108de588213b79714/chrome/browser/chromeos/accessibility/spoken_feedback_browsertest.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/b2a7771b89853f75969d43c108de588213b79714/ui/aura/test/ui_controls_factory_aurax11.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/b2a7771b89853f75969d43c108de588213b79714/ui/aura/test/ui_controls_factory_ozone.cc

Comment 9 by f...@opera.com, Sep 10 2014

Labels: -OS-Windows OS-All
Mergedinto: 348436
Status: Duplicate
Dupe of  issue 348436 . The font-size used when evaluating the 'em' unit(s) is zero (which even triggers an assert in the MQ-evaluator.)
Project Member

Comment 10 by bugdroid1@chromium.org, Sep 22 2014

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/15ea141544fedaf306c94890b5be19b7c5df885a

commit 15ea141544fedaf306c94890b5be19b7c5df885a
Author: dmazzoni <dmazzoni@chromium.org>
Date: Mon Sep 22 22:36:16 2014

Add test for ChromeVox keyboard commands.

This is just a couple of quick sanity checks to prevent future regressions
like the one in the linked bug. It tests both a Search+Shift shortcut and
the corresponding Prefix Key shortcut.

Adds support for sending the meta modifier key in
aura/x11 tests.

BUG= 404470 

Committed: https://src.chromium.org/viewvc/chrome?view=rev&revision=291547

Committed: https://chromium.googlesource.com/chromium/src/+/8cab2737f1cb6e6011b0946f6bef5027868602c0

Committed: https://crrev.com/91703961c10dfa0f452999ed7cb87945ea817362
Cr-Commit-Position: refs/heads/master@{#293687}

Review URL: https://codereview.chromium.org/490443002

Cr-Commit-Position: refs/heads/master@{#296074}

[modify] https://chromium.googlesource.com/chromium/src.git/+/15ea141544fedaf306c94890b5be19b7c5df885a/chrome/browser/chromeos/accessibility/spoken_feedback_browsertest.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/15ea141544fedaf306c94890b5be19b7c5df885a/ui/aura/test/ui_controls_factory_ozone.cc

Project Member

Comment 11 by bugdroid1@chromium.org, Sep 25 2014

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/14e5bdf573d0621dfdd553888a5d3c557fb699a0

commit 14e5bdf573d0621dfdd553888a5d3c557fb699a0
Author: jam <jam@chromium.org>
Date: Thu Sep 25 02:11:56 2014

Revert of Add test for ChromeVox keyboard commands. (patchset #21 id:390004 of https://codereview.chromium.org/490443002/)

Reason for revert:
flakes, see http://build.chromium.org/p/chromium.chromiumos/builders/Linux%20ChromiumOS%20Tests%20%28dbg%29%281%29/builds/31850

failures:
TestAsNormalAndGuestUser/SpokenFeedbackTest.ChromeVoxPrefixKey/0
TestAsNormalAndGuestUser/SpokenFeedbackTest.ChromeVoxPrefixKey/1
TestAsNormalAndGuestUser/SpokenFeedbackTest.ChromeVoxShiftSearch/1
TestAsNormalAndGuestUser/SpokenFeedbackTest.ChromeVoxShiftSearch/0
LoggedInSpokenFeedbackTest.AddBookmark

Original issue's description:
> Add test for ChromeVox keyboard commands.
>
> This is just a couple of quick sanity checks to prevent future regressions
> like the one in the linked bug. It tests both a Search+Shift shortcut and
> the corresponding Prefix Key shortcut.
>
> Adds support for sending the meta modifier key in
> aura/x11 tests.
>
> BUG= 404470 
>
> Committed: https://src.chromium.org/viewvc/chrome?view=rev&revision=291547
>
> Committed: https://chromium.googlesource.com/chromium/src/+/8cab2737f1cb6e6011b0946f6bef5027868602c0
>
> Committed: https://crrev.com/91703961c10dfa0f452999ed7cb87945ea817362
> Cr-Commit-Position: refs/heads/master@{#293687}
>
> Committed: https://crrev.com/15ea141544fedaf306c94890b5be19b7c5df885a
> Cr-Commit-Position: refs/heads/master@{#296074}

TBR=dtseng@chromium.org,sky@chromium.org,dmazzoni@chromium.org
NOTREECHECKS=true
NOTRY=true
BUG= 404470 

Review URL: https://codereview.chromium.org/603823002

Cr-Commit-Position: refs/heads/master@{#296627}

[modify] https://chromium.googlesource.com/chromium/src.git/+/14e5bdf573d0621dfdd553888a5d3c557fb699a0/chrome/browser/chromeos/accessibility/spoken_feedback_browsertest.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/14e5bdf573d0621dfdd553888a5d3c557fb699a0/ui/aura/test/ui_controls_factory_ozone.cc

Project Member

Comment 12 by bugdroid1@chromium.org, Sep 25 2014

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/1ed0acfc528fb52602d776d22ade9ad50c23f614

commit 1ed0acfc528fb52602d776d22ade9ad50c23f614
Author: jam <jam@chromium.org>
Date: Thu Sep 25 06:43:32 2014

Revert of Revert of Add test for ChromeVox keyboard commands. (patchset #1 id:1 of https://codereview.chromium.org/603823002/)

Reason for revert:
sorry I reverted this incorrectly, the problem was that the isolate needed a nacl file. I'm not sure why it only needed it on debug cros and not release. I landed it in https://codereview.chromium.org/597283004/

Original issue's description:
> Revert of Add test for ChromeVox keyboard commands. (patchset #21 id:390004 of https://codereview.chromium.org/490443002/)
>
> Reason for revert:
> flakes, see http://build.chromium.org/p/chromium.chromiumos/builders/Linux%20ChromiumOS%20Tests%20%28dbg%29%281%29/builds/31850
>
> failures:
> TestAsNormalAndGuestUser/SpokenFeedbackTest.ChromeVoxPrefixKey/0
> TestAsNormalAndGuestUser/SpokenFeedbackTest.ChromeVoxPrefixKey/1
> TestAsNormalAndGuestUser/SpokenFeedbackTest.ChromeVoxShiftSearch/1
> TestAsNormalAndGuestUser/SpokenFeedbackTest.ChromeVoxShiftSearch/0
> LoggedInSpokenFeedbackTest.AddBookmark
>
> Original issue's description:
> > Add test for ChromeVox keyboard commands.
> >
> > This is just a couple of quick sanity checks to prevent future regressions
> > like the one in the linked bug. It tests both a Search+Shift shortcut and
> > the corresponding Prefix Key shortcut.
> >
> > Adds support for sending the meta modifier key in
> > aura/x11 tests.
> >
> > BUG= 404470 
> >
> > Committed: https://src.chromium.org/viewvc/chrome?view=rev&revision=291547
> >
> > Committed: https://chromium.googlesource.com/chromium/src/+/8cab2737f1cb6e6011b0946f6bef5027868602c0
> >
> > Committed: https://crrev.com/91703961c10dfa0f452999ed7cb87945ea817362
> > Cr-Commit-Position: refs/heads/master@{#293687}
> >
> > Committed: https://crrev.com/15ea141544fedaf306c94890b5be19b7c5df885a
> > Cr-Commit-Position: refs/heads/master@{#296074}
>
> TBR=dtseng@chromium.org,sky@chromium.org,dmazzoni@chromium.org
> NOTREECHECKS=true
> NOTRY=true
> BUG= 404470 
>
> Committed: https://crrev.com/14e5bdf573d0621dfdd553888a5d3c557fb699a0
> Cr-Commit-Position: refs/heads/master@{#296627}

TBR=dtseng@chromium.org,sky@chromium.org,dmazzoni@chromium.org
NOTREECHECKS=true
NOTRY=true
BUG= 404470 

Review URL: https://codereview.chromium.org/600373002

Cr-Commit-Position: refs/heads/master@{#296670}

[modify] https://chromium.googlesource.com/chromium/src.git/+/1ed0acfc528fb52602d776d22ade9ad50c23f614/chrome/browser/chromeos/accessibility/spoken_feedback_browsertest.cc
[modify] https://chromium.googlesource.com/chromium/src.git/+/1ed0acfc528fb52602d776d22ade9ad50c23f614/ui/aura/test/ui_controls_factory_ozone.cc

Project Member

Comment 13 by bugdroid1@chromium.org, Sep 25 2014

The following revision refers to this bug:
  https://chromium.googlesource.com/chromium/src.git/+/97ec806ebc437afbbdd7657062f6fbca1d708dcc

commit 97ec806ebc437afbbdd7657062f6fbca1d708dcc
Author: dmazzoni <dmazzoni@chromium.org>
Date: Thu Sep 25 23:44:49 2014

ChromeVox spoken feedback test using shift and search keys.

Split off from cl 490443002 because for some reason this test seems to
fail with a NaCl error on one of the trybots. Let's try to land it
separately.

BUG= 404470 

Review URL: https://codereview.chromium.org/590913002

Cr-Commit-Position: refs/heads/master@{#296833}

[modify] https://chromium.googlesource.com/chromium/src.git/+/97ec806ebc437afbbdd7657062f6fbca1d708dcc/chrome/browser/chromeos/accessibility/spoken_feedback_browsertest.cc

Sign in to add a comment