Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Starred by 7 users
Status: Duplicate
Merged: issue 10812
Owner: ----
Closed: Apr 2010
EstimatedDays: ----
NextAction: ----
OS: Mac
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment
UOB Internet Banking
Reported by queenv...@gmail.com, Apr 4 2010 Back to list
Chrome Version       : 5.0.342.7 beta for mac
URLs (if applicable) : https://pib.uob.com.sg/PIBLogin/appmanager/Login/Public
Other browsers tested:
  Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4: Ok
  Firefox 3.x: Ok
         IE 7: Ok
         IE 8:Ok

What steps will reproduce the problem?
1.
2.
3.

What is the expected result?


What happens instead?
Error Message: "Applet not loaded properly! Please reload the page again."
 
Screen shot 2010-04-04 at AM 10.33.44.png
69.2 KB View Download
Mergedinto: 10812
Status: Duplicate
Hi, problem still exists with the following scenario:

Chrome Version: 6.0.472.63 beta for Mac
URLs: https://pib.uob.com.sg/PIBLogin/appmanager/Login/Public

Other browsers tested
Safari 5 (Mac): OK
Chrome 6 (Windows): OK

What steps will reproduce the problem?
1. Verify that latest Java for Mac OS X is installed via Software Update
2. Visit stated URL

Everything works fine on Chrome v3+ on Windows, however not on Mac OS X (any version).

Other Java applets from other websites are working OK.
Screen shot 2010-09-25 at AM 12.57.28.png
288 KB View Download
Comment 3 by Deleted ...@, Jan 16 2011
hi,
i am also getting the same issue with applet not loaded properly
under Mac OSX 10.6.5 and chrome 8.0.522.237. 
The configuration check provided by UOB 
did not even detect the JRE, see http://www.uob.com.sg/online_services/system_configuration_check.html
However the java test from http://javatester.org/version.html
was able to detect my JRE as 1.6.0_22 from apple mac 
Does anyone have solution for this ? 


Comment 4 by Deleted ...@, Mar 21 2011
I have a Mac and have exactly the same problem! Why can't UOB fix this when all other systems work fine. No internet banking is useless in today's environment!!!!
Comment 5 by Deleted ...@, Jul 26 2011
Is there any updates for this issue?
Comment 6 by bgill...@gmail.com, Jul 28 2011
Same issue here with Chrome 13.0.782.107.  It used to work fine for me in Firefox 5 and in Safari 5 but now those stopped working too.  This is my first time trying to log in to UOB since upgrading to OS X Lion, so maybe that is the culprit.
Comment 7 by Deleted ...@, Jul 31 2011
I have Mac Version 10.7, Safari, Firefox and Chrome all cant work... 
Comment 8 by Deleted ...@, Jul 31 2011
Just bought a Macbook Mac Air with Mac Version 10.7 using Safari, I have the same problem and it show applet not loaded properly. Please reload page again. Before this, I am using the older version Mac OSX 10.5.8 not problem. could UOB Internet Banking fix the problem please.
Comment 9 by Deleted ...@, Aug 2 2011
the matter can be solve while you use backward to job internet bank home page and internet banking again. You should see the cursor rest on the user block. repeat the above again if it doesn't response. I have done it, and it work on my OSX Lion now.
Comment 10 by Deleted ...@, Aug 7 2011
I also hv the same problem!! Safari also the same

Comment 11 by Deleted ...@, Aug 10 2011
One way to access UOB internet banking with your macbook/pro/air and safari 5.1 (post-Lion version).

Click on Safari->Preferences->Advanced and turn on Show Develop menu in menu bar.
Then go to UOB Personal Internet Banking (https://pib.uob.com.sg/PIBLogin/appmanager/Login/Public) and after it complains that "Applet not loaded properly!", click OK, then click on Develop->User Agent->Safari iOS 4.3.3 - iPad in menu bar.
The page will reload, and you will be able to log in to UOB Internet banking.

At least this method works for now..
Comment 12 by Deleted ...@, Aug 16 2011
The changing user agent to safari iOS - iPad works. Thanks. 

Comment 13 by Deleted ...@, Sep 25 2011
thanks a lot, u r a genius! been trying for months! anyone sounded uob out?
There are two problems here:
1) To me it seems that Login applet that UOB uses is taking longer to load on Chrome (and mostly safari) than Firefox. Possibly in chrome it sandboxes
2) UOB has a crappy way of checking applet loading (see below) which would fail in case applet loading takes longer. 

_How applet loading is checked?_
in Public:569 invokes initApplet() method. In pib_login.js:204-226 (initApplet()) method, it simply checks if the applet object is present in the DOM else it shouts about applet not being loaded.

I added a break point in the initApplet method, to see the check thats failing. And nothing failed. Crazy? Thats because, adding breakpoint and stepping through code gave just enough time for applet to load and validation to pass.


_What can be done about it?_
From UOB side -  Ideally, It would should check at least try 3 times with 1 sec wait in between. Or even better use a callback to execute this method.
 In the mean time - may be we could use a userscript (not sure about that) to introduce a delay in execution on initApplet method.
{SOLVED}
After spending sometime I managed to create a bookmarklet that can help you in logging in. It not the perfect solution but until folks at UOB choose to fix their code, this should help.

I have posted instructions for this on my blog. It simple and takes less then 5 seconds.
http://www.yogendra.me/2012/01/08/how-to-use-uob-internet-banking-on-chrome-on-mac-os-x/
Project Member Comment 16 by bugdroid1@chromium.org, Oct 13 2012
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:10812
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member Comment 17 by bugdroid1@chromium.org, Mar 11 2013
Labels: -Area-Undefined
Sign in to add a comment