New issue
Advanced search Search tips
Starred by 2 users

Issue metadata

Status: Duplicate
Merged: issue 395253
Owner: ----
Closed: Jul 2014
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment
link

Issue 396790: Major mouse over and mouse click displacement on web sites navigation and dev tools

Reported by soundstr...@gmail.com, Jul 23 2014

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0

Steps to reproduce the problem:
1. Emulate any page using Dev Tools Emulation
2. Stop Emulation and Restart Chrome (possibly computer as well I don't know)
3. Try to navigate any web site that has a drop down menu with sub menus. Or simply hover some text links with mouse over styles like underline on hover.

What is the expected behavior?
Everything should work fine without any problems.

What went wrong?
When I hover a link or try to navigate through a menu with sub menus, the hover is all screwed up and not accurate. Also, when using the Dev Tools Drawer it's hard to select the tab. For example, when I click the Emulator tab, the Rendering tab opens instead.

Did this work before? N/A 

Chrome version: 36.0.1985.125 (Official Build 283153)   Channel: n/a
OS Version: Windows 7
Flash Version: 14.0.0.14

I am experiencing this behavior of Chrome ever since I used the Emulation tool to fix one of my mobile sites. Ever since that day, Chrome has been acting like this and I have to use Firefox because Chrome is virtually unusable. Please advise! I need Chrome because of its Dev Tools.
 

Comment 1 by soundstr...@gmail.com, Jul 23 2014

P.S. I also tried clearing cache and reinstalling Chrome. What seems to fix the problem is disabling Dev Tools completely in the Settings file by setting the "devtools" property to "disabled":true. However, I still need to use the Dev Tools so this solution does not work for me.

Comment 2 by soundstr...@gmail.com, Jul 25 2014

I am attaching a trace file if that helps.
trace.zip
2.3 MB Download

Comment 3 by manoranj...@chromium.org, Jul 28 2014

Cc: dgozman@chromium.org
Labels: Needs-Feedback Cr-Platform-DevTools
This issue looks similar to https://code.google.com/p/chromium/issues/detail?id=133915?

Thank you!

Comment 4 by dgozman@chromium.org, Jul 28 2014

This one has nothing to do with  issue 133915 .

@soundstreamchat, am I right that your mouse position is off for the whole Chrome (including wrench menu, back-forward buttons, any web page links, DevTools, etc.)?
What do you mean by disabling DevTools in the Settings? Did you edit your Preferences file?

Comment 5 Deleted

Comment 6 Deleted

Comment 7 by soundstr...@gmail.com, Jul 29 2014

@dgozman@chromium.org, the mouse is only off for the Dev Tools and web page links. The back-forward buttons and bookmarks work fine. And yes, I edited the Preferences file. I only edited that one variable to see if it fixes the problem, which it did, and then I reverted it back to original settings. I found a very similar issue if not exactly the same here: https://code.google.com/p/chromium/issues/detail?id=395253

I did a bench mark test on SunSpider and Chrome is much much slower (like 10 times slower) than Firefox, so there is something wrong. Below is the result of the benchmark:

https://www.webkit.org/perf/sunspider-1.0.2/sunspider-1.0.2/results.html?%7B%22v%22:%20%22sunspider-1.0.2%22,%20%223d-cube%22:%5B15,15,16,14,14,14,15,15,15,15%5D,%223d-morph%22:%5B16,15,19,15,16,15,16,15,15,15%5D,%223d-raytrace%22:%5B17,17,19,16,17,17,18,17,17,17%5D,%22access-binary-trees%22:%5B2,2,2,2,2,2,2,3,2,2%5D,%22access-fannkuch%22:%5B12,11,11,11,10,11,11,12,11,12%5D,%22access-nbody%22:%5B7,6,6,6,5,7,6,5,6,6%5D,%22access-nsieve%22:%5B4,5,4,4,5,4,5,4,5,5%5D,%22bitops-3bit-bits-in-byte%22:%5B2,2,2,2,2,2,2,1,2,2%5D,%22bitops-bits-in-byte%22:%5B7,8,6,7,7,8,7,6,8,6%5D,%22bitops-bitwise-and%22:%5B3,3,3,3,4,4,3,4,4,3%5D,%22bitops-nsieve-bits%22:%5B6,6,6,6,6,7,6,6,7,7%5D,%22controlflow-recursive%22:%5B2,3,2,2,3,3,3,3,3,2%5D,%22crypto-aes%22:%5B9,9,8,9,9,10,10,9,10,8%5D,%22crypto-md5%22:%5B7,7,9,8,8,8,8,8,8,8%5D,%22crypto-sha1%22:%5B8,8,9,9,9,8,8,9,9,9%5D,%22date-format-tofte%22:%5B2959,2875,3112,2977,2875,2936,2928,2995,2972,2907%5D,%22date-format-xparb%22:%5B14,14,15,14,14,15,15,15,14,14%5D,%22math-cordic%22:%5B5,5,5,6,6,5,6,5,5,7%5D,%22math-partial-sums%22:%5B16,16,16,16,15,16,19,16,15,16%5D,%22math-spectral-norm%22:%5B4,4,4,4,4,4,4,4,4,4%5D,%22regexp-dna%22:%5B12,11,11,11,11,11,11,11,11,12%5D,%22string-base64%22:%5B9,9,9,9,9,9,9,10,9,9%5D,%22string-fasta%22:%5B15,16,16,15,15,15,16,17,15,16%5D,%22string-tagcloud%22:%5B35,37,38,37,40,38,37,37,38,39%5D,%22string-unpack-code%22:%5B31,33,34,30,31,33,31,31,32,31%5D,%22string-validate-input%22:%5B12,12,12,12,11,12,13,13,13,12%5D%7D

Comment 8 by dgozman@chromium.org, Jul 30 2014

Mergedinto: 395253
Status: Duplicate
Yes, this looks very much identical to  issue 395253 . I'll mark this one as duplicate. If 395253 will be resolved, and your problem still occurs, we can reopen this one and investigate further.

Sign in to add a comment