Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.
Starred by 30 users
Status: Duplicate
Merged: issue 402134
Owner:
User never visited
Closed: Aug 2014
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Bug



Sign in to add a comment
Severe keyboard/mouse lag
Reported by mixsy...@gmail.com, Jul 21 2014 Back to list
UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce the problem:
1. Type in a text input box on a web page; observe 0.75-1-second keystroke delay
2. Drag to select some web page text; observe random selection lag. Click outside the selection to deselect it; observe that selection is not always deselected as it should be (often requires several clicks)

What is the expected behavior?

What went wrong?
After an update over the last couple of days, typing into text input boxes has suddenly become EXTREMELY laggy -- EVERY keystroke is subject to a ~1 second delay.

Also, mouse clicks, hovers and drags are subject to similar lag and unresponsive clicks.

So far, I've observed this lag on every site I've visited. The upshot of this is that Chrome is currently virtually unusable.

I've tried restarting, closing all tabs, disabling all extensions, clearing cache and running in Incognito mode -- all to no avail.

Did this work before? N/A 

Chrome version: 36.0.1985.125  Channel: stable
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
Flash Version: Shockwave Flash 14.0 r0
 
Comment 1 by Deleted ...@, Jul 21 2014
I am having the exact same issue.  The lag is specific to chrome, not observed on Firefox or IE.  Also does not occur in the address field, only in the text boxes.  It seems like the last key stroke is what experiences the lage
Also having this same issue since the update to 36.0.1985.125.  Extremely frustrating.
Comment 3 Deleted
Comment 4 Deleted
Comment 5 by Deleted ...@, Jul 22 2014
trying to use bookmark bar takes about 5 seconds to work, along with left clicking and clicking on the options button since today :(
Comment 6 Deleted
Comment 7 by Deleted ...@, Jul 22 2014
Exact same problem here too, uninstalled Chrome and reset user profile to no avail. Have resorted to IE, hope there will be a fix!
same.  using Windows 7 64 bit home premium.  
did all steps above.  and moved chrome to 37 beta channel: no luck (cannot reverse this once it is done btw).  

in addition to task manager with processes sorted on cpu, also using a desktop sidebar gadget that monitors cpu usage.  

intel haswell core i7 4770, one of the fastest consumer grade chips....and computer is less than a month old).  the hyperthread presents itself to the OS as an eight core system).  On these "bad" pages typically one of these virtual cores is redlined at 100%.

I want to note: SOME sites are unaffected.  Gmail.  Google calendar.  some are dramatically affected: Google voice, Facebook, even ESPN.  

Once chrome is open and a "bad" site open on any tab, the whole computer slows down....might as well be an 8086 with two floppy disks whirring.  And why no word from Google on this epic fail.

Shipping us over to IE-land I not a win for Google
Comment 9 by Deleted ...@, Jul 22 2014
I updated my graphics driver and it fixed the problem
Comment 10 by Deleted ...@, Jul 22 2014
I'm having the same issue as well. So far no solution could be found. As much as I love chrome, this kind of crap shouldn't happen.
Comment 11 by Deleted ...@, Jul 22 2014
I have had the same issue for nearly a week now as well.  I would like to explain in more details, but it's SO FRUSTRATING typing with a lag/delay/random response that I can't...
Comment 12 by Deleted ...@, Jul 22 2014
I have also had this problem for a few days, I just recently tried as #9 to update my graphics driver and now everything runs smooth.
Comment 13 by Deleted ...@, Jul 22 2014
Since #9 and #12 seemed to have success, thought I'd try as well... and it worked.  (I'm willing to bet it'll become unstable again in a few weeks though...).  Graphics driver update seems to work - mine went from a legacy 2009 driver to a legacy 2010 driver, so maybe others want to try an uninstall/reinstall of the graphics driver to see if that fixes it?
No luck for me, brand new (desktop) computer, brand new graphics card, up to date driver.  If updating a driver works for some, that's great but it's also good fortune.

Google did not plan to go from first to worst with this update, nor would they knowingly release a new browser version that required a driver upgrade to function.  

My answer will be coming from Google, not my hardware manufacturer.
Comment 15 by jmpav...@gmail.com, Jul 23 2014
I found that if i turn off hardware acceleration. It fixes my issue:

http://www.solveyourtech.com/turn-hardware-acceleration-google-chrome/

I'm going to do that until google has resolved this problem.
Comment 16 by Deleted ...@, Jul 24 2014
nothing helps. same problem, i cannot locate what is wrong :( 
tried reinstalling ati drivers, stil no change.
hardware acceleration off: no change :(
Comment 17 by Deleted ...@, Jul 24 2014
sorry, i checked again (had to restart chrome for hardware acceleration off option)
now it is better. if i type and select last word (ctrl+shift+left arrow) ti works, as before it was stuck and it selected last word on it's own time....
Re: 36.0.1985.125

As I have reviewed this thread several times, I saw solutions proposed that worked for some, and not others. Neither of these solutions had any impact on the issues I described.
- update graphics device driver
- disable Chrome hardware acceleration

It occurred to me that
- Although I experienced the text box lag issue, there are other issues I am experiencing that dramatically affect the performance of the entire computer not just  a particular tab in Chrome.
- and finally....they occur only when I visit certain sites (and I cited Google Voice as an example).

In my case the entire computer's performance suffers severe lag issue.  Although I can see CPU usage sharply increase, that hardly explains my situation.  Mine is similar to what an XP user might experience if they did not any page file space allocated, (or too little) and they they had exhausted physical memory.  Everything comes to a screeching halt.  I have 8 gig, and my computer is typically using about 45% of it at any point in time, and that is still the case during these episodes.

It suggests that the cause or causes of the problems I am experiencing may be quite different than those described above.  That there are multiple problems, each with different solutions.  I do not have the skill or resources to track this down myself.  

I am curios as to whether others are experiencing performance degraded on the entire computer, not just Chrome.  In my case, with Google Voice open in Chrome, launching an unrelated app takes 20-30 seconds instead of a few 10ths of a second.  Closing Chrome itself takes 20 to 30 seconds.  

I did file a problem report that included screen shots of task manager, etc.  
disabling hardware acceleration in chrome helped.

toggle this option off:
Use hardware acceleration when available
Comment 20 by Deleted ...@, Jul 27 2014
Disabling hardware acceleration helped here too (although it took a solid minute before the page finished loading so I could click the checkbox...).

Windows 7 x64 Ultimate.  i7-920 with 6 GB RAM (3.2 GB in use).  ATI Radeon HD 5450 video, current driver, 1GB. Chrome Version 36.0.1985.125 m
Disabling hardware acceleration fixed it for me.
Labels: -OS-Windows OS-All Hotlist-ConOps Cr-UI-Input-Text
We have observed a spike in user reports (and an internal, reproducible case) where text input will significantly lag before appearing in a text input field.

"There is a typing lag on google chrome. Everytime I type out a sentence there is a delay from when I push the keys on my keyboard to when the letters show up on the screen. I tried typing something on Firefox and there was no lag. Please fix."

"...However the worst and most annoying problem is the lag on typing. The typing can't seem to keep up with my key presses and it is slow compared to every other program I use."
TextInputDelayReports.PNG
15.1 KB View Download
Comment 23 by rxc6...@gmail.com, Aug 2 2014
I am having the same problem.  It is not limited to the mouse, but also happens with my pointing pad and with keyboard navigation keys, as well.  It appears like the last character in the input buffer is not registering until another key is pressed, especially scroll up and down arrow keys.  Sometimes the last character is just delayed, and this occurs only with typing into a test box, like the one I am typing in now.  It is diffiicult to select text, and editing requires concentration to ensure you are typing where you think you are.

Problem only occurs in Chrome.  Not in IE, not in MS Word or Excel or other apps which accept text, or in apps which require mouse tracking. It is not related to load on the machine or disk space, or memory, or the USB port where the mouse is attached.  Have disconnected everything from all USB ports, and the problem still exists for trackpad and navigation keys.  I could video the behavior, and send the video, if that would be useful.

Quite annoying.  Has been evident for at least a week.

ASUS laptop, Windows 7 64 bit
I finally found an adequate solution that seems to be a band-aid, but solves the problems I experienced...for the most part.  See previous issues, my issues affected the computer far beyond what others reported.  

From the search bar, type "Turn Windows features on or off", and click that.  Wait for the screen to populate, and uncheck Windows Gadget platform.  Kiss your gadgets goodbye if you were using any.  

My Norton Internet Security is still infrequently reporting High CPU usage by Google Chrome, from time to time, but that message is more of less ignorable.  I have my Chrome back.  

I found this by first booting in Safe with Networking (no issues with Chrome), and next trying "normal boot" via msconfig, Used the hide Microsoft services checkbox, and disabled the rest.  Also no issues with Chrome.  I knew then that it was a software conflict,  

Then I found it via hit or miss / luck via enabling non- Microsoft services one at a time, what a chore. 
Comment 25 by rxc6...@gmail.com, Aug 3 2014
@WillardP

Thanks for the tip, but no joy for me.  Got rid of gadgets, but problem still exists with Chrome.  As I type this, it is there.
Comment 26 by Deleted ...@, Aug 4 2014
merci effectivement le problème pour moi a été résolu en décochant la case accélérateur matérielle de google chrome merci !!!

Comment 27 by Deleted ...@, Aug 4 2014
J'ai eu le même souci de ralentissements avec la dernière version de Google Chrome (36.0.1985.125 m).
J'ai décoché la case "Utiliser l'accélération matérielle (le cas échéant)" dans les paramètres de Google Chrome et ça a changé du tout au tout. Le navigateur fonctionne bien plus rapidement !
A surveiller si le problème venait à se reproduire.
Comment 28 by Deleted ...@, Aug 4 2014
Tip # 21 worked for me.
Comment 29 by Deleted ...@, Aug 4 2014
Tip #21 - turning off hardware accleration worked for me too.  Many thanks!
Comment 30 Deleted
Comment 31 by Deleted ...@, Aug 5 2014
Tip #21 - turning off hardware acceleration worked for me too.  hope others can find this page, I was searching for several days. 
Comment 32 by Deleted ...@, Aug 6 2014
Tip #21 improved greatly, but I am still having an issue with Click/Drag highlighting.  Doesn't seem to be working properly.  Is this related?
Cc: srsridhar@chromium.org kenjibaheux@chromium.org
Unfortunately we could not reproduce the issue on Windows 7/8 OS - chrome version 36.0.1985.125. No lag observed while typing in the text fields with hardware acceleration enabled. 

@melodychu: Could you please look into this issue.
Comment 34 by jas...@gmail.com, Aug 7 2014
I had the same problem on a client's computer running Windows 7 X64. They had a Radeon HD 4200 with the factory-shipped driver from 07/2009. Disabling the hardware acceleration did fix the problem temporarily. Updating to the newest driver available (dated 04/2013 ver. 8.970.100.1100) from AMD fixed the problem permanently.
Comment 35 by rxc6...@gmail.com, Aug 8 2014
Turning off hardware acceperation finally cured the problem for me.  I can re-create it, if there is some way for the chromium people to see what happens.
Comment 36 by Deleted ...@, Aug 8 2014
FWIW The hardware acceleration setting seems to work for me as well.  Will pipe back in  if that changes.
Comment 37 by nsch...@gmail.com, Aug 11 2014
disabling the hardware accelleration fixed this for me as well. Writing an e-mail in webmail used to unbearably slow, but works fine again now. I'll look for a newer version of the display driver (ATI)
Labels: Cr-Internals-GPU
Owner: wiltzius@chromium.org
Owner: vangelis@chromium.org
Mergedinto: 402134
Status: Duplicate
Folks, we've identified that this is an issue that affects older (circa 2009) AMD graphics drivers. The solution for now is to run chrome with the --disable-d3d11 flag or updating the graphics drivers (if newer ones are available) . We're working on a fix for the next Chrome stable update. Please refer to  issue 402134  . 
Comment 41 by Deleted ...@, Aug 15 2014
I have the same issue, and turning off hardware acceleration did not fix the problem, but #24, WillardP's tip did the trick. Gadgets off and it's back to normal. 
Comment 42 by mihal...@gmail.com, Aug 16 2014
Same irritating issue for me. Turning off hardware acceleration seems to solve the problem.
I have been having this same problem since July as the others have experienced plus more. Chrome also takes about ten seconds to appear after being started up. Video in the Chrome browser: Youtube, Netflix and Amazon pauses intermittently for several seconds at a time. I have a quad core processor, 12 gigs of ram and updated the driver  video card, so the computer isn't the problem. Followed all the above advice for only moderate improvement.
When is the next Chrome update to fix this?
Comment 44 by Deleted ...@, Aug 23 2014
Disabling hardware acceleration works.
I also had this problem, which was getting progressively worse. The scroll wheel was unusable, it would randomly switch directions or wait 2 seconds to move. I updated my NVidia drivers to the latest release and that fixed it.
#15 - disabling Chrome acceleration worked for me too, thanks
Comment 47 by Deleted ...@, Sep 2 2014
Disabling the hardware acceleration did the trick for me (Win7 with Radeon HD 5500)!
For those of you who are new on this thread: We have determined that this is an issue affecting older AMD/ATI drivers. The temporary solution for the time being is to run Chrome with --disable-d3d11 (you'll still get the benefits of h/w accelerated rendering). When Chrome updates to version 37, you'll no longer need to specify the flag in the command line. 

A better alternative is to update your graphics drivers, if new ones are available. 

Comment 49 by Deleted ...@, Sep 23 2014
I am running version 37 and still had issues but THANK YOU #15!  Turning off Hardware acceleration worked immediately.  I've been suffering with this for weeks and I am soooo very happy now.
This seems to be fixed for me in yesterday's build (current version out there). Thanks!
Comment 51 by Deleted ...@, Oct 4 2014
I'm still getting a ton of lag. Text boxes aren't too bad except on certain sites (IE and Firefox works fine on those sites). The address bar is so laggy that it's almost unusable. I'm running Chrome 37 and I've disabled hardware acceleration.
Comment 52 by Deleted ...@, Oct 6 2014
I have updated my graphics driver, turned hardware acceleration  off and updated my version of Chrome. I am running Windows 8.1 and I am still having this lag problem. It's particularly bad in Gmail. Typing an email is torture. Turning off hardware acceleration improved things for about a day...but now the lag is back  Please fix this...
I want to let you guys know that this issue is affecting me to.

I am running Chrome 37.0.2062.120 (64-bit) on Sabayon Linux on an Asus X550CC ultrabook and keyboard input, scrolling and drag-select of text are painfully laggy and have been since Chrome 35.x

Base on top it seems like Chrome is consuming an excessive amount of CPU with multiple Chrome processes consuming more than 3% CPU and sum CPU usage for all Chrome processes easily exceeding 10% overall.
Disabling HW accel seems to have fixed it for me too...
I am using chromium with Intel i3-3217u, hd4000 on linux.
No matter what I do it can't solve this issue.
Comment 56 by Deleted ...@, Dec 21 2014
Turning off accelarator worked onky for 24 hours. Problem has returned.
Comment 57 by Deleted ...@, Dec 29 2014
I switched back to Firefox on my (new) desktop because Chrome is just unusable due to the lag problem. Curiously enough, Chrome works perfectly fine on my 2-yr old laptop. They are both i7 machines running the latest Windows 8 version. 
RSoto21: could you please copy-paste the contents of the about:gpu page from your desktop? Also, if possible, can you please run chrome with the following command line flag:

--disable-d3d11 

to see if it makes a difference? 
Cc: -kenjibaheux@chromium.org
I have the same issue on Ubuntu 14.10 (64-bit) on chrome 40.0.2214.115 (64-bit). Both solutions (with disabling hardware acceleration and --disable-d3d11) works more or less the same for me.

I'm attaching my about:gpu
gpu.log
9.0 KB View Download
Comment 61 Deleted
Comment 62 by hr0...@gmail.com, Mar 12 2015
Windows 7 Pro 64-bit  Chrome Version 42.0.2311.39 beta-m

SOLVED by disabling extensions! FINALLY!!!

First, I know, it doesn't work for some people.  :-(  But if you haven't, definitely give it a try. 

This typing lag had been driving me crazy for over a year (through many updates of Chrome)... I often reverted to typing in Notepad and pasting into Gmail when composing an email. 

What finally worked for me was disabling extensions. I checked this post and only the original poster mixsy mentioned that she'd tried doing that but to no avail. 

I suggest you disable one extension (in More Tools, Extensions) and try composing an email. If it's still slow, then re-enable and try another one. I don't think it's necessary to restart Chrome each time. But if typing is still slow after you've tested all your extensions, then you should try the process again, but close & re-open Chrome after each extension you test. 

I hope this works for you (at least somebody out there). I know it's an extremely frustrating problem. I didn't find any solutions (or even mentions) in the numerous searches I've done over the past year. 

Good luck! 
Comment 63 Deleted
Comment 64 Deleted
Comment 65 Deleted
Comment 66 by Deleted ...@, Apr 4 2015
None of the proposed solutions worked for me. I'm wondering, how such an issue is not fixed within more than 9 months? This leads me to some unpleasant thoughts about the quality of development in Google... I'm uninstalling Chrome permanently.
gpu.html
84.1 KB View Download
Comment 67 by Deleted ...@, Apr 15 2015
Having the same problem on my Mac. Ideas?
Comment 68 by Deleted ...@, May 2 2015
On a mac OSX Yosemite 10.10.3 and am having the same issue/s still. Keyboard lagging on Gmail and Chrome
Same here. I also have been having this problem ever since I bought my HP (AMD A-10 core) almost a year ago. The motherboard had to be replaced, but Chrome has been lagging ever since I got it. Disabling Hardware Acceleration and removing extensions helped temporarily, but it's now worse than before. I'm checking my drivers to see if any need updating, but other than that I'm slowly but surely moving away from Chrome. Disappointing, because it has so many more features than Firefox or IE.
Comment 70 by Deleted ...@, Jul 29 2015
Same story here - terrible lag that I can't fix.  Disabling Hardware accel did nothing for me.  Just upgraded to Win 10 Pro today, issue still there as bad as ever.

I have dell precision M3800, Processor	Intel Core i7-4702HQ @ 2.20GHz, 2195 Mhz, am running Chrome 44 most up to date version.  Had this lag for a long time now.  Come on Google, I use gmail, calendar, maps, chrome, extensions - so much of my life is on google - are you going to make me get a new/better browser?

Comment 71 by Deleted ...@, Aug 1 2015
I guess no one is going to address this issue? I did a little testing/write up here, hopefully someone sees it, disabling hardware acc or removing extensions did not help for me: http://john.cuppi.net/google-chrome-textarea-input-lag/

Apparently the site won't let me post 3 links in a comment, but note that there are two other issues with this same problem (I've had the same problem myself). I don't expect Chrome to fix this though as they are making this site read-only on August 25. (See this link: https://code.google.com/p/support/wiki/ReadOnlyTransition)

Here's one of the other tickets with all similar tickets listed:
https://code.google.com/p/chromium/issues/detail?id=493216
Comment 73 by edc...@gmail.com, Sep 23 2015
"Slow typing in Gmail" problem here, too. BUT, it happens in BOTH Chrome Version 45.0.2454.99 m *AND* Firefox 41.0 (anyone else seeing the problem in BOTH browsers?)

Dell Optiplex 3010 w/ Intel Core i5 3.2GHz and 8GB memory running Win 7 Pro x64 SP1.



It only seems to happen in Reply mode. Happens in pop-outs, too.

Disabled "Use hardware acceleration when available" in Chrome, and all but "Avast!" and "LastPass" extensions.

In Firefox, only "Avast!," "LastPass" and "NoScript" Add-ons are enabled.


Comment 74 by iokz...@gmail.com, Nov 8 2015
Some issue here, everything type on address bar, or hover on anything with cursor will stop everything for a good second on two. Tried everything, nothing work. 

Tried two machine with debian 8. one 8 years old core 2 duo Machine, while the other is kind of oldish 12 cores xeon workstation. No luck what so ever.
Comment 75 by Deleted ...@, Nov 17 2015
Acer V5 i5 w/ 12GB Memory. 2IN 10.   Same lag problems being described here.  RE-installed chrome, changed virus protection from AVG to Avira, reset CHROME settings to defaults....   NOTHING WORKS TO GET RID OF THIS LAG..  
Centos 7, Intel integrated graphics. Chrome 47. Same problem as long as hw acceleration is enabled. So this problem is definitely not limited to Windows.
Comment 77 by thor...@gmail.com, Apr 19 2016
Hi!
I investigated the same problem now and it looks to be be the combination of chrome spell check and lots of data in a tag/field.

If you test textarea html tag using this site I see the exact same issue described in this bug. It slows keyboardinput to 1-2(or more) seconds pr letter.
http://www.w3schools.com/tags/tryit.asp?filename=tryhtml_textarea

however if you change the textarea to disable spellcheck the problem is gone...:
<textarea rows="4" cols="50" spellcheck="false">
Comment 78 by edc...@gmail.com, Apr 22 2016
Apparently, users can once again control Spell Check options in Chrome:
https://productforums.google.com/forum/#!topic/chrome/3hDpsFcxHrs

-- QUOTED TEXT --
I'm glad to say that the right-click Spellcheck menu and Disable Spell Check is back in just released Chrome 50.0.2661.75

http://googlechromereleases.blogspot.com/2016/04/stable-channel-update_13.html

You can right-click inside textfields and textboxes > Spellcheck, and you will see a context-menu list of currently available spellcheck languages, and a link for "Language settings" to access adding/editing languages and the Custom Spelling Dictionary.

The Spellcheck context-menu also has a check option for "Check the spelling of text fields", and un-checking this option will completely disable spell checking.

Finally, Spellcheck the context-menu also has a check option for "Ask Google for suggestions", which controls whether internet transfer will be used to get Google spell-correcting suggestions.
-- END QUOTED TEXT --

Sporadic delays of 1-10 seconds in response to both keyboard and mouse input began a few weeks ago, probably w Chrome 53 -- Windows 10 64-bit on Intel. Not seen on Nexus tablet or Samsung Galaxy S7 smartphone. I've tried all the suggestions I can find on Google sites and elsewhere, with no result. It's bad enough that this Chrome user since earliest releases is using MS Edge full-time.
Sign in to add a comment