New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 389380 link

Starred by 39 users

Issue metadata

Status: Archived
Owner: ----
Closed: Aug 21
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Compat



Sign in to add a comment

All tooltips are missing, including alt= tags, title= tags and tooltips for the UI itself, such as tabs

Reported by maxsn...@gmail.com, Jun 26 2014

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

Steps to reproduce the problem:
1. I had problems with updating Chrome
2. Changed the policies to allow automatic updating
3. Re-installed Chrome
4. Everything is working fine
5. Days later, tooltips are suddenly gone

What is the expected behavior?
I hover over a link or image; a tooltip of the title= tag should appear. I hover over a tap; the full title of the tab should appear

What went wrong?
No tooltips appear. They appear in other browser, meaning this is isolated to Chrome.

Did this work before? Yes About two weeks ago

Chrome version: 35.0.1916.153  Channel: stable
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)
Flash Version: Shockwave Flash 14.0 r0

I have tried disabling all plugins, disabled flash, cleaned both my history and cache, done a virus scan, downloaded plugins that are supposed to replace the tooltips with javascript, changed settings, rebooted my computer, tried proxies, checked the elements of pages, and none of these things have worked.
 
I'm having almost the same but without update errors.
Firefox works fine by the way.

Images without a link (<a href=) or with another hover action don't show alt and title tags.
Good site to test: http://www.thetimes.co.uk/.
Tabs, images with a link do show a tooltip.

Issue is at:
Windows Server 2008 R2 - Chrome Version 35.0.1916.153 m
Windows 7 (64 bits) - Chrome Version 36.0.1985.97 beta-m
Windows 7 (64 bits) - Chrome Version 38.0.2071.0 canary (64-bit)

Comment 2 by maxsn...@gmail.com, Jun 27 2014

The update errors I believe was a separate problem. I also just realized tooltips stopped working BEFORE I fixed the update problem. But the update problem started long before the tooltips, and solving that problem did not resolve the other.
I'm having this exact same issue.  I don't know when it started, just noticed it when I was trying to read XKCD. :D

No tooltips whatsoever, except sometimes while the page loads, I will see the tooltip that shows where links go, until the page finishes loading, then it stops. 

And I've never had any update errors... or any other errors for that matter.  And I tried everything like turning off extensions, antivirus, etc.

Chrome version: 35.0.1916.153 m
Windows 7 Pro x64

Labels: Needs-Feedback
Is this working fine in any other browsers? If yes, could you please send screen-shot will help in triage further.

Comment 5 by maxsn...@gmail.com, Jul 4 2014

Yes, it works fine in all other browsers. I'll take a few screenshots. Sadly screenshots seem to hide my cursor. In this screenshot I'm hovering over the youtube icon: http://puu.sh/9Wh2p/3dc721a3e3.jpg
In this one, I am hovering over the third tab: http://puu.sh/9Whdp/d65bea2994.jpg
As you can see here in firefox, I am hovering over the google doodle http://puu.sh/9Whij/9ac9878d9f.png
Cc: ranjitkan@chromium.org
Unable to reproduce this issue on chrome version 35.0.1916.153 on Windows and MAC os. Please see the attached screen shot, I am hovering it on Youtube. In the screen shots you attached I see you use a theme. Can you please let me know about it so that I can use the same them and give a try.
Tooltip.png
90.1 KB View Download

Comment 8 by Deleted ...@, Jul 9 2014

I just disabled it, and my tooltips are back...So, I guess that was the problem! Thank you so much for the help!

Comment 9 by Deleted ...@, Jul 10 2014

Never mind, it stopped working, again. When I reset my themes, they came back, I installed a new theme, and it still worked. I disabled it, and enabled the old one, and which again disabled them. So I reset and installed the new one again, and it started working. A few hours later, they where once again gone. And now when I hover over a link, the link address in the corner looks all scrambled and weird, as well. Here's a screenshot of what it looks like http://puu.sh/a4Pmj/0be902ad25.png Note the address in the bottom left.

Comment 10 by Deleted ...@, Aug 4 2014

So, I reset my theme and re-installed Chrome. My tooltips came back temporarily, but have again disappeared. They seemingly disappeared after I restarted my computer. So maybe it has something to do with a setting or something that can be changed or reset by a reboot? I am at a loss here. Tooltips are quite essential to my browsing, so this is getting very annoying. And I have yet to find any solution, or decent temporary standing for this feature yet.
Tooltips broken for me too on Windows 8.1 x64. Tried clearing cache/ disabling extentions/ incognito mode and all the usual steps. Doesn't work. Tooltips in Firefox work ok.
#11 valentin: what theme do you use for Chrome?
Default theme.
It is happening to me, too. No idea how to reproduce it. I'm using Windows 7 x64 but I tried it in more computers not just mine (including one with windows 8) and it is happening too. Also try it in incognito mode, clearing cache, restarting computer but it doesn't fix. In all of them I'm using default theme.Chrome version 39.0.2171.71 m

Comment 15 by Deleted ...@, Dec 12 2014

happening to me here doesn't show tooltip or full text on hover of twitch streams

Comment 16 by Deleted ...@, Mar 23 2015

I'm getting this issue as well. Running Windows 7 x64.

If I open the program or open a new tab the tooltip will function as normal for a very brief period of time, but once it disappears the first time (as it normally does when you stop mousing over) it does not return.

This will repeat every time I open a new tab or window - tooltip works for a few seconds, then shuts off. No extensions active.
Also having this problem, Version 42.0.2311.135 m, running Windows 7.
isshikik...@gmail.com, do you have the default theme? Please follow this link and report back if the problem still occurs or not:
https://support.google.com/chrome_webstore/answer/1053348
Yes, I have the default theme.
Update: Disabling my extensions did not help.

Comment 21 by maxsn...@gmail.com, May 16 2015

So, I reinstalled my browser not long after submitting this. That fixed the problem. I then reinstalled my OS, but now, just a few days ago, my tooltips are gone again.
Tooltips are working again mysteriously during typical browsing. Made no change to settings. No idea what has changed in system.
issihik, Chrome Stable has recently been updated to version 43. Maybe that did the trick?
Perhaps. Anyone still experiencing this problem?

Comment 25 Deleted

Comment 26 by maxsn...@gmail.com, May 26 2015

I still have this problem

Comment 27 by Deleted ...@, May 26 2015

I have this problem on dropdown lists, tooltips are not showing for the options.  Same script works in Mozilla and IE but not Chrome.  
And you two have been updated to version 43?

Comment 29 by Deleted ...@, May 27 2015

Version 43.0.2357.81 and no tooltip for me too (on dropdown lists). Default theme. I noticed this problem last week with version 42.
Do you get tooltips everywhere else they are supposed to be? (Images, links?)

Comment 31 by Deleted ...@, May 28 2015

It seems so. Dropdowns are the only consistent problem.
I've been having this issue for at least a month now, but haven't bothered reporting since I figured it would eventually sort itself out.  I'm on Debian Jessie 64bit with chrome 43.0.2357.65 using the Gtk Theme.

Extensions don't seem to be the cause since I can't get the alt text to pop on xkcd in an incognito window.  However, on an interesting side note, my chrome is synced between another Linux machine and an OSX machine, and both of those do not have issues with tooltips making it that much less likely that it's extension related.

I'm updating to chrome 43.0.2357.81-1 right now so we'll see if that does the trick...

Comment 33 by Deleted ...@, Jun 2 2015

We're seeing this too on Chrome on Windows... works on Mac. Here's a test 
http://jsfiddle.net/aaekdggu/

Comment 34 by Deleted ...@, Jun 2 2015

Try this one. On Chrome Windows, the select tooltip works, but not the option.
http://jsfiddle.net/aaekdggu/1/

Comment 35 by Deleted ...@, Jun 3 2015


tried http://jsfiddle.net/aaekdggu/1/

tooltips are not visible.

(linux - debian 8 - Chrome Version 43.0.2357.81 (64-bit))


P.S.
tooltips do work over multi-select <option> elements
(but do not work for single-select <option> elements)

Also tried http://jsfiddle.net/aaekdggu/1/

Tooltip for select was visible but not for the options

Comment 37 Deleted

Comment 38 by Deleted ...@, Jun 4 2015

I'm having the same issue. Tool tips are visible for the select dropdown but not for the options in the dropdown. Any workaround or fix in progress?

Comment 39 Deleted

Comment 40 by Deleted ...@, Jun 9 2015

HI Team,
I'm having the same issue. Tool tips are not visible  for the options in the dropdown while it is working for FF and IE browser. Any workaround or fix in progress?
Please find attachment for your reference.
ToolTipIssue.png
8.5 KB View Download
Have exakt the same issue (Chrome 43.0.2357.81, Win 7 64bit). Title in regular a-tags will not shown as tooltip. See sample here: https://www.marks-gmbh.de/Praezisionsflachstahl-Katalogabmessungen.html
Tooltips are not working in the "option" of the dropdown. It works for the "select".
And Strangely, it works in the Chrome on MAC but not on windows

I am using Chrome latest version 43.0.2357.124

Comment 43 by Deleted ...@, Jun 19 2015

Version 43.0.2357.125 (64-bit)

 Tooltips work on all elements except select->options

Works in IE and FF
Tooltips (even a title on an image) appear to no longer work in  46.0.2490.80 m.

See xkcd.com for an example.

Works as expected in FF.
Having same issue, all tooltips are gone. Any title attributes do not show up. It has been this way for several months. I have even uninstalled chrome, ran cc cleaner and wiped any reference of chrome from my registry, cleared all local settings files for chrome. I updated both video drivers and updated chrome to beta, same issue.

Version 47.0.2526.73 beta-m (64-bit)
Windows 7 Ultimate 64bit

Works fine in every other browser.
Can confirm the issue after 46.0.2490.80 m, running Windows 8.1 Enterprise.

Works fine in IE. Tooltips don't work, even the ones in the UI.
Tooltips via the title attribute stopped working fo me about 6 months ago.
Today, my Chrome updated to 47.0.2526.111 m.
Still not working.

Tested with the following code - all work with IE and none with Chrome:

<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">

<body>
Original <span style="color:inherit;font-size:inherit;" title="Att:307 

Def:429">1 Radiator</span>

<p>
<span title="Hover text">Hello World</span>
<p>

<span title="Att:307 Def:429" style="color:inherit;font-size:inherit;" 

>1 Radiator</span>



<p>
<select>
<option title="option 1">1- option one</option>
<option title="option 2">2- option two</option>
<option title="option 3">3- option three</option>
<option title="option 4">4- option four</option>
</select>



</body>
</html>


Project Member

Comment 48 by sheriffbot@chromium.org, Mar 9 2016

Labels: -Needs-Feedback Needs-Review
Owner: rponnada@chromium.org
Status: Assigned (was: Unconfirmed)
Thank you for providing more feedback. Assigning to requester "rponnada@chromium.org" for another review.

For more details visit https://sites.google.com/a/chromium.org/dev/issue-tracking/autotriage - Your friendly Sheriffbot
Cc: -ranjitkan@chromium.org ligim...@chromium.org
Components: -UI UI>Browser
Labels: -Needs-Review Needs-Bisect M-52
Owner: ----
Status: Untriaged (was: Assigned)
Thanks for the testcase, I am able to reproduce this issue in latest windows canary - 52.0.2718.0. Attached the testcase for trying a bisect.

Works fine in Firefox.

sample.html
584 bytes View Download
Labels: -Type-Bug Type-Compat
Cc: durga.behera@chromium.org
Labels: Needs-Feedback
Unable to reproduce the issue on Win 7 using canary 52.0.2718.0 and even on latest canary 52.0.2719.0 and stable 50.0.2661.87.
Could you please review the attached screen cast and let us know if any thing missed here.
389380_April_28.mp4
486 KB Download
Go ahead and close - latest Chrome Version 50.0.2661.94 m or maybe Adobe Flash resolved the issue.


maxsnall@ : Could you please update the thread if the issue still persist.

Comment 54 by netha...@gmail.com, May 18 2016

I am still having issues with tooltips not showing up. I can't recall them showing up at all on this system.

Version 50.0.2661.102 m
Running Windows 10 Pro x64, no custom skin.

Comment 55 by kir...@gmail.com, May 18 2016

BTW: tooltips absence can be caused by incorrect WinAPI behaviour on
some multi-monitor configurations.

2016-05-18 10:13 GMT+03:00 netham45@gmail.com via Monorail
<monorail@chromium.org>:

Comment 56 by netha...@gmail.com, May 18 2016

Then that's probably it. Anything to avoid in specific? I've got a fairly complex setup.

Comment 57 by kir...@gmail.com, May 18 2016

Have no idea. It is an invincible ancient bug of many faces. Deep
debugging needed.

2016-05-18 10:53 GMT+03:00 netham45@gmail.com via Monorail
<monorail@chromium.org>:

Comment 58 by netha...@gmail.com, May 18 2016

Tooltips work in Edge and IE and on pretty much every other app. Just not in Chrome.
Labels: -Needs-Bisect
netham45@ : Could you please help providing the complete Setup and Url details along with their steps to reproduce it.
Removing Needs-Bisect till we have a repro steps to triage further.
Project Member

Comment 60 by sheriffbot@chromium.org, Jun 1 2016

Labels: -M-52 M-53 MovedFrom-52
Moving this nonessential bug to the next milestone.

For more details visit https://www.chromium.org/issue-tracking/autotriage - Your friendly Sheriffbot

Comment 61 by kir...@gmail.com, Jul 4 2016

Hmm... Looks like tooltips began to work fully correct in the actual version of Chrome (mine is 51.0.2704.106 m).
I've got 5 monitors at varying resolutions. I commonly disable 4 of them leaving just the TV enabled, if that matters. I call the same .exe that hitting Win+P on 'Extend' and 'Only Monitor One' run.

Here is how my screens are laid out: 
http://i.imgur.com/3fIGWaz.png 
1:3840x2160
2-4:1920x1080
5:1680x1050

As far as Chrome, I've completely wiped Chrome's appdata to get a clean install to no avail. I'm just trying to get a Tooltip to show on an XKCD comic.

I'm currently on Win 10 Pro Insider 14352, but the bug has been present on all versions.
Forgot to mention, monitors 1,2,3 are on an Nvidia GTX 970 while 4,5 are on an Intel HD Graphics 3000.

Comment 64 by kir...@gmail.com, Jul 5 2016

Oops. I've forgot to state that I'm using Win7 x64 on a notebook with external display.
Restarted Chrome several times. Tooltips are still working. 
Project Member

Comment 65 by sheriffbot@chromium.org, Jul 19 2016

Labels: -M-53 MovedFrom-53
This issue has been moved once and is lower than Pri-1. Removing the milestone.

For more details visit https://www.chromium.org/issue-tracking/autotriage - Your friendly Sheriffbot

Comment 66 by edo...@gmail.com, Aug 3 2016

On Windows 10 x64, version 52.0.2743.116 m,

No tooltips shown (title, alt). Tooltips shown for link in the bottom of the page is displayed only if press mouse button (either left or right) on them.

This is very frustrating since some components I've been using to develop software rely heavily on tooltips (like toolbar icons, action buttons, all wihtout a caption)
Issue is still present in Version 53.0.2785.116 m.
updated to 64-bit Chrome.Version 53.0.2785.143 m (64-bit)
no more tooltips! terrible!
Windows 10 x64 BTW
Version 54.0.2840.99 m on Windows 8.1, most obviously displayed as a lack of the punchline in XKCD comics :)

Comment 71 by p...@eirikh.no, Dec 2 2016

Was just updated to 55.0.2883.75 m from 54.0.2840.99 m on Win8.1. Having the same issue, no tooltips on title="" or img alt="" tags.
I am also now experiencing the tooltips missing issue. I've done everything to try to get them back to no avail. Right about the time it stopped working I added a whole bunch of extensions: so many that the address bar shrunk down to the minimum size and the extension icons overflowed into the 3-dots menu. I think this is what caused the tooltips to disappear. There must be a switch that is changed when this happens?
I confirm this very frustrating bug that break important feature made to provide information to user: no tooltip at all over html element with title attribute. It works as intended in any other software and browser like Firefox or Edge.

Every Chromium based browsers (as Portable/Standalone version too) I tested with clean profile and system are affected:

- Vivaldi 1.5 and up (last stable version based on chromium 55.0.2883.98)
- IronPortable 51 and up (last stable version based on chromium 55.0.2900.1)
- Last Chrome 55.0.2883

My setup: 

- Windows 10 Professionnel ‎(X64)‎ 1607
- NVidia GPU (drivers up to date)
- One screen plugged in DVI port

See details here: http://www.driverscloud.com/en/configuration/43489792-1/summary-gigabyte-technology-co-ltd-x79-ud3-xx

You can easily test the title attribute in those site:
- http://portal.covenant.edu/title_test.html
- http://codepen.io/freMea/pen/mOYqLd
- Your own local html page contenting : https://bugs.chromium.org/p/chromium/issues/attachmentText?aid=232812

I hope this very chromium specific old bug will be solved. It makes browsing experience on some site very bad.
I made further test with old version of IronPortable started from version 10.0.650.1. http://download1.srware.net/old/iron/win/portable

Some old x64 builds don't work on my system. So I suggest you test with x86 builds.

Tooltips work perfectly on my sytem to version 31.0.1700.0.

It suddenly stops to work from v.32.0.1750.0.

So this bug is 3 years old. Happy birthday '^_^

Hope this help to find the culprit.
The bug is inconsistent. Yesterday, I reboot my desktop PC to see if it could solve it to no avail. Today, I just get my PC out of sleep and now tooltips are working with last chromium based browsers. Nothing else I could be aware of have been changed since my previous tests. Odd !

I think it is still worth investigating what could cause this chromium specific bug since v.32 because I didn't find out any workaround to solve it yet.
More details.

Again, I lost tooltip display in chromium after reboot. Since last time it returned to normal after a sleep/awake PC, I decided to investigate more about that before doing it again. 

I try those things to no avail:
- Software: Refresh shell (with nircmd)
- Software: Refresh system (with nircmd)
- Software: Restart explorer
- Hardware: Restart screen monitor

Then, I switch my screen monitor with display port cable. It did the trick. When I revert to the DVI connection, tooltip were still there. But after reboot, tooltip were lost again at least until some processes start.

Finally, I found the culprit that make my chromimum tooltip invisible: a skin from rainmeter, a program that display information on the desktop.

Solution just make sure that position of every loaded skin is NOT set to "stay topmost".

Voilà !

But still, why has it become problematic since v32 and only chromium is affected? 

So, if you have invisible tooltip, try to stop some background processes and see.

Hope it helps.
I figured out why my tooltips were missing!!  It was because of WINAMP's
S7Reflex Skin. After choosing a different skin all my tooltips came back!!
Thanks for the clue to look at skins and to close programs one at a time
until the tooltips re-appeared.
Hi, my tooltips in Chrome are also sometimes missing, and I've figured out it's related to TeamViewer.

If I connect to a computer in TeamViewer, or changes focus to/from the TeamViewer window a few times, almost always the tooltips in Chrome disappear. Once I then disconnect from the remote computer in TeamViewer, the tooltips are instantly back.
I can reproduce this issue with TeamViewer.  Surprisingly, it happens on one machine with Aero disabled and doesn't on the machine with Aero enabled.

Firefox and Edge are not affected irrespective of TeamViewer connection running or not.
I'm able to reproduce this issue at will with Chrome v58 on Linux (Ubuntu 16.04).

Basically when the tool-tips stops working after some sort of partial re-draw operation, if I switch tabs in Chrome, they start working again. 

See attached video that includes URLs and such to reproduce the issue yourselves.
chrome_v58_title_tooltip_bug.ogv
5.3 MB View Download
Status: Archived (was: Untriaged)
Archiving old bugs that haven't been actively assigned in over a year.

If you feel this issue should still be addressed, feel free to reopen it or to file a new issue. Thanks!

Sign in to add a comment