New issue
Advanced search Search tips

Issue 387 link

Starred by 9 users

Issue metadata

Status: Duplicate
Owner: ----
Closed: Oct 2008
Components:
EstimatedDays: ----
NextAction: ----
OS: All
Pri: 2
Type: Bug

Restricted
  • Only users with Commit permission may comment.



Sign in to add a comment

Google Finance - Flash Hangs Browser (5 to 10 Seconds)

Reported by andrewre...@gmail.com, Sep 3 2008

Issue description

Product Version      : 0.2.149.27 (1583)
URLs (if applicable) : http://finance.google.com/finance?q=goog
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
    Firefox 3:OK
         IE 6:OK

What steps will reproduce the problem?
1. Open the link
2. Open Task Manager (for monitoring processes)
2. Mouse over the flash chart in random fashion (over chart and off chart)
3. Browser will spike to 100% CPU and the browser will hang for several 
seconds in which you will either not be able to move the mouse or will not 
be able to interact with any other tab.

What is the expected result?


What happens instead?


Please provide any additional information below. Attach a screenshot if 
possible.
 
 
Chrome-GoogleFinance-Hang.JPG
143 KB View Download

Comment 1 by Deleted ...@, Sep 4 2008

This seems to happen to every flash enabled video site for me. YouTube, for example, hangs for several seconds 
and the Browser does spike to a high CPU Usage when this happens.

Also this is not a one time thing, it seems to do it a few times depending on how much flash video it has to load. 
It is not continuous though, it spikes up and then drops back down to normal for a few seconds before spiking 
up again.

Comment 2 by ninke...@gmail.com, Sep 4 2008

I can confirm this.  It happens especially on flash video sites like YouTube.

It happens on my single-core (Athlon 64) desktop at home, but not my dual core (Core 
2 Duo) desktop at work.  I'm not sure if it has anything to do with intel/amd, or 
single/dual core, but it's a reliable and consistently reproducible bug on my AMD64 
box.

Others have reported this here:

http://groups.google.com/group/google-chrome-help-
troubleshooting/browse_thread/thread/41167ad92159468/3bd58339eafa50b8?
hl=en&lnk=gst&q=freeze#3bd58339eafa50b8

Comment 3 by ninke...@gmail.com, Sep 4 2008

civ2boss:

Next time this behavior happens, could you try right-clicking on Chrome's entry in 
the Windows task bar, and see if that un-freezes Chrome?  Doing this consistently un-
freezes Chrome for me, and others in the post I linked to above say it fixes it for 
them (temporarily, at least.  It still will happen again, but doing this seems to un-
freeze it.)
andrewreiss/ninkendo: Can you please give us full details of your system
configuration and the flash version you have(go to about:plugins)?

Thanks.
OS: XP Pro SP3
Shockwave Flash 9.0 r115
chrome-about.JPG
31.8 KB View Download
Labels: -Area-Unknown Area-Plugins
andrewreiss: Can you please upgrade the flash version to
9.0.124.0(http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash)
and see if it works?
I upgraded to 9.0.124.0 and the problem persists. See the Attachment.
stillHangs.JPG
198 KB View Download
I haven't seen it hang on a Dual Core machine, but it does hang on a single core 
Athlon 2500+ XP Pro SP3 with 2GB RAM.

Comment 9 by Deleted ...@, Sep 13 2008

I have the same problem. I happens in all kinds of flash applications such as youtube
and certain ads, but it's most aggravating when using google finance. It happens when
scrolling anywhere on the page of a particular stock, when I mouse over a chart or if
I scroll in a chart. It also happens on youtube but mostly when I scroll. The Browser
process will spike at 100% CPU for 10's of seconds, then go back to normal until I
touch the chart again. It may also freeze when going back to the previous page from
the chart.

I'm experiencing this on my home PC as well as my work laptop, both running win XP
SP2 and Flash player version 9.0.124.0. The laptop is an intel centrino 1.86 GHz and
the home PC is an AMD 64 3200+. The laptop is running McAfee Antivirus while the home
PC is running AVG. I am NOT experiencing it on my dads Core2Duo laptop where chrome
is running smoothly. I am also not experiencing the problem in Firefox 3 or IE 7.

Comment 10 by emiku...@gmail.com, Sep 14 2008

Same problem when playing a Flash game.  Occasionally the top item in Chrome's task 
manager ("Page: Browser") shoots up to 100% CPU and the whole browser freezes up for 
several seconds.

Doesn't happen on a Core 2 Duo, does happen on a single-core P4.

Finding the 100% CPU process in Windows's Task Manager and setting its priority to 
"Below Normal" (as suggested in one of the many dupes of this bug report) fixes this 
issue on the single-core computer.  Not only does the browser remain responsive but 
the CPU use doesn't stay pegged at 100% for several seconds.
Status: Untriaged
Several flash objects use significant CPU, for many users this 'hits their ceiling.'
Same problem here,
CPU: Athlon XP mobile 1 core 2500+

main process starts hanging (1-12seconds) whenever a flash is running.
hanging (100% CPU) thread: "chrome.exe+0x229e8" lots of context switches
stack:
ntoskrnl.exe!ExReleaseResourceLite+0x206
ntoskrnl.exe!ProbeForWrite+0x505
ntoskrnl.exe!ZwYieldExecution+0xb78
ntdll.dll!KiFastSystemCallRet
USER32.dll!GetLastInputInfo+0x105
chrome.dll+0x9556
chrome.dll+0x8b58
chrome.dll+0x8a36
chrome.dll+0x8972
chrome.dll+0x4f48a4
chrome.dll+0x5e6137
chrome.dll+0x5e61dc

hangs on tab switch, page scrolling, seems random but only when flash is running.
Having pandora running in a tab makes stuff pretty bad...
some more thoughts:
I don't think it is a problem of the PC not being fast enough for the flash, as the 
Process containing the Flash does work as expected. Only the Browser UI seems to be 
affected.
update:

I tried ninkendo's suggestion:
"Next time this behavior happens, could you try right-clicking on Chrome's entry in 
the Windows task bar, and see if that un-freezes Chrome?  Doing this consistently un-
freezes Chrome for me, and others in the post I linked to above say it fixes it for 
them (temporarily, at least.  It still will happen again, but doing this seems to un-
freeze it.)"

and this seems to help make chrome respond immediately

Comment 15 by Deleted ...@, Sep 22 2008

Has anyone reproduced the issue with the Flash Player 10 RC from Adobe Labs:
http://labs.adobe.com/technologies/flashplayer10/ 

Comment 16 by Deleted ...@, Sep 23 2008

Installing Flash Player 10 RC seems to have alleviated the problem for me.

Comment 17 by Deleted ...@, Sep 24 2008

I spoke too soon, the problem is not fixed by Flash Player 10 RC.

I've noticed that this occurs after a pop-up from a flash page. Specifically, 
Pandora.com triggers the freeze behavior every time it tries to pop-up a window. 
Right-clicking the chrome entry in the taskbar does bring back Chrome's UI 
responsiveness for me when this occurs.

Comment 18 by Deleted ...@, Sep 27 2008

It just happened to me as well. Chrome does not even show the 'sad tab' and freezes 
up instantaneously. Ironically, it actually happened during me browsing Google 
Finance site. Apparently it doesn't like the flash plug-in or something. My disk 
usage shot up along with my CPU usage spike. Google, please do something about this. 

Comment 19 by Deleted ...@, Sep 27 2008

same thing happens here.  Celeron Mobile laptop running windows vista basic.  any fix 
yet?

Comment 20 by Deleted ...@, Sep 28 2008

Same problem here. I'm running Windows XP SP3 and Flash version 9.0.124.0.

Comment 21 by Deleted ...@, Sep 28 2008

My chrome randomly freezes aswell, on opening youtube and pdf files
Labels: -area-plugins Area-WebKit Plugins
Deprecate Area-Plugins label in favor of Area-WebKit and a separate Plugins 
label (reducing number of Area- labels).
"Me too".  All Flash sites can occasionally lock browser UI; Google Finance seems 
particularly egregious.
Status: Duplicate
This is a duplicate of  issue 772 , which has been fixed. The fix will be in 0.3 and 
released to the dev channel soon. A fix for all Beta users should be available in a 
few weeks.

Comment 25 by Deleted ...@, Oct 9 2008

With such a LARGE bug like this, I would have expected it to be patched quicker than
"a few weeks".
I use google finance religiously, and have just started getting used to chrome.  Not
releasing this makes me pick one or the other.
Back to firefox for me, I'll check it out in a few months after you've fixed some of
the major bugs.
This is going on in Firefox too. I was having this issue with Google Finance using
FireFox 3.5. I am searching for the problem and find this site with you all talking
about Chrome doing this. Well I dont use Chrome and its going on in Firefox.
This is going on in Firefox too. I was having this issue with Google Finance using
FireFox 3.5. I am searching for the problem and find this site with you all talking
about Chrome doing this. Well I dont use Chrome and its going on in Firefox.

Comment 28 by Deleted ...@, Aug 31 2010

I'm experiencing this issue at my Internet Explorer version 6.0 at work and previously it was working perfectly fine. It appears to have an issue with the Interactive chart that goes nuts for a bit and then freezes IE.

Comment 29 Deleted

Project Member

Comment 30 by bugdroid1@chromium.org, Oct 12 2012

Labels: Restrict-AddIssueComment-Commit
Owner: ----
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Project Member

Comment 31 by bugdroid1@chromium.org, Mar 11 2013

Labels: -Area-WebKit Cr-Content
Project Member

Comment 32 by bugdroid1@chromium.org, Apr 6 2013

Labels: -Cr-Content Cr-Blink

Sign in to add a comment