New issue
Advanced search Search tips
Starred by 2 users

Issue metadata

Status: WontFix
Owner:
Closed: Aug 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment
link

Issue 385171: Chrome Canary reported "Egads! Installation failed. Error code: 0xa0430721."

Reported by msw@chromium.org, Jun 16 2014 Project Member

Issue description

My Win7 Canary installation wouldn't upgrade today, so I uninstalled it.
(I didn't record the failure code, sorry)

I downloaded a new setup binary and attempted to re-install.
http://www.google.com/intl/en/chrome/browser/canary.html
That failed with "Egads! Installation failed. Error code: 0xa0430721."

I can't find that resource string in codesearch, or other useful info.
It was an intermittent issue, but hope we could link to more info.
A Google search for that string didn't bring up any great Chrome info.
 

Comment 1 by sorin@chromium.org, Jun 16 2014

The error is coming from Omaha: https://code.google.com/p/omaha/source/browse/trunk/base/error.h?r=109

#define GOOPDATE_E_FAILED_TO_GET_LOCK_UNINSTALL_PROCESS_RUNNING  \
    MAKE_OMAHA_HRESULT(SEVERITY_ERROR, 0x721)

It indicates that somehow Omaha was uninstalling at the time an install was called. Therefore, the install error out since it could not acquire the necessary locks.

Comment 2 by sorin@chromium.org, Jun 16 2014

Owner: sorin@chromium.org

Comment 3 by msw@chromium.org, Jun 16 2014

D'oh it might even be more obvious than I thought... I attempted to re-install Chrome Canary very soon after un-installing it (maybe 30s). After running uninstall, "Google Chrome Canary" was still in the uninstall programs list until I clicked the refresh there. Perhaps I just didn't wait long enough, to then attempt re-installation.

Comment 4 by sorin@chromium.org, Jun 16 2014

This is most likely the result of a race condition between Google Update uninstalling itself when the Chrome Canary was uninstalled, and the install of the new Chrome Canary.

Comment 5 Deleted

Comment 6 Deleted

Comment 7 by Deleted ...@, Apr 17 2015

go to run and type regedit and erase all google 1.find it in hkey_current_user and go to software youll find google there 2 and hkey_local_machine got to sofware scroll down and just find google and delete it and try  reinstalling it hope it works

Comment 8 by Deleted ...@, Jun 15 2015

Just kill all Google processes from all users then run the installer.

Comment 9 by jamescam...@gmail.com, Aug 15 2015

Its worked for me.. great!!!!!!!!!!!!

Comment 10 by sorin@chromium.org, Aug 17 2015

Status: WontFix

Sign in to add a comment