Project: chromium Issues People Development process History Sign in
New issue
Advanced search Search tips
Starred by 45 users
Status: Duplicate
Merged: issue 572763
Owner:
Closed: Jan 2016
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Chrome
Pri: 2
Type: Feature



Sign in to add a comment
USB Monitor with Chromebook
Reported by debbie.c...@gmail.com, May 31 2014 Back to list
UserAgent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.114 Safari/537.36

Steps to reproduce the problem:
1. Not supported
2. 
3. 

What is the expected behavior?
Unable to connect USB Monitor to Chromebook

What went wrong?
Nothing worked

Did this work before? No 

Chrome version: 35.0.1916.114  Channel: stable
OS Version: OS X 10.7.5
Flash Version: Shockwave Flash 13.0 r0

Would be great to have the ability to use a portable monitor connected by USB with a Chromebook as HDMI is not supported by portable monitors as standard.
 
Comment 1 Deleted
Comment 2 Deleted
Labels: Cr-OS-Kernel
Comment 4 by Deleted ...@, Sep 26 2014
Ditto. Please add this usb video support
Comment 5 by zevan...@gmail.com, Sep 29 2014
YEs, a usb monitor would be wonderful.
Comment 6 Deleted
Comment 7 Deleted
Comment 8 Deleted
Comment 9 by Deleted ...@, Dec 1 2014
This would be the final piece in my workflow.
Please. This would save a lot of space in my bag.
aoc usb monitor would be helpful addition to cb
aoc usb monitor would be very useful
Definitely would love this addition
Comment 14 by Deleted ...@, Mar 27 2015
aoc monitor support would be lovely.
Comment 15 by Deleted ...@, Mar 29 2015
Another request for USB monitor support. I can't travel for work with my Chromebook without this feature. 
We are fully integrated into the Google Ecosystem at work, Chromebooks are becoming more popular for the travel folks, but not being able to use thier USB Monitors with them is holding them back. 
Sadly when I bought a chrome book I assumed this would be simple and not an issue at all. I guess I was wrong. Not sure I'll be able to use the Chromebook at all for what I intended.

Darn.
This is very much needed for the possabuility to work with 2 screens on this laptop. If that is possible this would be a possible laptop for a big part of my organisation.
Yes, please make this happen!!!  This would add some real productivity to the Acer C910 and the Chromebook Pixel as well.  Being mobile has become a pipe-dream for me as I am so used to using dual monitors.  The addition of this functionality would let me be fully mobile again!!!  Please, please, please!!!
Comment 20 by Deleted ...@, Jul 24 2015
Please add USB monitor support for AOC type Model e1649Fwu. This would be most helpful. Thank You!
yes, please add USB monitor support
Any updates?
Comment 23 by m...@mikemoran.com, Aug 26 2015
I would be happy to see this support. I have replaced my Windows laptop with a Chromebook and I can only run one of the two monitors I formerly used. I looked into purchasing a Chrombox but I found that they support only two monitors, which doesn't get me anywhere, given that with my Chromebook I have the laptop screen and one other screen already. I want three!
Comment 24 by Deleted ...@, Sep 2 2015
I 24th this motion.  Need it for business trips and presentations to clients.  Lenovo ThinkVision LT1421 14" Portable USB LED Monitor
I need this so much!!!  This would turn my chromebook from a weekend/end of day casual browsing machine into a full work station for me.  Being able to ditch my bulky company laptop and just use this would make me completely mobile and still 100% productive as I am with my day to day pc.
Cc: h...@chromium.org
Labels: Cr-OS-Kernel-Graphics
Status: Untriaged
Comment 27 by Deleted ...@, Nov 25 2015
Why is this not done yet? I need to hook up my 12 aoc usb monitors to my Toshiba  chromebook 2 for a true google cardboardesk immersive  computing experience. cheap surround computing is needed for my survival. Don't murder me by excluding this feature any longer.
Comment 28 by h...@chromium.org, Nov 25 2015
Cc: abodenha@chromium.org marc...@chromium.org zelidrag@chromium.org
Comment 29 by h...@chromium.org, Nov 25 2015
Ok, one thing at a time. There are multiple issues being discussed here.

(1) The main issue is USB monitor support - several specific monitor models are mentioned in comments #20, #24, #27
(2) The secondary issue seems to be supporting >= 3 monitors

For (2) it is already possible to physically connect 2 external monitors to Chrome OS and they would be placed in horizontal extended multi-monitor mode, however the UI for multi-monitor configuration is still ongoing (see  bug 467193 ).

For (1) all Chrome and Chrome OS side work for UDL 2.0 ("DisplayLink', 'Universal DisplayLink') are already implemented as of Chrome OS release 45 (see  bug 238785 ) for all Chromebook and Chromebox devices currently running the Freon graphics stack. This includes all Intel-based devices, the Samsung exynos-based devices and the Rockchip based ARM devices.

The only unsupported devices at the moment are the NYAN and its variants (based on NVIDIA Tegra) -- we are still waiting on graphics driver support, see  bug 478339 .

In addition, it is known that the USB monitor can only run in extended desktop mode. There's another bug open ( bug 463560 ) to support mirroring.

Please add details to the bug (with a complete copy & paste from chrome://version, AND the exact USB monitor model #) if your device is not based on NVIDIA Tegra SOC. 
Comment 30 by j...@techminds.co, Dec 25 2015
I tried an Asus MB168B USB3 external display this morning with my Chromebook Pixel, it didn't work.


Google Chrome	47.0.2526.106 (Official Build) (64-bit)
Revision	0
Platform	7520.63.0 (Official Build) stable-channel samus
Blink	537.36 (@0)
JavaScript	V8 4.7.80.25
Flash	20.0.0.228-r1
User Agent	Mozilla/5.0 (X11; CrOS x86_64 7520.63.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36
Command Line	/opt/google/chrome/chrome --ppapi-flash-path=/opt/google/chrome/pepper/libpepflashplayer.so --ppapi-flash-version=20.0.0.228-r1 --ppapi-flash-args=enable_hw_video_decode=1 --enable-fixed-position-compositing --enable-impl-side-painting --max-tiles-for-interest-area=512 --ui-enable-per-tile-painting --ui-prioritize-in-gpu-process --use-gl=egl --gpu-sandbox-failures-fatal=yes --enable-logging --log-level=1 --use-cras --user-data-dir=/home/chronos --max-unused-resource-memory-usage-percentage=5 --system-developer-mode --login-profile=user --enable-natural-scroll-default --has-chromeos-keyboard --default-wallpaper-large=/usr/share/chromeos-assets/wallpaper/default_large.jpg --default-wallpaper-small=/usr/share/chromeos-assets/wallpaper/default_small.jpg --child-wallpaper-large=/usr/share/chromeos-assets/wallpaper/child_large.jpg --child-wallpaper-small=/usr/share/chromeos-assets/wallpaper/child_small.jpg --guest-wallpaper-large=/usr/share/chromeos-assets/wallpaper/guest_large.jpg --guest-wallpaper-small=/usr/share/chromeos-assets/wallpaper/guest_small.jpg --enable-prefixed-encrypted-media --enterprise-enrollment-initial-modulus=14 --enterprise-enrollment-modulus-limit=18 --vmodule=screen_locker=1,webui_screen_locker=1,*ui/display/chromeos*=1,*ash/display*=1,*ui/ozone*=1,*zygote*=1,*plugin*=2 --login-manager --first-exec-after-boot
Executable Path	/opt/google/chrome/chrome
Profile Path	/home/chronos/u-d146110b6f326b60349a1b72e2418e5814c1b910
Variations	47f591a-3f4a17df
6a89113b-e4b26eb4
6345b824-3d47f4f4
930c120f-ca7d8d80
e950616e-ca7d8d80
7c1bc906-f55a7974
76b48ab8-a2567007
31362330-ca7d8d80
811bc6bc-d93a0620
9e5c75f1-c3641592
f5dd6118-3d47f4f4
f79cb77b-3d47f4f4
3a716e87-3f4a17df
ca65a9fe-91ac3782
4117e878-3d47f4f4
9736de91-ca7d8d80
dbffab5d-ca7d8d80
244ca1ac-4ad60575
3ac60855-486e2a9c
ed1d377-e1cc0f14
75f0f0a0-6bdfffe7
e7e71889-4ad60575
b39ea213-d1372334
bd368a6b-d2c8e0a4
a70306ec-3f4a17df
Comment 31 by h...@chromium.org, Dec 28 2015
Re:#30 Joe - can you briefly describe what happens when you plug in this Asus MB168B monitor? Specifically (1) do you see any error messages / dialog box showing up on your Chromebook Pixel when you plug or unplug the monitor, and (2) do you see anything on the external display at all, whether it is garbled picture, wrong color, or just completely black.
Comment 32 by j...@techminds.co, Dec 29 2015
1) The Chromebook doesn't react at all, no sounds or pop-ups.

2) The external display flashes once and turns on, but it appears to not be receiving any signal and turns itself off shortly after.
Labels: -Pri-2 Pri-1 M-49
Owner: jdufault@chromium.org
Status: Assigned
jdufault@ can you take a look since you've been poking at UDL stuff lately?  Feel free to order a display if you need.
Labels: -Pri-1 -M-49 Pri-2
Turns out the MB168B is a DisplayLink 3 device. We don't support those.
Comment 35 by j...@techminds.co, Jan 4 2016
That's unfortunate. It sounds like there are no plans to support that in the future then?
Mergedinto: 572763
Status: Duplicate
Display over USB using UDL 2.0 currently works. UDL 3.0 support is a WIP.

Merging into  crbug.com/572763  for UDL 3.0 support.
Sign in to add a comment