New issue
Advanced search Search tips
Note: Color blocks (like or ) mean that a user may not be available. Tooltip shows the reason.

Issue 377850 link

Starred by 2 users

Issue metadata

Status: Archived
Owner: ----
Closed: Aug 2015
Cc:
Components:
EstimatedDays: ----
NextAction: ----
OS: Windows
Pri: 2
Type: Bug



Sign in to add a comment

HTML tags at start of edit area and not followed by space corrupt content

Reported by cacycl...@gmail.com, May 27 2014

Issue description

UserAgent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.114 Safari/537.36

Example URL:
All Wikipedias/MediaWiki installations when using the editor wikEd

Steps to reproduce the problem:
1. In an iframe in designmode or a contenteditable container, load code starting with a tag, directly followed by text without a separating space (e.g. "<button>BUTTON</button>text", "<div>DIV</div>text", or "<span></span>text")
2. Delete the edit content (by any method)

What is the expected behavior?

What went wrong?
1. For the BUTTON tag, any subsequent text will start in the middle of the line, not at the beginning
2. For the DIV tag, the DIV becomes an unselectable and undeletable empty tag at the beginning. Any subsequent text will be added inside this DIV tag
3. For the empty SPAN tag, the empty span tag does not get copied when copying the whole text. Also, any space after the empty SPAN tag gets lost. When not at the very beginning of the edit area, the empty tag and the space get copied as expected.

Does it occur on multiple sites: Yes

Is it a problem with a plugin? No 

Did this work before? N/A 

Does this work in other browsers? Yes 

Chrome version: 35.0.1916.114  Channel: stable
OS Version: 6.3
Flash Version: Shockwave Flash 13.0 r0

These bugs are major problem for the Wikipedia editor wikEd and lead to the accumulation of junk at the beginning of the edited text and to the deletion/corruption of content.
 
testcase Chrome tag without spaces at start.html
2.4 KB View Download

Comment 1 Deleted

Comment 2 by cacycl...@gmail.com, May 27 2014

This bug might or might not be related to the following other bugs:

-  Bug 377811 : Empty <button> tag at start of edit area corrupts content
- Webkit 34377 (https://bugs.webkit.org/show_bug.cgi?id=34377): Select-All does not select all content (HTML editor for iframes in designmode)
-  Bug 271445 : A range returned by Selection.getRangeAt() should be identical to a range set by Selection.addRange()

Comment 3 by tkent@chromium.org, May 29 2014

Labels: -Cr-Content Cr-Blink-Editing
Cc: sdayala@chromium.org
Labels: Needs-Feedback
CacycleWP,Thanks for filing the issue.seems to be new feature request ,not sure.Can you please send me the demo video for the above issue,indicating the effected area.What all the other browsers,does it worked with???
Also Can you confirm this is Latest beta:36.0.1985.32 or Latest dev: 37.0.2017.2 if its not a feature request.

Thanks in Advance.
 Issue 377811  has been merged into this issue.

Comment 6 Deleted

sday: no, this is most definitely not a feature request. Please open the  
testcase if you want to see the bug in action. I cannot test beta or dev  
versions.
Status: Available
Repro-ed. Workaround at least for the first example: type one letter, delete again and restart typing would fix the issue it seems.

Comment 9 by Deleted ...@, Nov 17 2014

HELP!  I don't understand a thing you are talking about except when I installed wikied months ago it changed my life (oka, just my editing life) and now it isn't working at all in my editing window.  Here is what I have tried:  uninstall and reinstall on my preferences page.  Install directly to my ?commons.js user page.  Since I don't know what is going on, I can't fix it.  I am willing to share my username and password, which I can of course change when the fix is applied.  Can someone help me???

Bfpage - a befuddled editor on Wikipedia
(Automated-archive) Issue requiring feedback hasn't been modified/ commented on in the last 180 days, please re-open or file a new bug if this is still an issue.
Status: Archived
(Automated-archive) Issue requiring feedback hasn't been modified/ commented on in the last 180 days, please re-open or file a new bug if this is still an issue.

Sign in to add a comment